Subject: Fwd: Message with no Package: tag cannot be processed! (Package: x2gosuspend-session executes with no SESSION_NAME set)

From: Martin Cigorraga <[email-masked]>
Date: Thu, 13 Dec 2012 15:25:14 -0300

On Wed, Dec 12, 2012 at 8:01 AM, Mike Gabriel <
[email-masked]> wrote:

> Package: x2goserver
> Severity: normal
> Tag: moreinfo
>
> User msx on IRC reported the below issues on IRC:
>
> 04:23 < msx> hi all! is anyone else having erratic behaviour of the x2go
> server? I find that from time to time it tends to break leaving my
> previously
>              opened sessions orphan - there's no way to attach to them any
> more. This is the error message i just get while trying to connect with one
> of my
>              sessions running awesomewm:
> 04:23 < msx> "Connection failed Died at /usr/lib/x2go/x2gogetagent line
> 33. Died at /usr/lib/x2go/x2gochangestatus line 35. ERROR: failed to
> suspend session
>              with ID Died at /usr/lib/x2go/x2gochangestatus line 35.
> argument "session_id" missed at /usr/lib/x2go/x2godbwrapper.pm line 575."
> 04:24 < msx> the thing is that the session on the server seems to still be
> alive, it's just the x2go client can't attach to it
>
> @msx: what exact version of X2G Server are you using? The reason for this
> issue can also be in the X2Go client being used. So, what client do you use
> (x2goclient, pyhoca-*) and what version of that client?
>
> Greets,
> Mike
>
>
Hello Mike, thanks for being aware of this issue.
These are the software versions of the x2go software I'm enjoying:
x2goserver 3.1.1.4-2
x2goclient 3.99.2.2-1

Regarding pyhoca-* I was kindly pointed to the x2go website by another IRC
user to learn about it and since it isn't already packaged in my GNU/Linux
distribution (Arch Linux) I was planning to add it; however some errors at
compile time what I don't have the time right now to debug[0] made it
impossible to install & run the application.
Please let me know if you need further feedback from my part.

[0] From the glimpse I gave to the errors it seems it's related to the way
Python 2 is packaged here in Arch, being named /usr/bin/python2 in contrast
to most other distros (and Python 3 /usr/bin/python) and thus breaking
compatibility with all the Python 2 scripts created outside AL. This issue
is really easy to resolve, I just need a couple of free hours to figure it
out and test that everything works okay and then I will pack pyhoca for
Arch.

Subject: Message with no Package: tag cannot be processed! (Package: x2gosuspend-session executes with no SESSION_NAME set)
From: X2Go Bug Tracking System <[email-masked]>
To: Martín Cigorraga <[email-masked]>
Date: Thu, 13 Dec 2012 05:48:02 +0000

Your message didn't have a Package: line at the very first line of the
mail body (part of the pseudo-header), or didn't have a Package: line
at all. Unfortunatly, this means that your message has been ignored
completely.

Without this information we are unable to categorise or otherwise deal
with your problem report. Please _resubmit_ your report to
[email-masked] and tell us which package the
report is for. For help, check out
http://bugs.x2go.org/Reporting.html.

Your message was dated Thu, 13 Dec 2012 02:42:09 -0300 and had
message-id <[email-masked]>
and subject Package: x2gosuspend-session executes with no SESSION_NAME set.
The complete text of it is attached to this message.

If you need any assistance or explanation please contact
[email-masked] and include the the attached
message.

If you didn't send the attached message (spam was sent forging your
from address), we apologize; please disregard this message.

-- 
-1: http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=-1
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: Package: x2gosuspend-session executes with no SESSION_NAME set
From: Martín Cigorraga <[email-masked]>
To: [email-masked]
Date: Thu, 13 Dec 2012 02:42:09 -0300

---------- Forwarded message ----------
From: Martín Cigorraga <[email-masked]>
Date: Thu, Dec 13, 2012 at 1:24 AM
Subject: x2gosuspend-session executes with no SESSION_NAME set
To: [email-masked]

On Wed, Dec 12, 2012 at 8:01 AM, Mike Gabriel <
[email-masked]> wrote:

> Package: x2goserver
> Severity: normal
> Tag: moreinfo
>
> User msx on IRC reported the below issues on IRC:
>
> 04:23 < msx> hi all! is anyone else having erratic behaviour of the x2go
> server? I find that from time to time it tends to break leaving my
> previously
>              opened sessions orphan - there's no way to attach to them any
> more. This is the error message i just get while trying to connect with one
> of my
>              sessions running awesomewm:
> 04:23 < msx> "Connection failed Died at /usr/lib/x2go/x2gogetagent line
> 33. Died at /usr/lib/x2go/x2gochangestatus line 35. ERROR: failed to
> suspend session
>              with ID Died at /usr/lib/x2go/x2gochangestatus line 35.
> argument "session_id" missed at /usr/lib/x2go/x2godbwrapper.pm line 575."
> 04:24 < msx> the thing is that the session on the server seems to still be
> alive, it's just the x2go client can't attach to it
>
> @msx: what exact version of X2G Server are you using? The reason for this
> issue can also be in the X2Go client being used. So, what client do you use
> (x2goclient, pyhoca-*) and what version of that client?
>
> Greets,
> Mike
>
>
Hello Mike, thanks for being aware of this issue.
These are the software versions of the x2go software I'm enjoying:
x2goserver 3.1.1.4-2
x2goclient 3.99.2.2-1

Regarding pyhoca-* I was kindly pointed to the x2go website by another IRC
user to learn about it and since it isn't already packaged in my GNU/Linux
distribution (Arch Linux) I was planning to add it; however some errors at
compile time what I don't have the time right now to debug[0] made it
impossible to install & run the application.
Please let me know if you need further feedback from my part.

[0] From the glimpse I gave to the errors it seems it's related to the way
Python 2 is packaged here in Arch, being named /usr/bin/python2 in contrast
to most other distros (and Python 3 /usr/bin/python) and thus breaking
compatibility with all the Python 2 scripts created outside AL. This issue
is really easy to resolve, I just need a couple of free hours to figure it
out and test that everything works okay and then I will pack pyhoca for
Arch.

---

From: Mike Gabriel <[email-masked]>
Date: Tue, 26 Mar 2013 00:03:00 +0100

tag #82 pending
thanks

Hi Martin,

>> (x2goclient, pyhoca-*) and what version of that client?

A fix for this issue has been committed:
http://code.x2go.org/gitweb?p=x2goserver.git;a=commitdiff;h=163fb7f7d7a35a44cda95fd6fb41a1fc574a9133

The fix will be available in the next major release of X2Go Server  
(4.1.0.0). It will not be cherry-picked into the release/4.0.0.x  
branch, though.

Greets,
Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, rothenstein 5, 24214 neudorf-bornstein
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb