Subject: Bug#818: x2goserver: client-side folder sharing broken on Ubuntu 10.04

From: Mike Gabriel <[email-masked]>
Date: Mon, 16 Mar 2015 10:28:30 +0000

Package: x2goserver
Severity: normal
Version: 4.0.1.19

Hi all,

x2goserver: client-side folder sharing is broken on Ubuntu 10.04 since  
X2Go Server 4.0.1.19.

REASON:
-------

I just discovered that the "timeout" command that we have started  
using in /usr/bin/x2gomountdirs since 4.0.1.19 of X2Go Server is  
normally shipped via the essential .deb package "coreutils". Normally,  
it is not necessary to add dependencies for essential packages.

However, on Ubuntu 10.04, the timeout command is not shipped with the  
coreutils package but with a separate package called "timeout". There  
you have to explicitly install the "timeout" .deb package.

So, basically in X2Go Server's debian/control file we need to add

    timeout | coreutils,

under Depends: of bin:package x2goserver.

However, as Ubuntu 10.04 will reach End of Life probably before the  
next X2Go Server release will come out, I am unsure if we should still  
change this.

Please other devs give feedback,
Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: Mike Gabriel <[email-masked]>
Date: Wed, 21 Nov 2018 20:32:19 +0000

Control: close -1

On  Mo 16 Mär 2015 11:28:30 CET, Mike Gabriel wrote:

> Package: x2goserver
> Severity: normal
> Version: 4.0.1.19
>
> Hi all,
>
> x2goserver: client-side folder sharing is broken on Ubuntu 10.04  
> since X2Go Server 4.0.1.19.
>
> REASON:
> -------
>
> normally shipped via the essential .deb package "coreutils".  
> Normally, it is not necessary to add dependencies for essential  
> packages.
>
> However, on Ubuntu 10.04, the timeout command is not shipped with  
> the coreutils package but with a separate package called "timeout".  
> There you have to explicitly install the "timeout" .deb package.
>
> next X2Go Server release will come out, I am unsure if we should  
> still change this.
>

Ubuntu 10.04 has by far reached EOL. Thus closing this bug report.

Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
mobile: +49 (1520) 1976 148
landline: +49 (4354) 8390 139

GnuPG Fingerprint: 9BFB AEE8 6C0A A5FF BF22  0782 9AF4 6B30 2577 1B31
mail: [email-masked], http://das-netzwerkteam.de

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Wed, 21 Nov 2018 20:40:06 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2goserver package:

#818: x2goserver: client-side folder sharing broken on Ubuntu 10.04

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
818: http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=818
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: Re: [X2Go-Dev] Bug#818: x2goserver: client-side folder sharing broken on Ubuntu 10.04
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Date: Wed, 21 Nov 2018 20:32:19 +0000

Control: close -1

Mike
-- 

DAS-NETZWERKTEAM

Subject: x2goserver: client-side folder sharing broken on Ubuntu 10.04
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Date: Mon, 16 Mar 2015 10:28:30 +0000

Package: x2goserver
Severity: normal
Version: 4.0.1.19

Hi all,

REASON:
-------

    timeout | coreutils,

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy: