Subject: x2goclient freeze after several seconds

From: Jozsef Kozo <[email-masked]>
Date: Mon, 9 Mar 2015 11:28:22 +0100

Package: x2goclient
Version: 4.0.3.1 ( Qt- 4.8.6)

Client OS: Windows 8.1 Enterprise x64
Server OS: CentOS 6.5

Hi all,

I can connect from a client to my server.
I am able to connect but several seconds ~30 my session freeze and x2go ask
me for terminate my session.
Tried with several versions of client, with same issue. Also tried disable
audio, file sharing,clipboard,keyboard settings, and run with administrator
privileges, disable firewall.

This happens even when no other sessions are running on the client machine.

Debug says : http://pastebin.com/837xZS97

I reported this on IRC they told me create ticket cause this can be a bug.

Best,
JK

---

From: Mihai Moldovan <[email-masked]>
Date: Mon, 16 Mar 2015 16:22:34 +0100

On 09.03.2015 11:28 AM, Jozsef Kozo wrote:
> I am able to connect but several seconds ~30 my session freeze and
> x2go ask me for terminate my session.

What server version are you using? This highly sounds like a problem
4.0.1.19 fixed. (Handling failing xsession scripts gracefully.)

Can you test with 4.0.1.19, please?

Mihai

---

From: Jozsef Kozo <[email-masked]>
Date: Tue, 17 Mar 2015 11:32:15 +0100

Hi Mihai,

Is there any way to install x2goserver from yum on CentOS 6.5 with this
version : 4.0.1.19 ? I found several rpm but need a lot of dependencies for
install. Also tried from tarball but with no luck ( install ).

x2goserver:  4.0.1.18
x2goagent:   3.5.0.27
x2goserver-extensions: 4.0.1.16
x2goserver-xsessions:  4.0.1.16

Best,
JK

---

From: Orion Poplawski <[email-masked]>
Date: Tue, 17 Mar 2015 07:36:11 -0600

On 03/17/2015 04:32 AM, Jozsef Kozo wrote:
> version : 4.0.1.19 ? I found several rpm but need a lot of dependencies
> for install. Also tried from tarball but with no luck ( install ).

It's in EPEL testing:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2015-0953/x2goserver-4.0.1.19-1.el6

yum --enablerepo=epel-testing upgrade

Please test and leave feedback.

-- 
Orion Poplawski
Technical Manager                     303-415-9701 x222
NWRA/CoRA Division                    FAX: 303-415-9702
3380 Mitchell Lane                  [email-masked]
Boulder, CO 80301              http://www.cora.nwra.com

---

From: Jozsef Kozo <[email-masked]>
Date: Wed, 18 Mar 2015 09:03:41 +0100

Hi Guys,

Looks like the new version of x2goserver solved the problem.
Awesome community/support .

Thank you all !

Best,
JK

---

From: Mihai Moldovan <[email-masked]>
Date: Wed, 18 Mar 2015 09:13:42 +0100

Control: reassign -1 x2goserver-xsession 4.0.1.18
Control: close -1
Control: fixed -1 4.0.1.19
Control: forcemerge 632 808

> Awesome community/support .

Great news! You're welcome. :)

Closing up.

Mihai