Subject: xinamera extension is broken after update

From: Robert Reich <[email-masked]>
Date: Tue, 24 Feb 2015 16:44:25 +0000 (UTC)

Package: x2goclient
Version: 4.0.3.2-0~800~ubuntu14.04.1

xinamera extension is broken after update.
Windows, panels etc  maximize over two monitors

Linux Mint 17.1 / Mate
x2goclient_4.0.1.1-1ubuntu2_i386.deb still working flawlessly

regards

---

From: Mike Gabriel <[email-masked]>
Date: Wed, 25 Feb 2015 05:05:05 +0000

Hi Robert,

> x2goclient_4.0.1.1-1ubuntu2_i386.deb still working flawlessly

You you sure this is caused by an upgrade of X2Go Client? It is more  
likely that this is a server issue.

On the X2Go Server, please check

   ls -al /usr/lib/nx/X11/Xinerama

and report back what that gives...

The file structure should resemble something like this:

/usr/lib/nx
├── bin
│   ├── nx
│   ├── nxagent
│   ├── nxauth
│   └── nxproxy
└── X11
     └── Xinerama
         ├── libNX_X11.so.6 -> /usr/lib/x86_64-linux-gnu/libX11.so.6
         ├── libNX_Xext.so.6 -> /usr/lib/x86_64-linux-gnu/libXext.so.6
         └── libXinerama.so.1 -> ../../../x86_64-linux-gnu/libNX_Xinerama.so.1

3 directories, 7 files

Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: Robert Reich <[email-masked]>
Date: Mon, 2 Mar 2015 13:53:20 +0000 (UTC)

Hi Mike
Downgrading client  to 4.0.1.1 helps.Server is also x2goserver-4.0.1 (from epel). Maybe problem will solve after epel updates server.Will use old client meanwhile, thank you.
ls -all /usr/lib64/nx/X11/Xineramalrwxrwxrwx  1 root root   29  5. Dez 10:56 libNX_X11.so.6 -> ../../../../lib64/libX11.so.6
lrwxrwxrwx  1 root root   30  5. Dez 10:56 libNX_Xext.so.6 -> ../../../../lib64/libXext.so.6
lrwxrwxrwx  1 root root   22  5. Dez 10:56 libXinerama.so.1 -> ../libNX_Xinerama.so.1

/usr/lib64/nx/
├── bin
│   └── nxagent
├── libXcompext.so.3 -> libXcompext.so.3.5.0
├── libXcompext.so.3.5.0
├── libXcompshad.so.3 -> libXcompshad.so.3.5.0
├── libXcompshad.so.3.5.0
├── libXcomp.so.3 -> libXcomp.so.3.5.0.28
├── libXcomp.so.3.5.0.28
└── X11
    ├── libNX_X11.so.6 -> libNX_X11.so.6.2
    ├── libNX_X11.so.6.2
    ├── libNX_Xcomposite.so.1 -> libNX_Xcomposite.so.1.0
    ├── libNX_Xcomposite.so.1.0
    ├── libNX_Xdamage.so.1 -> libNX_Xdamage.so.1.0
    ├── libNX_Xdamage.so.1.0
    ├── libNX_Xdmcp.so.6 -> libNX_Xdmcp.so.6.0
    ├── libNX_Xdmcp.so.6.0
    ├── libNX_Xext.so.6 -> libNX_Xext.so.6.4
    ├── libNX_Xext.so.6.4
    ├── libNX_Xfixes.so.3 -> libNX_Xfixes.so.3.0
    ├── libNX_Xfixes.so.3.0
    ├── libNX_Xinerama.so.1 -> libNX_Xinerama.so.1.0
    ├── libNX_Xinerama.so.1.0
    ├── libNX_Xpm.so.4 -> libNX_Xpm.so.4.11
    ├── libNX_Xpm.so.4.11
    ├── libNX_Xrandr.so.2 -> libNX_Xrandr.so.2.0
    ├── libNX_Xrandr.so.2.0
    ├── libNX_Xrender.so.1 -> libNX_Xrender.so.1.2.2
    ├── libNX_Xrender.so.1.2.2
    ├── libNX_Xtst.so.6 -> libNX_Xtst.so.6.1
    ├── libNX_Xtst.so.6.1
    └── Xinerama
        ├── libNX_X11.so.6 -> ../../../../lib64/libX11.so.6
        ├── libNX_Xext.so.6 -> ../../../../lib64/libXext.so.6
        └── libXinerama.so.1 -> ../libNX_Xinerama.so.1

Kind regards

Regards 

     Mike Gabriel <[email-masked]> schrieb am 6:05 Mittwoch, 25.Februar 2015:

 Hi Robert,

/usr/lib/nx
├── bin
│   ├── nx
│   ├── nxagent
│   ├── nxauth
│   └── nxproxy
└── X11
    └── Xinerama

3 directories, 7 files

Mike
-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy: