Subject: Bug#796: Ubuntu Server 14.04.2 PPA: Unresolvable Dependencies for x2goserver

From: Joe Gullo <[email-masked]>
Date: Fri, 20 Feb 2015 23:00:35 -0800

Package: x2goserver
Version: 4.1.0.0-0~1214~ubuntu14.04.1

Package: x2goagent
Version: 2:3.5.0.29-0~489~ubuntu14.04.1

Package: nxagent
Version: 2:3.5.0.29-0~505~ubuntu14.04.1

Fully patched ubuntu server 14.04.2 server.  Using the x2go stable PPA.
When trying to install x2goserver, I get the following:

surfrock66@sr66-blade:~$ sudo apt-get install x2goserver x2goagent nxagent
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nxagent : Depends: libxcomp3 (= 2:3.5.0.28-0~481~ubuntu14.04.1) but
2:3.5.0.29-0~591~ubuntu14.04.1 is to be installed
           Depends: libxcompext3 (= 2:3.5.0.28-0~481~ubuntu14.04.1) but it
is not going to be installed
           Depends: libxcompshad3 (= 2:3.5.0.28-0~481~ubuntu14.04.1) but it
is not going to be installed
E: Unable to correct problems, you have held broken packages.
surfrock66@sr66-blade:~$ sudo dpkg -s libxcomp3 | grep Version; sudo dpkg
-s libxcompext3 | grep Version; sudo dpkg -s libxcompshad3 | grep Version
Version: 2:3.5.0.29-0~591~ubuntu14.04.1
Version: 2:3.5.0.29-0~591~ubuntu14.04.1
Version: 2:3.5.0.29-0~591~ubuntu14.04.1

Seems the PPA hosts x2goserver, which depends on x2goagent, which depends
on nxagent, which depends on these 3 libraries being downrevv'd.

Joe Gullo
Web Designer
http://www.surfrock66.com
[email-masked]
(714)926-0336
BTC: 1BsnULNMABRS8nPeMzywkxnfD5ZuRiESxu

---

From: Mihai Moldovan <[email-masked]>
Date: Sun, 14 Aug 2016 00:49:19 +0200

Control: reassign -1 launchpad.net
Control: tag -1 moreinfo

Is this still a problem, or did whatever broke in the repository get fixed
"automatically"?

Mihai

---

From: Mihai Moldovan <[email-masked]>
Date: Mon, 22 Aug 2016 16:32:31 +0200

Control: close -1

> Is this still a problem, or did whatever broke in the repository get fixed

I installed x2goserver successfully in a new 14.04 environment during the
gathering and haven't seen any dependency problems.

I'll be closing this bug report.

If it's still an issue, feel free to reopen this report.

Mihai

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Mon, 22 Aug 2016 14:35:02 +0000

This is an automatic notification regarding your Bug report
which was filed against the launchpad.net package:

#796: Ubuntu Server 14.04.2 PPA: Unresolvable Dependencies for x2goserver

It has been closed by Mihai Moldovan <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mihai Moldovan <[email-masked]> by
replying to this email.

-- 
796: http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=796
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: Re: Ubuntu Server 14.04.2 PPA: Unresolvable Dependencies for x2goserver
From: Mihai Moldovan <[email-masked]>
To: Joe Gullo <[email-masked]>, [email-masked]
Date: Mon, 22 Aug 2016 16:32:31 +0200

Control: close -1

Mihai

Subject: Ubuntu Server 14.04.2 PPA: Unresolvable Dependencies for x2goserver
From: Joe Gullo <[email-masked]>
To: [email-masked]
Date: Fri, 20 Feb 2015 23:00:35 -0800

Package: x2goserver

Package: x2goagent

Package: nxagent

Joe Gullo
Web Designer