Subject: Pyhoca-Gui freezes when connection to desktop

From: "Ja Bi" <[email-masked]>
Date: Thu, 12 Feb 2015 14:13:33 +0100 (CET)

Package: Pyhoca-Gui-0.5.0.3, python-x2go 0.5.0.2, x2goserver-4.0.1.18-r2 
(gentoo)

I tried with lxde and xfce and both do the same. After some time (2-20sec) 
it stops, freeze somehow. You cant move any window, nothing, but when you 
are on a bottom frame of some window, mouse pointer changes(but you cant 
still resize the window)

1.anytime when i connect to server and try to run lxde or xfce session

2.nothing

3.run session smoothly

4.it is frozen

client is updated gentoo linux

server is updated gentoo linux with

nx-3.5.0.28

NXAGENT - Version 3.5.0

*  dev-util/xfce4-dev-tools

      Latest version installed: 4.11.0

*  x11-themes/gtk-engines-xfce

      Latest version installed: 3.0.1-r201

*  xfce-base/libxfce4ui

      Latest version installed: 4.11.1

*  xfce-base/libxfce4util

      Latest version installed: 4.11.0

*  xfce-base/xfce4-appfinder

      Latest version installed: 4.11.0

*  xfce-base/xfce4-meta

      Latest version installed: 4.10

*  xfce-base/xfce4-panel

      Latest version installed: 4.11.1

*  xfce-base/xfce4-session

      Latest version installed: 4.11.0-r2

*  xfce-base/xfce4-settings

      Latest version installed: 4.11.3

 lxde-base/lxde-common

         Latest version installed: 0.5.5-r3

---

From: Mike Gabriel <[email-masked]>
Date: Fri, 13 Feb 2015 08:41:20 +0000

reassign -1 pyhoca-gui

Hi Jan,

> server is updated gentoo linux with

PyHoca-GUI with wxPython 3.0 and python-gevent << 1.0 (strictly less!)  
behaves weirdly.

What wxPython version do you use? What gevent version do you use?

Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: "Ja Bi" <[email-masked]>
Date: Fri, 13 Feb 2015 13:40:49 +0100 (CET)

Does not ring a bell. "reassign" is some command???

---------- Původní zpráva ----------
Od: Mike Gabriel <[email-masked]>
Komu: Ja Bi <[email-masked]>, [email-masked]
Datum: 13. 2. 2015 9:41:24
Předmět: Re: [X2Go-Dev] Bug#788: Pyhoca-Gui freezes when connection to 
desktop

"reassign -1 pyhoca-gui

Hi Jan,

Mike
-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.
xfb"

---

From: Mihai Moldovan <[email-masked]>
Date: Fri, 13 Feb 2015 18:23:06 +0100

> Does not ring a bell. "reassign" is some command???

Yes, it's a command for the Debian Bugtracker. Feel free to ignore it.

Down in his message, Mike asked some questions:
> What wxPython version do you use?
>
> What gevent version do you use?

An answer would be greatly appreciated.

Mihai

---

From: "Ja Bi" <[email-masked]>
Date: Sat, 14 Feb 2015 15:34:29 +0100 (CET)

thanks :)
dev-python/wxpython-3.0.2.0:3.0::gentoo  USE="cairo libnotify opengl -
examples" PYTHON_TARGETS="python2_7"

dev-python/gevent

      Latest version installed: 1.0.1

---------- Původní zpráva ----------
Od: Mihai Moldovan <[email-masked]>
Komu: Ja Bi <[email-masked]>, [email-masked]
Datum: 13. 2. 2015 18:30:20
Předmět: Re: [X2Go-Dev] Bug#788: Bug#788: Pyhoca-Gui freezes when connection
to desktop

Mihai"

---

From: "Ja Bi" <[email-masked]>
Date: Sat, 21 Feb 2015 11:16:48 +0100 (CET)

Second try :(

dev-python/gevent

---------- Původní zpráva ----------
Od: Mihai Moldovan <[email-masked]>
Komu: Ja Bi <[email-masked]>, [email-masked]
Datum: 13. 2. 2015 18:30:20
Předmět: Re: [X2Go-Dev] Bug#788: Bug#788: Pyhoca-Gui freezes when connection
to desktop

Mihai"

---

From: Mihai Moldovan <[email-masked]>
Date: Sat, 21 Feb 2015 16:21:54 +0100

Hi

Sorry for the delay. I've noticed your message the first time around,
but given that gevent is recent enough, I didn't have any additional
information.

I can only suggest to start pyhoca-gui with the additional parameters
--debug and --libdebug to see what is going on (if anything.)

Disclaimer: I have practically no idea of python in general and X2Go's
python code (including pyhoca*) specifically, Mike is probably the best
person to help with that.

Mihai

On 21.02.2015 11:16 AM, Ja Bi wrote:
> Second try :(
>
> dev-python/wxpython-3.0.2.0:3.0::gentoo  USE="cairo libnotify opengl
> -examples" PYTHON_TARGETS="python2_7"
>
> dev-python/gevent
> [...]