Subject: x2go clipboard bug

From: Sergey Savko <[email-masked]>
Date: Wed, 11 Feb 2015 15:11:39 +0400 (MSK)

Package: x2goclient
Version: 4.0.3.2
Severity: normal

x2goclient doesnt work with clipboard properly.
When you copy a file to clipboard and closed a source directory its just disapear from clipboard .
It's with plain text also. 
When you copy to clipboard a part of a text from text document and then closed a text editor, the clipboard will be empty.

-- 
Yours truly,
Sergey Savko.

---

From: Mike Gabriel <[email-masked]>
Date: Wed, 11 Feb 2015 11:49:27 +0000

Control: tag -1 moreinfo

Hi Sergey,

On  Mi 11 Feb 2015 12:11:39 CET, Sergey Savko wrote:

> When you copy to clipboard a part of a text from text document and  
> then closed a text editor, the clipboard will be empty.

isn't that normal X11 behaviour? I experience the same on my locally  
Debian jessie + i3 window manager machine.

In KDE3 there was this klipboard tool (I know you are using KDE4).  
Does something like this exist in KDE4?

I sense that this is no X2Go bug... Right?

Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: Sergey Savko <[email-masked]>
Date: Wed, 11 Feb 2015 16:49:01 +0400 (MSK)

I tried FreeNX on the same server with the same user profile, it works.

Video: http://youtu.be/r-GABBB_APE

----- Исходное сообщение -----
От: "Mike Gabriel" <[email-masked]>
Кому: "Sergey Savko" <[email-masked]>, [email-masked]
Отправленные: Среда, 11 Февраль 2015 г 14:49:27
Тема: Re: [X2Go-Dev] Bug#785: x2go clipboard bug

Control: tag -1 moreinfo

Hi Sergey,

Mike
-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

---

From: Ulrich Sibiller <[email-masked]>
Date: Wed, 11 Feb 2015 21:29:18 +0100

> Video: http://youtu.be/r-GABBB_APE

First, what versions of x2go and FreeNX are you using? In 3.5.0.28 I
habe contributed a fix regarding clipboard handling.

Second, have you tried doing that without klipper running?

And third: please retry that, but this time do NOT use any KDE or qt
application. E.g. use gedit.

Uli

---

From: Sergey Savko <[email-masked]>
Date: Thu, 12 Feb 2015 01:31:44 +0400 (MSK)

1. 
x2go:
x2goserver:amd64/trusty 4.0.1.18-0~949~ubuntu14.04.1
x2goagent:all/trusty 2:3.5.0.27-0~446~ubuntu14.04.1
libnx-x11:amd64/trusty 2:3.5.0.27-0~446~ubuntu14.04.1

nx:
nx_3.4.0-eter16ubuntu_amd64.deb
But it is not installed because of conflicts with package x2go ("nxagent"). I conclude FreeNX uses the same libraries as x2go.

2. Without Clipper bug is also present.

3. Copy from gedit to libreoffice, with closing gedit, bug is present.

Bug is limited not only copying the text, but also copying files. 
If you open a folder in the dolphin and copy the file, after closing the folder, the file on the desktop will not be paste.

----- Исходное сообщение -----
От: "Ulrich Sibiller" <[email-masked]>
Кому: "Sergey Savko" <[email-masked]>, [email-masked]
Отправленные: Среда, 11 Февраль 2015 г 23:29:18
Тема: Re: [X2Go-Dev] Bug#785: Bug#785: x2go clipboard bug

Uli

-- 
Yours truly,
Sergey Savko.

---

From: Sergey Savko <[email-masked]>
Date: Thu, 12 Feb 2015 02:06:01 +0400 (MSK)

To be precise it's not quite FreeNX. This patched FreeNX, called the RX from the company etersoft.
Tomorrow I will try to update and test.

-- 
Yours truly,
Sergey Savko.

----- Исходное сообщение -----
От: "Ulrich Sibiller" <[email-masked]>
Кому: "Sergey Savko" <[email-masked]>
Отправленные: Четверг, 12 Февраль 2015 г 0:34:29
Тема: Re: [X2Go-Dev] Bug#785: Bug#785: x2go clipboard bug

So then try a newer x2go version. You should ensure that nx-libs is 3.5.0.28.

Regarding FreeNX: I am pretty sure nx 3.4.0 did not have that
clipboard problem I fixed in 3.5.0.28.

Uli