Subject: Patch for 782

From: Sergey Savko <[email-masked]>
Date: Fri, 6 Feb 2015 14:38:49 +0400 (MSK)

Tag: patch

X2goclient connected under the old authid.

-- 
Yours truly,
Sergey Savko.

From d4d73e30fb59643749b1a8428a79e4792a76250d Mon Sep 17 00:00:00 2001
From: Sergey_Savko <[email-masked]>
Date: Fri, 6 Feb 2015 13:30:33 +0300
Subject: [PATCH] broker autologoff authid fix

---
 httpbrokerclient.cpp |    4 ++++
 1 file changed, 4 insertions(+)

diff --git a/httpbrokerclient.cpp b/httpbrokerclient.cpp
index 5f009d4..5780cca 100644
--- a/httpbrokerclient.cpp
+++ b/httpbrokerclient.cpp
@@ -242,6 +242,10 @@ void HttpBrokerClient::slotSshUserAuthError(QString error)
 void HttpBrokerClient::getUserSessions()
 {
     QString brokerUser=config->brokerUser;
+    // Otherwise, after logout from the session, we will be connected by a previous user without a password by authid.
+    if (config->brokerAutologoff) {
+        nextAuthId=config->brokerUserId;
+    }
     x2goDebug<<"called getUserSessions: brokeruser: "<<brokerUser<<" authid: "<<nextAuthId;
     if(mainWindow->getUsePGPCard())
         brokerUser=mainWindow->getCardLogin();
-- 
1.7.10.4

---

From: Mike Gabriel <[email-masked]>
Date: Fri, 06 Feb 2015 10:53:36 +0000

Control: tag -1 patch

> X2goclient connected under the old authid.

The patch looks good...

Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb