Subject: Bug#778: Info received and FILED only (Migrating/Closing)

From: "X2Go Bug Tracking System" <[email-masked]>
Date: Thu, 25 Jan 2024 21:55:01 +0000

Thank you for the additional information you have supplied regarding
this Bug report.

This is an automatically generated reply to let you know your message
has been received.

Your message has not been forwarded to the package maintainers or
other interested parties; you should ensure that the developers are
aware of the problem you have entered into the system - preferably
quoting the Bug reference number, #778.

If you wish to submit further information on this problem, please
send it to [email-masked].

Please do not send mail to [email-masked] unless you wish
to report a problem with the Bug-tracking system.

-- 
778: https://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=778
X2Go Bug Tracking System
Contact [email-masked] with problems

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Thu, 25 Jan 2024 21:55:02 +0000

This is an automatic notification regarding your Bug report
which was filed against the nx-libs package:

#778: affected by CVE 2015-0235: Stop using gethosbyname()

It has been closed by Stefan Baur <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Stefan Baur <[email-masked]> by
replying to this email.

Subject: Migrating/Closing
From: Stefan Baur <[email-masked]>
To: [email-masked]
Date: Thu, 25 Jan 2024 22:51:36 +0100

Control: close -1
Control: archive -1

This issue is now being tracked in the Arctica Issue Tracker over on 
Github: <https://github.com/ArcticaProject/nx-libs/issues/1070>

Kind Regards,
Stefan Baur
-- 
BAUR-ITCS UG (haftungsbeschränkt)
Geschäftsführer: Stefan Baur
Eichenäckerweg 10, 89081 Ulm | Registergericht Ulm, HRB 724364
Fon/Fax 0731 40 34 66-36/-35 | USt-IdNr.: DE268653243

Subject: affected by CVE 2015-0235: Stop using gethosbyname()
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Date: Sun, 01 Feb 2015 08:04:41 +0100

Package: src:nx-libs
Severity: important

The NX source code uses gethostbyname() at several locations and is potentially affected by CVE 2015-0235 (GHOST security issue in glibc).

We should move towards using getaddrinfo() asap.

Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976148

GnuPG Key ID 0x25771B13
mail: [email-masked], http://das-netzwerkteam.de