Subject: Bug#775: desktop sharing full screen usability issues

From: Samo Dadela <[email-masked]>
Date: Fri, 30 Jan 2015 10:45:29 +0000

Package: x2goclient (Windows 7 x86)
Version: 4.0.3.0
[ Server: FC21 x64 ]

Hi, 

Found x2go recently as an alternative to NoMachine NX (which is not usable for programming since jpg compression makes terminal windows unusable... and there are other issues like random hangups, etc). 

My use case is as follows: 
- connect to the existing desktop session in full screen (aka desktop sharing in x2go)
- need grab keyboard when connected (example: alt-tab must switch between windows in the session, not between Windows on the client, ctrl-alt-left must switch to another desktop on the server, etc..)
- be able to enter/exit fullscreen mode somehow - by using a hotkey, for example
- be able to see the mouse cursor

In other words... behave as though I was connected to the real desktop on the server.

What I tried:

1) Specifying fullscreen in the Session preferences
What happens: 
- I get a full screen windows, 
- there is no mouse cursor (the mouse works - I see the windows receiving focus)
- When using alt-tab it switches between windows on the client (other combinations are also intercepted by Windows, not the desktop)

2) To make alt-tab work, I tried the instruction at http://www.terheyden.com/blog/?p=202 - (x2go client - getting Alt+Tab to work) by specifying -rootless and -keyhook (don't forget to change the path to VcXsrv.exe otherwise you can't use x2go client anymore without deleting the registry keys; this is an already know bug).
What happens:
- alt-tab works, other keys work (like ctrl-alt-left to switch desktops)
- still no mouse cursor (even tried -swcursor but it doesn't help)
- can't enter/exit full screen... it seems that the combinations ctrl-alt-f are now passed to the server 

3) BTW, tried pyhoca too - but it complains that it needs server 4.1 for desktop sharing ;(

Maybe the above (apart from the mouse cursor) are not bugs but just the way things work...

What I would like:
- changing x2goclient on Windows so that such functionality can be achieved by a few mouse clicks (add a grab keyboard option, define 'exit x2go' hotkey,...)
or... if this is too much work
- some instruction on how to achieve the functionality mentioned above (add it to the FAQ?)

Next I saw some post claiming success using Xming... I'll give that a shot, but wouldn't it be better if x2go handled it by itself?

Best regards, 

Samo

---

From: keely <[email-masked]>
Date: Fri, 19 Jul 2024 09:08:03 +0800 (CST)

Hi,

We are an importer and distributor of coffee and related products, etc, serving HK and Macau. We would like to know more about your company's brands and prices, and hope to have the opportunity to cooperate with you.

Best regards,

Keely

---

From: Kevin <[email-masked]>
Date: Mon, 23 Dec 2024 16:44:38 +0800 (CST)

Good afternoon,

I am an importer from Guangdong, China, I would like to know more about your company and hope that we can have a chance to co-operate, please feel free to ask questions if you have any questions about us.

I look forward to hearing from you soon.

Cheers 

Kevin

---

From: lynne <[email-masked]>
Date: Fri, 27 Dec 2024 11:00:19 +0800 (CST)

Hello, 

I am an importer and wholesaler from China with business in: Mainland China, Macau and Hong Kong. Our company is interested in expanding our sales recently. Hope to have the opportunity to co-operate with your company.

Looking forward to your reply.

Sincerest regards,
Lynne

---

From: Joel Mercier <[email-masked]>
Date: Sat, 10 May 2025 12:31:46 +0000

Dear friend,

I hope this email finds you well.

My name is Mr. Joel Mercier, and I am the CEO of JMH Holdings LLC and Silicate Resources LLC, originally from France but I am based in the US. I am reaching out to explore the possibility of establishing a partnership to pursue profitable investment opportunities in your country.

As part of this venture, I would appreciate it if you could prepare a business proposal within your area of expertise. I will review the proposal and, following a thorough discussion, we can proceed to the next steps in finalizing our partnership.

In addition, since you will be facilitating the introduction to this business, I am entrusting you with the management of the investment portfolio on my behalf. Once we engage in detailed discussions, we can further align our approach and finalize an agreement to guide our collaboration.

For this investment, I have allocated a budget of 70 million USD, and I would welcome your professional advice on how best to allocate and utilize these funds for maximum profitability.

Attached below, a copy of my passport for identity confirmation.

I look forward to reviewing your proposal and discussing the next steps toward a successful partnership.

Best regards,

Mr. Joel Mercier
CEO, JMH Holdings LLC & Silicate Resources LLC
What’sapp: +1 (380) 254-4251

All the best and Sincerely

[✍]

The two most important days in your life are the day you were born and the day you find out why.

- Mark Twain

This e-mail and its attachments may contain Joël Mercier and his companies proprietary information, which is PRIVILEGED, CONFIDENTIAL, or subject to COPYRIGHT belonging to Joel Mercier. This e-mail is intended solely for the use of the individual or entity to which it is addressed.  If you are not the intended recipient of this e-mail, or the employee or agent responsible for delivering this e-mail to the intended recipient, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this e-mail is STRICTLY PROHIBITED and may be UNLAWFUL.

---

From: coray <[email-masked]>
Date: Tue, 30 Sep 2025 13:11:06 +0800 (CST)

Greetings,

As a Guangdong-based FMCG importer, we are interested in gin and related products. Could you share more information about your company？We would like to know more about your brand and would like to establish a relationship with you.

Eagerly await your response.  

Cora

---

From: Qianfan <[email-masked]>
Date: Wed, 21 Jan 2026 16:44:34 +0800 (CST)

Dear Sir/Madam,

Good day,

We are a Chinese importer and distributor, boasting a mature supply chain network covering Shenzhen, Guangzhou, Hong Kong and Singapore. We are writing to inquire about detailed information regarding your company product portfolio and brand positioning. If your offerings align with the categories of our centralized procurement plan, we are eager to explore in-depth cooperation opportunities with your esteemed company.

Best regards,

Qanfan Team

---

From: Qianfan <[email-masked]>
Date: Fri, 23 Jan 2026 14:07:51 +0800 (CST)

Hi,

Hope you doing well!

I would like to learn more about your company and hope to have the opportunity to cooperate.

Best regards,

Qanfan Team

At 2026-01-21 18:40:02, "X2Go Bug Tracking System" <[email-masked]> wrote:
>Thank you for the additional information you have supplied regarding
>this Bug report.
>
>This is an automatically generated reply to let you know your message
>has been received.
>
>Your message is being forwarded to the package maintainers and other
>interested parties for their attention; they will reply in due course.
>
>Your message has been sent to the package maintainer(s):
> X2Go Developers <[email-masked]>
>
>If you wish to submit further information on this problem, please
>send it to [email-masked].
>
>Please do not send mail to [email-masked] unless you wish
>to report a problem with the Bug-tracking system.
>
>-- 
>775: https://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=775
>X2Go Bug Tracking System
>Contact [email-masked] with problems

---

From: Mateus Cardoso Pires <[email-masked]>
Date: Sun, 17 May 2026 01:33:42 +0000

________________________________
De: Mateus Cardoso Pires
Enviado: sábado, 16 de maio de 2026 22:09
Assunto: Certified Mail.

I have a very good deal we can do together, will you be in for it? Contact my email: ([email-masked]) for details.
Thanks.