Subject: X2Go issue (in src:pyhoca-gui) has been marked as closed

From: X2Go Release Manager <[email-masked]>
Date: Thu, 28 Jan 2016 18:33:22 +0100 (CET)

close #769
thanks

Hello,

we are very hopeful that X2Go issue #769 reported by you
has been resolved in the new release (0.5.0.5) of the
X2Go source project »src:pyhoca-gui«.

You can view the complete changelog entry of src:pyhoca-gui (0.5.0.5)
below, and you can use the following link to view all the code changes
between this and the last release of src:pyhoca-gui.

    http://code.x2go.org/gitweb?p=pyhoca-gui.git;a=commitdiff;h=c6680da4cacd7a6c3ce155f4180630abbb4a550a;hp=301225fa55b2ebe503fa4705bbbda119b4a549eb

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:pyhoca-gui.

Thanks a lot for contributing to X2Go!!!

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
X2Go Component: src:pyhoca-gui
Version: 0.5.0.5-0x2go1
Status: RELEASE
Date: Thu, 28 Jan 2016 18:23:00 +0100
Fixes: 689 769 979
Changes: 
 pyhoca-gui (0.5.0.5-0x2go1) RELEASED; urgency=medium
 .
   [ Mike Gabriel ]
   * New upstream version (0.5.0.5):
     - Handle notification the GTK3-way. (Fixes: #769).
     - Catch a wx._core.PyAssertionError (C++ assertion "IsOk()" failed at
       ../src/common/image.cpp(429) in Scale(): invalid image) when
       rendering icons in the published applications menu. (Fixes: #979).
   * debian/control,pyhoca-gui.specs:
     + Pull-in gobject introspection packages for libnotify support.
       Fallback to pynotify (GTK2 based notifcations) only if
       gi.repository.Notify is unavailable. (Fixes: #689).
 .
   [ Mihai Moldovan ]
   * New upstream version (0.5.0.5):
   * debian/control:
     - Drop python-support run-time dependency, add dh-python alternative to
       python-support build dependency.
       Needed at least for unstable, which has no python-support package
       anymore.

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Thu, 28 Jan 2016 17:35:09 +0000

This is an automatic notification regarding your Bug report
which was filed against the pyhoca-gui package:

#769: pyhoca-gui gtk3 support

It has been closed by X2Go Release Manager <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact X2Go Release Manager <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go issue (in src:pyhoca-gui) has been marked as closed
From: X2Go Release Manager <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Thu, 28 Jan 2016 18:33:22 +0100 (CET)

close #769
thanks

Hello,

light+love

---

Subject: pyhoca-gui gtk3 support
From: Orion Poplawski <[email-masked]>
To: [email-masked]
Date: Mon, 26 Jan 2015 14:39:09 -0700

Package: pyhoca-gui
Version: 0.5.0.3

Fedora rawhide is in the process of moving to wxPython 3.0 with gtk3 support.
 This appears to be breaking pyhoca-gui:

/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:40: Warning:
g_boxed_type_register_static: assertion 'g_type_from_name (name) == 0' failed
  from gtk import _gtk
/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:40: Warning:
g_type_set_qdata: assertion 'node != NULL' failed
  from gtk import _gtk
/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:40: Warning: cannot
register existing type 'GtkWidget'
  from gtk import _gtk
/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:40: Warning:
g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE
(instance_type)' failed
  from gtk import _gtk
/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:40: Warning: cannot
register existing type 'GtkBuildable'
  from gtk import _gtk
/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:40: Warning:
g_type_interface_add_prerequisite: assertion 'G_TYPE_IS_INTERFACE
(interface_type)' failed
  from gtk import _gtk
/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:40: Warning:
g_once_init_leave: assertion 'result != 0' failed
  from gtk import _gtk
/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:40: Warning:
g_type_register_static: assertion 'parent_type > 0' failed
  from gtk import _gtk

I believe this is because we are mixing a gtk2 based notify-python module with
the gtk3 wxPython module.  This seems like further impetus to move to a modern
python libnotify interface, either notify2 or gobject introspection Notify.

Code difference for gi appears to be:

diff --git a/pyhoca/wxgui/notify.py b/pyhoca/wxgui/notify.py
index bc49028..85f0d52 100644
--- a/pyhoca/wxgui/notify.py
+++ b/pyhoca/wxgui/notify.py
@@ -22,7 +22,7 @@ import wx
 from x2go import X2GOCLIENT_OS
 from x2go import log
 if X2GOCLIENT_OS in ('Linux', 'Mac'):
-    import pynotify
+    from gi.repository import Notify
 import exceptions
 import basepath

@@ -52,7 +52,7 @@ class libnotify_NotifierPopup(object):
         self._PyHocaGUI = _PyHocaGUI
         self._pyhoca_logger = self._PyHocaGUI._pyhoca_logger

-        if not pynotify.init("PyHocaGUI"):
+        if not Notify.init("PyHocaGUI"):
             raise NotSupportedException

     def prepare(self, context, title=None, text=None, icon=None, timeout=None):
@@ -132,8 +132,8 @@ class libnotify_NotifierPopup(object):

         try:
             if not self._PyHocaGUI.disable_notifications and title and text:
-                n = pynotify.Notification(title, text, icon)
-                n.set_urgency(pynotify.URGENCY_NORMAL)
+                n = Notify.Notification.new(title, text, icon)
+                n.set_urgency(Notify.Urgency.NORMAL)
                 n.set_timeout(timeout)
                 n.show()
         except:

Although with that change, unless I comment out the set_urgency() call, I
don't see the message "SSH key authentication has been successful." pop-up
above the pyhoca-gui icon.  But perhaps the new behavior is proper.

-- 
Orion Poplawski
Technical Manager                     303-415-9701 x222
NWRA, Boulder/CoRA Office             FAX: 303-415-9702
3380 Mitchell Lane                       [email-masked]
Boulder, CO 80301                   http://www.nwra.com