Subject: Bug#767: X2Go issue (in src:pyhoca-gui) has been marked as closed

From: Mike DePaulo <[email-masked]>
Date: Sun, 25 Jan 2015 18:13:05 +0100 (CET)

close #767
thanks

Hello,

we are very hopeful that X2Go issue #767 reported by you
has been resolved in the new release (0.5.0.4) of the
X2Go source project »src:pyhoca-gui«.

You can view the complete changelog entry of src:pyhoca-gui (0.5.0.4)
below, and you can use the following link to view all the code changes
between this and the last release of src:pyhoca-gui.

    http://code.x2go.org/gitweb?p=pyhoca-gui.git;a=commitdiff;h=3292f07f23bdc1028cc393839515109307735edf;hp=301225fa55b2ebe503fa4705bbbda119b4a549eb

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:pyhoca-gui.

Thanks a lot for contributing to X2Go!!!

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
X2Go Component: src:pyhoca-gui
Version: 0.5.0.4-20150125
Status: RELEASE
Fixes: 767
Changes: 
 pyhoca-gui (0.5.0.4-20150125) RELEASED; urgency=medium
 .
   [ Mike DePaulo ]
   * Windows Build Process & Dependencies
     - Update paramiko from upstream 1.5.2 to our modified
       version, 1.15.2.1, which has the fix for upstream
       bug #461 applied.
       This fixes PyHoca-GUI's support for Pageant (the ssh agent.)
       (Fixes: #767)

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Sun, 25 Jan 2015 17:15:02 +0000

This is an automatic notification regarding your Bug report
which was filed against the pyhoca-gui package:

#767: PyHoca-GUI with Pageant: An unknown error occurred during authentication

It has been closed by Mike DePaulo <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike DePaulo <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go issue (in src:pyhoca-gui) has been marked as closed
From: Mike DePaulo <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Sun, 25 Jan 2015 18:13:05 +0100 (CET)

close #767
thanks

Hello,

light+love

---

Subject: PyHoca-GUI with Pageant: An unknown error occurred during authentication
From: Michael DePaulo <[email-masked]>
To: "[email-masked]" <[email-masked]>
Date: Sun, 25 Jan 2015 11:31:15 -0500

Package: pyhoca-gui
Version: 0.5.0.3-20150124
tags +win32

When attempting to connect to a server using Pageant ("Discover SSH
keys or use SSH agent for X2Go authentication"), you get this error:
An unknown error occurred during authentication

This is a regression between 0.5.0.0-pre02 (the previous build) and
0.5.0.3-20150124 (the current build.) I've attached the debug logs.
(On Windows, logs are under %AppData%\pyhoca-gui\ )

0.5.0.0-pre02 bundles paramiko 1.14.0.
0.5.0.3-20150124 bundles paramiko 1.15.2
This appears to be a regression in paramiko, #461:
https://github.com/paramiko/paramiko/issues/461
@ThiefMaster's commit fixes the issue fine. The paramiko maintainer
seems to be away, so it has not been merged yet.

I will release a new build of PyHoca-GUI with the paramiko commit applied.