Subject: RE: Segfault of QDialog in a PyQt application

From: PAILLAT Olivier SOPRA GROUP <[email-masked]>
Date: Thu, 22 Jan 2015 10:07:26 +0000

Package: client
Version: 4.0.3.0
Qt 4.8.6

When we run our PyQt application on our Debian Wheezy computer with an ssh -X connection it work fine
But when we use X2Go to access the computer and we run our application we've got a segmentation fault at the first QDialog opening. (when we run QDialog.exec_).
We recently update the X2Go version and before that update it was working fine.
We found at least one post that describe the same problem in January 2014 on your bug report site :
X2Go Bug report logs - #410
Segfault of _X11TransWritev in libNX_X11.so.6 with libQtGui

Like suggested in this report  if we run a simple application to test an opening of a dialog box it work fine with X2Go

>From your experience of this bugs is there any way to solve this problem ?

Sincerely,

Olivier PAILLAT
Agence STIE Sud-Est

[Sopra Steria]

Sopra Steria
780 rue Guillibert de la Lauzière
Pichaury 2 - CS 40496
13593 Aix-en-Provence Cedex 3 - France
Phone: +33 (0)4 42 25 71 46
[email-masked]<mailto:[email-masked]> - www.soprasteria.com<http://www.soprasteria.com>

Le contenu de cet e-mail est susceptible d'être confidentiel, soumis au secret professionnel ou protégé par la loi. L'utilisation, la copie et la divulgation non autorisées d'une partie ou de l'intégralité de ce message sont susceptibles d'être illégales. Si vous avez reçu ce message par erreur, supprimez-le après avoir averti l'expéditeur. Les pièces jointes du présent e-mail ont fait l'objet d'un contrôle antivirus. Néanmoins, nous déclinons toute responsabilité concernant les dommages causés par d'éventuels virus.
Pensez à l'environnement avant d'imprimer.

---

From: Mike Gabriel <[email-masked]>
Date: Thu, 22 Jan 2015 12:52:55 +0000

Control: reassign -1 x2goclient
Control: reassign #758 x2goclient
Control: reassign #760 x2goclient
Control: merge -1 #758
Control: merge -1 #760
Control: tag -1 build-win32
Control: tag -1 moreinfo

Hi Olivier,

On  Do 22 Jan 2015 11:07:26 CET, PAILLAT Olivier SOPRA GROUP wrote:

> But when we use X2Go to access the computer and we run our  
> application we've got a segmentation fault at the first QDialog  
> opening. (when we run QDialog.exec_).
> Like suggested in this report  if we run a simple application to  
> test an opening of a dialog box it work fine with X2Go
>

Please send us a little Python snippet that lets your PyQt application crash.

I am currently working on the NX code tree, so your timing for  
submitting this bug is quite good, right now.

Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: Mike Gabriel <[email-masked]>
Date: Thu, 22 Jan 2015 12:56:16 +0000

Control: reassign -1 nxagent

> [ ... ]

> Segfault of _X11TransWritev in libNX_X11.so.6 with libQtGui

This is actually an issue in nxagent (aka x2goagent), not X2Go Client.  
So reassigning.

Mike

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

---

From: PAILLAT Olivier SOPRA GROUP <[email-masked]>
Date: Thu, 22 Jan 2015 14:47:12 +0000

Hello,

Thank you for your answer.
I have made a simple python application (see the tar.gz attached) that reproduce the problem
You will need PyQt4 to run it

The command is simple 
python gui.py

if it work it open a QDialog nearly empty
If you reproduce the bug you will end with a segmentation fault with a very brief QDialog opening

Actually we have some doubts about our environment and we won't be surprised if you don't reproduce the bug with your PyQt4
But we want to close some of the paths of explanation of our bug and since it occurs only with X2Go we submit it to you

Regards

Olivier PAILLAT
Agence STIE Sud-Est

Sopra Steria
780 rue Guillibert de la Lauzière
Pichaury 2 - CS 40496
13593 Aix-en-Provence Cedex 3
France
Phone: +33 (0)4 42 25 71 46
[email-masked] - www.soprasteria.com

-----Message d'origine-----
De : Mike Gabriel [mailto:[email-masked]] 
Envoyé : jeudi 22 janvier 2015 13:53
À : PAILLAT Olivier SOPRA GROUP; [email-masked]
Objet : Re: [X2Go-Dev] Bug#757: Segfault of QDialog in a PyQt application

Hi Olivier,

On  Do 22 Jan 2015 11:07:26 CET, PAILLAT Olivier SOPRA GROUP wrote:

> Package: client
> Version: 4.0.3.0
> Qt 4.8.6
>
> When we run our PyQt application on our Debian Wheezy computer with an 
> ssh -X connection it work fine But when we use X2Go to access the 
> computer and we run our application we've got a segmentation fault at 
> the first QDialog opening. (when we run QDialog.exec_).
> Like suggested in this report  if we run a simple application to test 
> an opening of a dialog box it work fine with X2Go
>

I am currently working on the NX code tree, so your timing for submitting this bug is quite good, right now.

Mike

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

---

From: Mike Gabriel <[email-masked]>
Date: Fri, 15 May 2015 13:33:26 +0000

Control: forcemerge #875 -1

Hi Olivier,

On  Do 22 Jan 2015 15:47:12 CET, PAILLAT Olivier SOPRA GROUP wrote:

> Actually we have some doubts about our environment and we won't be  
> surprised if you don't reproduce the bug with your PyQt4
> But we want to close some of the paths of explanation of our bug and  
> since it occurs only with X2Go we submit it to you
>
> Regards

Sorry for getting back so late. We are currently working on the  
nx-libs 3.6.x release and I have just tested your GUI example under  
the development version of nx-libs.

The issue seems to be fixed there. I will merge this bug into #875  
which is the tracking bug for the nx-libs 3.6.x upgrade in X2Go.

Mike

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy: