Subject: Bug#752: x2go windows client garbles local audio

From: "Hopkins, Bill" <[email-masked]>
Date: Tue, 20 Jan 2015 18:22:54 +0000

Package: X2Go Client

Version: V.4.0.2.0 (Qt - 4.8.5)

There was no error message associated with the problem.

To bring on the problem, all I have to do is start the X2Go client; it does not require me connecting to a server.

I am listening to streaming audio on my laptop, with the audio going to a speaker system with subwoofer. When I start up the X2Go client, it switches the audio output device to the lame laptop speakers. I can make the audio go back to the nice speakers by unplugging the audio cable and plugging it back in. However, the sound is then slight distorted; the level of distortion varies periodically, and it becomes so bad that the music is almost completely replace by static.

The laptop is running Windows 7 Professional (it remains up-to-date via Microsoft Tuesday Patches). The laptop is a Dell Studio 1558, with a quad-core i5 processor, 8 GB memory, 256GB SSD.

Since the problem occurs without a connection, the version of the server software is irrelevant.

Two connections are configured, both with audio disabled (which is why I'm wondering why the client is messing with the audio at all).

By the way, I tried using reportbugs on my server, but Ubuntu takes umbrage, and I didn't think you wanted the report sent to Debian (which is what it seems to want me to do). So I used the email option.

Thanks! Great product. Most responsive remote desktop product I've used.

---

From: Mike Gabriel <[email-masked]>
Date: Tue, 20 Jan 2015 21:08:27 +0000

Control: reassign -1 x2goclient
Control: found -1 4.0.2.0
Control: tag -1 build-win32

On  Di 20 Jan 2015 19:22:54 CET, Hopkins, Bill wrote:

> To bring on the problem, all I have to do is start the X2Go client;  
> it does not require me connecting to a server.
>
> I am listening to streaming audio on my laptop, with the audio going  
> to a speaker system with subwoofer. When I start up the X2Go client,  
> it switches the audio output device to the lame laptop speakers. I  
> can make the audio go back to the nice speakers by unplugging the  
> audio cable and plugging it back in. However, the sound is then  
> slight distorted; the level of distortion varies periodically, and  
> it becomes so bad that the music is almost completely replace by  
> static.
>
> The laptop is running Windows 7 Professional (it remains up-to-date  
> via Microsoft Tuesday Patches). The laptop is a Dell Studio 1558,  
> with a quad-core i5 processor, 8 GB memory, 256GB SSD.
>
> Two connections are configured, both with audio disabled (which is  
> why I'm wondering why the client is messing with the audio at all).
>
> By the way, I tried using reportbugs on my server, but Ubuntu takes  
> umbrage, and I didn't think you wanted the report sent to Debian  
> (which is what it seems to want me to do). So I used the email option.
>

Please try how things behave with a newer version of X2Go Client. If  
possible, try these two versions:

latest release:
http://code.x2go.org/releases/binary-win32/x2goclient/releases/4.0.3.1-20150119/x2goclient-4.0.3.1-20150119-setup.exe

development snapshot:
http://code.x2go.org/releases/binary-win32/x2goclient/heuler/mingw32-4.8/qt-4.8/x2goclient-4.0.3.2-2015.01.20-ee7265d-setup.exe

Thanks,
Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: "Hopkins, Bill" <[email-masked]>
Date: Tue, 20 Jan 2015 21:46:55 +0000

The latest release fixed two problems - the audio issue AND the use of monitor selector to make it come up in the proper monitor.

Danke schoen! (can't do umlaut with plain text)

Bill Hopkins

-----Original Message-----
From: Mike Gabriel [mailto:[email-masked]] 
Sent: Tuesday, January 20, 2015 2:08 PM
To: Hopkins, Bill; [email-masked]
Subject: Re: [X2Go-Dev] Bug#752: x2go windows client garbles local audio

On  Di 20 Jan 2015 19:22:54 CET, Hopkins, Bill wrote:

> To bring on the problem, all I have to do is start the X2Go client; it 
> does not require me connecting to a server.
>
> it switches the audio output device to the lame laptop speakers. I can 
> make the audio go back to the nice speakers by unplugging the audio 
> cable and plugging it back in. However, the sound is then slight 
> distorted; the level of distortion varies periodically, and it becomes 
> so bad that the music is almost completely replace by static.
>
> via Microsoft Tuesday Patches). The laptop is a Dell Studio 1558, with 
> a quad-core i5 processor, 8 GB memory, 256GB SSD.
>
> Two connections are configured, both with audio disabled (which is why 
> I'm wondering why the client is messing with the audio at all).
>

Please try how things behave with a newer version of X2Go Client. If possible, try these two versions:

latest release:

development snapshot:

Thanks,
Mike

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

---

From: Mike Gabriel <[email-masked]>
Date: Tue, 20 Jan 2015 21:58:59 +0000

Control: fixed -1 4.0.3.1
Control: close -1

On  Di 20 Jan 2015 22:46:55 CET, Hopkins, Bill wrote:

> The latest release fixed two problems - the audio issue AND the use  
> of monitor selector to make it come up in the proper monitor.
>

Bitte schön (welcome)! (Thanks to Michael DePaulo's meticulous work on  
the pulseaudio stuff in X2Go).

Mike

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Tue, 20 Jan 2015 22:00:02 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2goclient package:

#752: x2go windows client garbles local audio

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
752: http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=752
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: Re: [X2Go-Dev] Bug#752: x2go windows client garbles local audio
From: Mike Gabriel <[email-masked]>
To: "Hopkins, Bill" <[email-masked]>
Cc: [email-masked]
Date: Tue, 20 Jan 2015 21:58:59 +0000

Mike

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

Subject: x2go windows client garbles local audio
From: "Hopkins, Bill" <[email-masked]>
To: "[email-masked]'" <[email-masked]>
Date: Tue, 20 Jan 2015 18:22:54 +0000

Package: X2Go Client

---

From: Michael DePaulo <[email-masked]>
Date: Wed, 21 Jan 2015 20:36:37 -0500

On Tue, Jan 20, 2015 at 1:22 PM, Hopkins, Bill <[email-masked]> wrote:
> Package: X2Go Client
>
> Version: V.4.0.2.0 (Qt – 4.8.5)
>
> I am listening to streaming audio on my laptop, with the audio going to a
> speaker system with subwoofer. When I start up the X2Go client, it switches
> the audio output device to the lame laptop speakers. I can make the audio go
> back to the nice speakers by unplugging the audio cable and plugging it back
> in. However, the sound is then slight distorted; the level of distortion
> varies periodically, and it becomes so bad that the music is almost
> completely replace by static.
>
> The laptop is running Windows 7 Professional (it remains up-to-date via
> Microsoft Tuesday Patches). The laptop is a Dell Studio 1558, with a
> quad-core i5 processor, 8 GB memory, 256GB SSD.
>
> Two connections are configured, both with audio disabled (which is why I’m
> wondering why the client is messing with the audio at all).
>
> By the way, I tried using reportbugs on my server, but Ubuntu takes umbrage,
> and I didn’t think you wanted the report sent to Debian (which is what it
> seems to want me to do). So I used the email option.
>
> Thanks! Great product. Most responsive remote desktop product I’ve used.
[...]

Hi Bill,

Thanks, and sorry you ran into this issue.

It sounds like PulseAudio is causing this problem.
(X2Go Client for Windows 4.0.2.0 & later bundle PulseAudio 5.0.)
With X2Go Client for Windows 4.0.2.0, pulseaudio.exe is started as
soon as you launch X2Go Client.
With X2Go Client for Windows 4.0.3.1, pulseaudio.exe is started once
you actually launch a session that uses audio.
Of course, that change wouldn't actually fix the problem (unless you
never use audio.)

I would like you to do the following to collect more output from PulseAudio:
1. Install the latest debug build of X2Go Client for Windows
http://code.x2go.org/releases/binary-win32/x2goclient/releases/4.0.3.1-20150119/non-default-builds/
2. Reproduce the problem by starting a session with audio enabled.
3. Look in the folder %USERPROFILE%\.x2go\pulse . You should see 1 or
more folders with random names like "tmp.Hp8872". Open up the newest
folder, and you should see the file "pulse.log". Reply back with that
file attached.

-Mike#2

---

From: Michael DePaulo <[email-masked]>
Date: Wed, 21 Jan 2015 21:07:34 -0500

Ignore my last email.

I am not sure what fixed it, but I am glad the latest release fixed it
for you. :)

-Mike#2