Subject: new DebBugs scripts: mbox / cleanbug

From: Mike Gabriel <[email-masked]>
Date: Sat, 20 Feb 2016 08:51:49 +0000

Hi all,

last night, I created to new scripts for the debbugs software  
underneath bugs.x2go.org.

Both scripts are attached and can be found under /usr/lib/debbugs on  
host ymir.das-netzwerkteam.de.

Especially the cleanbug script should be of interested here.

I recently received various abuse notifications from my provider and  
they all relate to X2GO bugs containing mails with virus attachments.  
These need to be cleaned.

I already did so for the reported URLs:

http://bugs.x2go.org/128
http://bugs.x2go.org/232
http://bugs.x2go.org/496
http://bugs.x2go.org/765

But there are more...

Please coordinate in the X2Go core team, who will work on cleaning up  
the X2Go bugtracker. Currently, these people have access:

   Heinz
   Mihai
   Mike

You have to log into ymir.das-netzwerkteam.de (aka bugs.x2go.org) as  
user locadm and become root via sudo.

The cleanbug script itself is easy to handle:

   # /usr/lib/debbugs/cleanbug <bugno>

Once you triggered the script, you have to look at bug posts on the  
selected bug and say yes and no.

At the end you get asked, if you really want to write back the changes  
to the bug. The answer's question defaults to "no".

You should create some back before manipulating existing bugs. For  
this, create copies of <bugno>.log in /var/lib/debbugs/spool/db-h/

Note for archived bugs: for cleaning up archived bugs, you have to  
unarchive them first.

Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/mailxchange/kronolith/fb.php?u=m.gabriel%40das-netzwerkteam.de

---

From: Stefan Baur <[email-masked]>
Date: Sat, 20 Feb 2016 16:41:01 +0100

> underneath bugs.x2go.org.

Thank you for your effort!
(/me hand out an attaboy certificate)

> Please coordinate in the X2Go core team, who will work on cleaning
> up the X2Go bugtracker. Currently, these people have access:
> 
> 
> Heinz Mihai Mike

I've pinged h1 regarding this, I guess he'd be the best choice ATM,
with Mihai and Mike#1 still being pretty busy with real life things,
from what I've heard.

- -Stefan

- -- 
BAUR-ITCS UG (haftungsbeschränkt)
Geschäftsführer: Stefan Baur
Eichenäckerweg 10, 89081 Ulm | Registergericht Ulm, HRB 724364
Fon/Fax 0731 40 34 66-36/-35 | USt-IdNr.: DE268653243

---

From: Stefan Baur <[email-masked]>
Date: Sat, 20 Feb 2016 16:45:47 +0100

Am 20.02.2016 um 16:41 schrieb Stefan Baur:

> Thank you for your effort! (/me hand out an attaboy certificate)

s/hand/hands/

> I've pinged h1 regarding this, I guess he'd be the best choice
> ATM, with Mihai and Mike#1 still being pretty busy with real life
> things, from what I've heard.

s/Mike#1/Mike#2/
(though it probably applies to Mike#1 as well, else he wouldn't have
posted this)

Sorry, ENOTENOUGHCAFFEINE and distracted.

- -Stefan

- --

---

From: Mike Gabriel <[email-masked]>
Date: Sat, 20 Feb 2016 19:57:56 +0000

Hi Stefan,
(dropping x2go-project list from Cc: as BTS posts to it anyway for  
message arriving at #751)

> Sorry, ENOTENOUGHCAFFEINE and distracted.

I am currently going through open/closed bugs of nx-libs. While doing  
that, I am transferring all relevant bugs to the Github issue tracker  
of nx-libs [1].

I will see if I can handle bug reports against python-x2go, pyhoca-*  
and x2gobroker.

The rest is on you guys.

@Stefan: if you send me a public key, I can give you access to  
[email-masked] and you can happily clean up spam/viruses from  
BTS. The more we / you share the workload the better.

Also, please agree on someone who takes care of future spamming of bugs.

Please note that the BTS now has a dual antivirus software protection  
(Sophos AV + ClamAV). Also the SpamAssassin daemon has been configured  
to be more strict and drop all mails with X-Spam-Index >= 2.0.

Greets,
Mike
-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

---

From: Mihai Moldovan <[email-masked]>
Date: Wed, 24 Feb 2016 02:48:23 +0100

> I already did so for the reported URLs:

Further bugs processed:

http://bugs.x2go.org/98 (archived)
http://bugs.x2go.org/11
http://bugs.x2go.org/323
http://bugs.x2go.org/343
http://bugs.x2go.org/711
http://bugs.x2go.org/120
http://bugs.x2go.org/723
http://bugs.x2go.org/227
http://bugs.x2go.org/342
http://bugs.x2go.org/248
http://bugs.x2go.org/252
http://bugs.x2go.org/670
http://bugs.x2go.org/884
http://bugs.x2go.org/99

These were only the "biggest offenders", though (i.e., bugs with a mailbox size
higher than 1 MB.)

A simple grep for 'Interfax' reveals a lot more of affected bug reports...

Mihai

---

From: Mike Gabriel <[email-masked]>
Date: Wed, 24 Feb 2016 10:07:43 +0000

Hi all,

> A simple grep for 'Interfax' reveals a lot more of affected bug reports...

I just checked all python-x2go bugs:

CLEAN-UP DATE: 20160224
#954 open - clean
#190 open - de-spammed
#809 open - clean
#324 open - clean
#392 open - clean
#648 open - clean
#691 open - clean
#335 closed archived clean
#508 closed archived clean
#167 closed archived clean
#334 closed archived clean
#588 closed archived clean
#130 closed archived clean
#162 closed archived clean
#192 closed archived clean
#194 closed archived clean
#283 closed archived clean
#307 closed archived clean
#329 closed archived clean
#330 closed archived clean
#358 closed archived clean
#497 closed archived clean
#500 closed archived clean
#532 closed archived clean
#537 closed archived clean
#602 closed archived clean
#658 closed archived clean

Mike
-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

---

From: Mihai Moldovan <[email-masked]>
Date: Thu, 25 Feb 2016 18:36:45 +0100

Mike

Since you changed debbugs a bit, submitted bug reports do not show up on
x2go-dev anymore (if filed by addresses not also subscribed to x2go-dev), but
instead hit the moderation queue.

Previously, forwarded mails were not bounced by the mailing list. Any idea what
might have changed?

Nihai

---

From: Mihai Moldovan <[email-masked]>
Date: Wed, 10 Aug 2016 07:50:16 +0200

Further bugs processed:

http://bugs.x2go.org/914
http://bugs.x2go.org/28
http://bugs.x2go.org/465
http://bugs.x2go.org/109
http://bugs.x2go.org/503
http://bugs.x2go.org/688
http://bugs.x2go.org/373
http://bugs.x2go.org/480
http://bugs.x2go.org/667
http://bugs.x2go.org/369
http://bugs.x2go.org/775
http://bugs.x2go.org/483
http://bugs.x2go.org/837
http://bugs.x2go.org/343
http://bugs.x2go.org/120
http://bugs.x2go.org/711
http://bugs.x2go.org/323
http://bugs.x2go.org/31