Subject: X2Go Client: broker access -> zero conf

From: Mike Gabriel <[email-masked]>
Date: Fri, 16 Jan 2015 13:44:12 +0000

Package: x2goclient
Severity: wishlist

Just discussed an idea with Stefan on VideoChat. How about providing  
code in X2Go Client that tries to auto-detect local network broker  
setups automatically (zeroconf X2Go Client).

Approaches would be:

   o retrieve the domain's SRV records and check if special records for
     X2Go Broker setups can be found
   o use a similar approach like browsers use for wpad.dat
   o make this configurable in X2Go Client settings

Mike + Stefan

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: Michael DePaulo <[email-masked]>
Date: Sun, 25 Jan 2015 13:03:04 -0500

On Fri, Jan 16, 2015 at 8:44 AM, Mike Gabriel
<[email-masked]> wrote:
> Package: x2goclient
> Severity: wishlist
>
> Just discussed an idea with Stefan on VideoChat. How about providing code in
> X2Go Client that tries to auto-detect local network broker setups
> automatically (zeroconf X2Go Client).
>
> Approaches would be:
>
[...]

2 other local network options are:

 o "zeroconf" (Avahi/Bonjour)
 o SSDP/UPnP.

https://en.wikipedia.org/wiki/Avahi_(software)

https://en.wikipedia.org/wiki/Simple_Service_Discovery_Protocol

However, on Windows at least, firewalls are likely to block them.

-Mike#2