Subject: Bug#742: [X2Go-Dev] Bug#742: Bug#742: Executing parec seems unnecessary now that X2Go Client for Windows 4.0.3.0 uses PulseAudio 5.0

From: Michael DePaulo <[email-masked]>
Date: Sat, 24 Jan 2015 19:11:48 -0500

Control: close -1 4.0.3.2

On Sat, Jan 24, 2015 at 6:30 PM, Michael DePaulo <[email-masked]> wrote:
[...]
>> On  Mi 14 Jan 2015 20:05:46 CET, George Trakatelis wrote:
>>
>>>[...]
>>>
>>> The attached patch saves x2goclient from calling slotStartParec()
>>> once per second unnecessarily.
>> thanks for providing this patch, George.
>
> Thanks!
>
> I'll test the patch for regressions. If there are none, I will commit it.
> (I will however delete that 1 line rather than comment it out.)

I tested it successfully on XP 32-bit and on Windows 8.1 64-bit. So I
applied it (after deleting that one commented out line.)

Also, I did not bother to update the changelog because I feel this is
a very minor change, and I do not want to bombard users with too many
details in the changelog. I will confirm on x2go-project that doing so
is OK.

Thanks,

-Mike#2

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Sun, 25 Jan 2015 00:15:02 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2goclient package:

#742: Executing parec seems unnecessary now that X2Go Client for Windows 4.0.3.0 uses PulseAudio 5.0

It has been closed by Michael DePaulo <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Michael DePaulo <[email-masked]> by
replying to this email.

-- 
742: http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=742
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: Re: [X2Go-Dev] Bug#742: Bug#742: Executing parec seems unnecessary now that X2Go Client for Windows 4.0.3.0 uses PulseAudio 5.0
From: Michael DePaulo <[email-masked]>
To: [email-masked], George Trakatelis <[email-masked]>
Date: Sat, 24 Jan 2015 19:11:48 -0500

Thanks,

-Mike#2

Subject: Executing parec seems unnecessary now that X2Go Client for Windows 4.0.3.0 uses PulseAudio 5.0
From: "George Trakatelis" <[email-masked]>
To: <[email-masked]>
Cc: "'Michael DePaulo'" <[email-masked]>
Date: Wed, 14 Jan 2015 21:05:46 +0200

Package: x2goclient
Version: 4.0.3.0

When trying to figure out why I get 
'Object::connect: No such slot ONMainWindow::slotSndTunOk(int)' 
in the debugging output of X2Go Client for Windows 4.0.3.0, 
I bumped onto a common error: 
Argument mismatch between function call and function definition. 
That prevents slotSndTunOk() from ever executing. 

slotStartParec() depends on slotSndTunOk() to execute parec. 
Executing parec was needed due to a PulseAudio's bug as explained in 
http://x2go-dev.x2go.narkive.com/wNgRoxTO/parec

One peculiar thing is that after fixing that mismatch, 
which enabled parec to execute, 
x2goclient became extremely sluggish. 
The only way to revert things back to normal 
was to prevent parec from ever executing. 
It seems that parec in not needed now that X2Go Client uses PulseAudio 5.0.

Dept. of Applied Informatics, University of Macedonia
George Trakatelis