Subject: Bug#722: Fwd: [Bug 1179869] New: [abrt] x2goclient: ref(): x2goclient killed by SIGSEGV

From: Orion Poplawski <[email-masked]>
Date: Wed, 07 Jan 2015 10:56:36 -0700

Package: x2goclient
Version: 4.0.2.1

This crashing here:
x2goSession ONMainWindow::getSessionFromString ( const QString& string )
{
    QStringList lst=string.split ( '|' );
    x2goSession s;
    s.agentPid=lst[0];
    s.sessionId=lst[1];

looks like the session string is corrupted and doesn't have the expected
number of elements.  Need some error checking here.

-------- Forwarded Message --------
Subject: [Bug 1179869] New: [abrt] x2goclient: ref(): x2goclient killed by SIGSEGV
Date: Wed, 07 Jan 2015 17:05:11 +0000
From: [email-masked]
To: [email-masked]

https://bugzilla.redhat.com/show_bug.cgi?id=1179869

            Bug ID: 1179869
           Summary: [abrt] x2goclient: ref(): x2goclient killed by SIGSEGV
           Product: Fedora
           Version: 20
         Component: x2goclient
          Assignee: [email-masked]
          Reporter: [email-masked]
        QA Contact: [email-masked]
                CC: [email-masked]

Version-Release number of selected component:
x2goclient-4.0.2.1-1.fc20

Additional info:
reporter:       libreport-2.2.3
backtrace_rating: 4
cmdline:        x2goclient
crash_function: ref
executable:     /usr/bin/x2goclient
kernel:         3.16.6-203.fc20.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 ref at ../../src/corelib/arch/qatomic_x86_64.h:121
 #1 QString::operator= at tools/qstring.cpp:1410
 #2 ONMainWindow::getSessionFromString at ../onmainwindow.cpp:3657
 #3 ONMainWindow::selectSession at ../onmainwindow.cpp:4364
 #4 ONMainWindow::slotListSessions at ../onmainwindow.cpp:3629
 #5 ONMainWindow::qt_static_metacall at moc_onmainwindow.cpp:385
 #6 QMetaObject::activate at kernel/qobject.cpp:3567
 #7 SshProcess::sshFinished at moc_sshprocess.cpp:140
 #8 SshProcess::slotChannelClosed at ../sshprocess.cpp:443
 #9 SshProcess::qt_static_metacall at moc_sshprocess.cpp:84

-- 
You are receiving this mail because:
You are on the CC list for the bug.
You are the assignee for the bug.

---

From: Mike Gabriel <[email-masked]>
Date: Thu, 08 Jan 2015 09:48:32 +0000

Control: severity -1 important
Control: retitle -1 add sanity checks when processing stdout of X2Go  
Server commands

Hi Orion,

> number of elements.  Need some error checking here.

Unfortunately, X2Go Client code does no sanitizing at all at most  
place. It simply expects that the X2Go Server on the other end is  
working correctly (which it sometimes is not)...

Raising severity to important...

Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: Sophia jasper <[email-masked]>
Date: Thu, 11 Feb 2021 12:44:30 +0000

Greetings I am  Sophia jasper. I hope we can start a relationship please reply me