Subject: Bug#717: Fwd: [Bug 1179010] New: [abrt] nxagent: _XReply(): nxagent killed by SIGSEGV

From: Orion Poplawski <[email-masked]>
Date: Mon, 05 Jan 2015 15:13:05 -0700

Package: nx-libs
Version: 3.5.0.28

This looks like infinite recursion in the _XIDHandler() libX11 code.  Not sure
there is anything to be done besides trying to rebase nx-libs on a newer Xorg
X11 release.

-------- Forwarded Message --------
Subject: [Bug 1179010] New: [abrt] nxagent: _XReply(): nxagent killed by SIGSEGV
Date: Mon, 05 Jan 2015 21:37:20 +0000
From: [email-masked]
To: [email-masked]

https://bugzilla.redhat.com/show_bug.cgi?id=1179010

            Bug ID: 1179010
           Summary: [abrt] nxagent: _XReply(): nxagent killed by SIGSEGV
           Product: Fedora
           Version: 21
         Component: nx-libs
          Assignee: [email-masked]
          Reporter: [email-masked]
        QA Contact: [email-masked]
                CC: [email-masked]

Description of problem:
This seems to happen when I've had a nx2go client session going for most of the
day.  Though it doesn't happen every day and seems to occur only about once a
week at most.  I start my session at 9am, if it's going to happen it happens
around 2pm more or less.

Causes KDE to be unresponsive and the other apps super sluggish.

Disconnecting or pausing the session causes it to abort and not be resumable.
Once it's like that, there's no way to salvage it.  Save what can be saved and
exit and log back in.

Version-Release number of selected component:
nxagent-3.5.0.28-1.fc21

Additional info:
reporter:       libreport-2.3.0
backtrace_rating: 4
cmdline:        /usr/lib64/nx/../x2go/bin/x2goagent -extension XFIXES -nolisten
tcp -nolisten tcp -dpi 96 -D -auth /home/sly/.Xauthority -geometry 1680x1050
-name X2GO-sly-209-1420466729_stDKDE_dp24 :209
crash_function: _XReply
executable:     /usr/lib64/nx/bin/nxagent
kernel:         3.17.7-300.fc21.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (2 frames)
 #0 _XReply at XlibInt.c:2249
 #1 _XIDHandler at XlibInt.c:2073

-- 
You are receiving this mail because:
You are on the CC list for the bug.
You are the assignee for the bug.

---

From: Ulrich Sibiller <[email-masked]>
Date: Tue, 6 Jan 2015 00:14:57 +0100

> there is anything to be done besides trying to rebase nx-libs on a newer Xorg

This gets more important every day. Unfortunately the X11 code
underwent massive changes in the meantime so this is a HUGE task. But
it should definitely be done.

We had a crash and could identify a bug in the X11 code. A colleague
of mine found an according patch which we tried to backport to NX. We
failed because the current X11 code looks totally different now...

Uli