Subject: Bug#70: X2Go Client debug's code works fine meanwhile

From: Mike Gabriel <[email-masked]>
Date: Sun, 29 Jun 2014 19:21:17 +0000

Control: close -1

Closing a bug that should be fixed by now...

Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Sun, 29 Jun 2014 19:25:03 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2goclient package:

#70: X2Go Client: some of the debug code fails to compile

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
70: http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=70
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go Client debug's code works fine meanwhile
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Date: Sun, 29 Jun 2014 19:21:17 +0000

Control: close -1

Mike
-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

Subject: X2Go Client: some of the debug code fails to compile
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Date: Mon, 03 Dec 2012 10:05:48 +0100

Package: x2goclient
Severity: minor
Version: HEAD

Hi Alex,

some of the debug code lines fail to compile if a LOG_FILE has been set.

The below patch shows which lines I had to comment out to make X2Go  
Client compile with debug output.

Greets,
Mike

diff --git a/onmainwindow.cpp b/onmainwindow.cpp
index 76f8ba9..1f2e2b7 100644
--- a/onmainwindow.cpp
+++ b/onmainwindow.cpp
@@ -261,7 +261,7 @@ ONMainWindow::ONMainWindow ( QWidget *parent )  
:QMainWindow ( parent )

      QDesktopWidget wd;

-    x2goDebug<<"primary screen geometry:  
"<<wd.screenGeometry(wd.screenNumber(this));
+    //x2goDebug<<"primary screen geometry:  
"<<wd.screenGeometry(wd.screenNumber(this));

      if ( wd.screenGeometry(wd.screenNumber(this)).width() <1024 ||
              wd.screenGeometry(wd.screenNumber(this)).height() <768 )
@@ -9375,7 +9375,7 @@ void ONMainWindow::slotSetProxyWinFullscreen()
  void ONMainWindow::resizeProxyWinOnDisplay(int disp)
  {
      QRect geom=QApplication::desktop()->screenGeometry(disp-1);
-    x2goDebug<<"resizing proxy win to fit display  
"<<disp<<"("<<geom<<")"<<endl;
+    //x2goDebug<<"resizing proxy win to fit display  
"<<disp<<"("<<geom<<")"<<endl;
  #ifdef Q_OS_LINUX
      XSync(QX11Info::display(),false);
      XMoveWindow(QX11Info::display(), proxyWinId,geom.x(),geom.y());
@@ -9425,7 +9425,7 @@ void ONMainWindow::slotConfigXinerama()
      if (newGeometry==lastDisplayGeometry)
          return;
      lastDisplayGeometry=newGeometry;
-    x2goDebug<<"New proxy geometry: "<<lastDisplayGeometry<<endl;
+//    x2goDebug<<"New proxy geometry: "<<lastDisplayGeometry<<endl;
      QDesktopWidget* root=QApplication::desktop();
      QList<QRect> newXineramaScreens;
      for (int i=0; i< root->numScreens(); ++i)
@@ -9437,17 +9437,17 @@ void ONMainWindow::slotConfigXinerama()
               
intersection=root->screenGeometry(i).intersected(lastDisplayGeometry);
          if (!intersection.isNull())
          {
-            x2goDebug<<"intersected with "<<i<<": "<<intersection<<endl;
+//            x2goDebug<<"intersected with "<<i<<": "<<intersection<<endl;
              intersection.moveLeft(intersection.x()-lastDisplayGeometry.x());
              intersection.moveTop(intersection.y()-lastDisplayGeometry.y());
-            x2goDebug<<"xinerama screen: "<<intersection<<endl;
+//            x2goDebug<<"xinerama screen: "<<intersection<<endl;
              newXineramaScreens<<intersection;
          }
      }
      if (xineramaScreens != newXineramaScreens)
      {
          xineramaScreens=newXineramaScreens;
-        x2goDebug<<"xinerama screen changed, new screens:  
"<<xineramaScreens<<endl;
+//        x2goDebug<<"xinerama screen changed, new screens:  
"<<xineramaScreens<<endl;
          xineramaTimer->stop();
          QStringList screens;
          foreach (QRect disp, xineramaScreens)

-- 

DAS-NETZWERKTEAM
mike gabriel, rothenstein 5, 24214 neudorf-bornstein
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31

freeBusy: