Subject: epel 5 repos have signature errors

From: Michael DePaulo <[email-masked]>
Date: Fri, 12 Dec 2014 09:22:30 -0500

Package: buildscripts
Severity: normal

As reported here:

http://lists.x2go.org/pipermail/x2go-user/2014-December/002705.html

A CentOS 5 user is getting these errors:

error: nx-libs-3.5.0.28-0.0x2go1.1.git20141114.546.main.el5.centos: Header V4
RSA/SHA1 signature: BAD, key ID 5bfe2b6e
error: libXcomp-3.5.0.28-0.0x2go1.1.git20141114.546.main.el5.centos: Header V4
RSA/SHA1 signature: BAD, key ID 5bfe2b6e
etc....

The cause appears to be that CentOS 5 cannot handle V4 signatures, only V3.
http://adminotes.blogspot.fr/2011/12/centos-6-rpm-sign-problem-v4-signatures.html

---

From: Mike Gabriel <[email-masked]>
Date: Sat, 13 Dec 2014 02:18:07 +0000

Control: tag -1 pending

Hi Michael,

> http://adminotes.blogspot.fr/2011/12/centos-6-rpm-sign-problem-v4-signatures.html

I hope this (and a previous commit) fixes the issue:
http://code.x2go.org/gitweb?p=buildscripts.git;a=commitdiff;h=3c79b61da0e25e7df61206d0d6ac986e457ff7af

I have just triggered rebuilds of nightly packages nx-libs and  
x2goserver. Can you check (once the have built) if those packages are  
now installable on Centos5?

Thanks,
Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: Michael DePaulo <[email-masked]>
Date: Sat, 13 Dec 2014 09:10:54 -0500

On Fri, Dec 12, 2014 at 9:18 PM, Mike Gabriel
<[email-masked]> wrote:
> I have just triggered rebuilds of nightly packages nx-libs and x2goserver.
> Can you check (once the have built) if those packages are now installable on
> Centos5?
>
> Thanks,
> Mike

Hi Mike#1,

I just setup a CentOS 5.11 64-bit VM and tried to install the nightly packages.

I am still getting the errors like both Michael Dubois and I get with
the stable release packages.

error: nx-libs-3.5.0.29-0.0x2go1.0.git20141213.552.heuler.el5.centos:
Header V4 RSA/SHA1 signature: BAD, key ID 5bfe2b6e

-Mike#2