Subject: Bug#694: Info received and FILED only (Closing)

From: "X2Go Bug Tracking System" <[email-masked]>
Date: Thu, 25 Jan 2024 21:25:01 +0000

Thank you for the additional information you have supplied regarding
this Bug report.

This is an automatically generated reply to let you know your message
has been received.

Your message has not been forwarded to the package maintainers or
other interested parties; you should ensure that the developers are
aware of the problem you have entered into the system - preferably
quoting the Bug reference number, #694.

If you wish to submit further information on this problem, please
send it to [email-masked].

Please do not send mail to [email-masked] unless you wish
to report a problem with the Bug-tracking system.

-- 
694: https://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=694
X2Go Bug Tracking System
Contact [email-masked] with problems

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Thu, 25 Jan 2024 21:25:01 +0000

This is an automatic notification regarding your Bug report
which was filed against the cups-x2go package:

#694: CUPS 1.7.x remounts /tmp and breaks cups-x2go

It has been closed by Stefan Baur <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Stefan Baur <[email-masked]> by
replying to this email.

Subject: Closing
From: Stefan Baur <[email-masked]>
To: [email-masked]
Date: Thu, 25 Jan 2024 22:24:50 +0100

Control: close -1
Control: archive -1

Once this [0] patch was dropped from Debian Buster, the issue went away.

Kind Regards,
Stefan Baur

[0] 
<https://salsa.debian.org/printing-team/cups/-/commit/3f9e548dce8b890e48c78292f0dba45bd4db8325>

-- 
BAUR-ITCS UG (haftungsbeschränkt)
Geschäftsführer: Stefan Baur
Eichenäckerweg 10, 89081 Ulm | Registergericht Ulm, HRB 724364
Fon/Fax 0731 40 34 66-36/-35 | USt-IdNr.: DE268653243

Subject: CUPS 1.7.x remounts /tmp and breaks cups-x2go
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Date: Tue, 09 Dec 2014 05:15:48 +0000

Package: cups-x2go
Severity: important

The workaround provided below can be applied to x2goprint from  
x2goserver-printing package.

But my gut feelings tell me, we need to review cups-x2go. Maybe this  
bug gets reassigned to x2goserver-printing later, if my gut feelings  
get proven wrong.

Mike

----- Weitergeleitete Nachricht von Роман <[email-masked]> -----
   Datum: Mon, 01 Dec 2014 10:59:36 +0300
     Von: Роман <[email-masked]>
Betreff: [X2Go-User] X2Go Linux Server. Virtual print issue workaround
      An: [email-masked]

For those who can't print to redirected printer here my workaround.
 
On X2Go Server do following (by root):
----------------------------------------------
cd /usr/bin
 
mv x2goprint x2goprint.orig
 
cat << EOF > x2goprint
#!/bin/bash
umount /tmp
x2goprint.orig $@
EOF
 
chmod a+x x2goprint
-----------------------------------------------
 
The problem is that CUPS remounts /tmp during print process.
Therefore temporary x2go directories have become unavailable.
 
Best regards,
Inpos.

----- Ende der weitergeleiteten Nachricht -----

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb