Subject: Bug#673: [X2Go-Dev] Bug#673: GUI-based Applications stall when x2go session is suspended

From: Mike Gabriel <[email-masked]>
Date: Fri, 15 May 2015 13:53:16 +0000

Control: close -1

Re-Cc:ing #637 (got dropped off from the list of recipients with the  
previous post)

Closing this issue on user request. I remember to have seen something  
similar in X2Go sessions, but some tests today confirm that there is  
no such issue on my setups.

Greets,
Mike

On  Fr 09 Jan 2015 04:02:12 CET, Jerry Rabe wrote:

> Mike,
>
> As it turns out, it was just yesterday that I found that this bug
> seems to be fixed in the latest version!  My post actually was
> incorrect in that I had observed the issue on x2goserver package
> 4.0.1.15 instead of 4.0.1.18 (at that time anything above 4.0.1.15
> wasn't working due to some unknown system incompatibility).  But
> yesterday I did a full system "yum update" on all three of our Centos
> 7 machines, and not only is x2goserver 4.0.1.18-4.el7 working well,
> but the GUI hang issue is now non-existent!  From my perspective, you
> can move this issue to closed.
>
> You are doing a wonderful job on this project, and it is very
> impressive.  Thank you.
>
> One other thing I just noticed.  If the system goes down ungracefully,
> the x2go fuse-based shared drives do not get unmounted, and
> subsequently will not re-mount after a reboot.  I finally fixed it by
> removing /var/lib/x2go/x2go_sessions and re-installing x2goserver.  Is
> there an easier way to fix this?
>
> --
> Jerry Rabe
>
>
> On Thu, Jan 8, 2015 at 4:47 PM, Mike Gabriel
> <[email-masked]> wrote:
>> Control: reassign -1 nxagent
>> Control: severity -1 important
>>
>> HI Jerry,
>>
>> On  Do 13 Nov 2014 17:12:23 CET, Jerry Rabe wrote:
>>
>>> When an x2go session is suspended, any running GUI-based application
>>> will stall as soon as it tries to update graphical information in the
>>> GUI.  This was not the case with the old freenx server, and it is a
>>> problem for large jobs that take a long time to run.  Not sure if this
>>> is just a configuration/install problem.
>>> What does NOT stall:
>>> - Text-based output from command line-based shell scripts.
>>> - GUI-based applications running in suspended x2go sessions as
>>> Published Applications.
>>> What DOES Stall:
>>> - GUI-based applications running in suspended x2go sessions (accessed
>>> by X2GoClient) on a Linux Desktop (i,.e. MATE, XFCE)
>>> - GUI-based applications running in suspended NX sessions (accessed
>>> by an NX3 client) on a Linux Desktop (i,.e. MATE, XFCE)
>>>
>>> The steps taken to produce the bug:
>>> - Start a GUI-based Application (for testing, use the Linux System
>>> Monitor, open the "Resources" tab)
>>> - Suspend the x2go session.
>>> - Some time later, resume the session.  The GUI now continues
>>> running, but it had stalled while the session was suspended.
>>>
>>> The client machine's OS: Windows 7 SP1
>>> The client machine's version of X2GoClient: 4.0.3.0
>>> The server's OS: Centos 7
>>> The server's version of the x2goserver package: 4.0.1.18-1.el7  x86_64
>>> The server's version of the x2goserver-xsession package: 4.0.1.18-1.el7
>>> x86_64
>>> The server's version of the nxagent package:3.5.0.27-1.el7 x86_64
>>
>>
>> this is an issue that needs to be addressed soon.
>>
>> Reassigning to nxagent package and raising severity...
>>
>> Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Fri, 15 May 2015 13:55:03 +0000

This is an automatic notification regarding your Bug report
which was filed against the nxagent package:

#673: GUI-based Applications stall when x2go session is suspended

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
673: http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=673
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: Re: [X2Go-Dev] Bug#673: GUI-based Applications stall when x2go session is suspended
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Cc: [email-masked]
Date: Fri, 15 May 2015 13:53:16 +0000

Control: close -1

Greets,
Mike

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

Subject: GUI-based Applications stall when x2go session is suspended
From: Jerry Rabe <[email-masked]>
To: [email-masked]
Date: Thu, 13 Nov 2014 10:12:23 -0600

Package: x2goserver
Version:  4.0.1.15-2.el7  x86_64

The server's version of the x2goserver-xsession package: 4.0.1.18-1.el7 x86_64