X2Go Bug report logs - #671
Desktop Sessions like KDE and ICEWM quit immediately after spawning with x2goserver >4.0.1.15

version graph

Package: x2goserver; Maintainer for x2goserver is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goserver is src:x2goserver.

Reported by: Thomas Wagner <t.wagner@nthfs.jku.at>

Date: Wed, 12 Nov 2014 12:50:01 UTC

Severity: normal

Tags: pending

Fixed in version 4.0.1.19

Done: X2Go Release Manager <git-admin@x2go.org>

Bug is archived. No further changes may be made.

Full log


Message #30 received at 671@bugs.x2go.org (full text, mbox):

Received: (at 671) by bugs.x2go.org; 13 Nov 2014 13:19:45 +0000
From t.wagner@nthfs.jku.at  Thu Nov 13 14:19:43 2014
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=-1.9 required=5.0 tests=BAYES_00,URIBL_BLOCKED
	autolearn=ham version=3.3.2
Received: from email.uni-linz.ac.at (email.edvz.uni-linz.ac.at [140.78.3.65])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTP id F338B5DB3D
	for <671@bugs.x2go.org>; Thu, 13 Nov 2014 14:19:42 +0100 (CET)
Received: from mail.icie.jku.at (iciemail.mechatronik.uni-linz.ac.at [140.78.138.2])
	by email.uni-linz.ac.at (Postfix) with ESMTP id D46AD1E8C7C;
	Thu, 13 Nov 2014 14:19:42 +0100 (CET)
Received: from [10.78.1.99] (unknown [10.78.1.99])
	by mail.icie.jku.at (Postfix) with ESMTPSA id A10A93382E3;
	Thu, 13 Nov 2014 14:19:42 +0100 (CET)
Message-ID: <5464AFEE.3060005@nthfs.jku.at>
Date: Thu, 13 Nov 2014 14:19:42 +0100
From: Thomas Wagner <t.wagner@nthfs.jku.at>
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Thunderbird/31.2.0
MIME-Version: 1.0
To: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
CC: 671@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#671: Desktop Sessions like KDE and ICEWM quit
 immediately after spawning with x2goserver >4.0.1.15
References: <20141113111555.Horde.oWmDnNG4lfO0saJFe8lPyg6@mail.das-netzwerkteam.de> <5464A294.8080904@nthfs.jku.at> <20141113131509.Horde.67fioLa4A1VkRuTVwPCvYQ2@mail.das-netzwerkteam.de>
In-Reply-To: <20141113131509.Horde.67fioLa4A1VkRuTVwPCvYQ2@mail.das-netzwerkteam.de>
Content-Type: text/plain; charset=windows-1252
Content-Transfer-Encoding: 7bit
Hi,

In
http://code.x2go.org/gitweb?p=x2goserver.git;a=commitdiff;h=3d98f8999f60840329241d82de6d741d1c2cbc9c
you added a poll for /etc/SUSE-brand
However, on my openSUSE 13.1 systems /etc/SuSE-release exists and
/etc/SUSE-brand is not there.

best regards

Thomas

Am 13.11.2014 um 14:15 schrieb Mike Gabriel:
>
> This was changed for 4.0.1.16, however, now all desktop session
> startups fail for distributions we are not aware of.
>
> For openSUSE (or SUSE in general, actually), this was fixed by a
> post-4.0.1.18 commit (present in the nightly builds and pending for
> release 4.0.1.19):
> http://code.x2go.org/gitweb?p=x2goserver.git;a=commitdiff;h=3d98f8999f60840329241d82de6d741d1c2cbc9c
>
>


Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Thu May 23 17:26:39 2019; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.