Subject: window border and control disappears after maximize and move

From: "Anand G." <[email-masked]>
Date: Tue, 11 Nov 2014 15:57:17 -0800

Package: x2goclient
Version: 4.0.3.0

x2goclient-4.0.3.0-20141021
Windows 7 64-bit SP1

Laptop connected to a USB docking station supporting two monitors.  Laptop is 
display #1.  Monitors attached to dock are displays #2 & #3.  Order of displays is: 2, 3, 1 from left to right.  This is according the the "Identify all 
displays" button in session preferences.
Laptop is running at 1600x900
Monitors #2 & #3 run at 1680x1050

x2goclient session type "Single application" command is xterm.

session settings: Custom display (800x600), dpi is 96, Xinerama extension unchecked

Start new session and xterm opens on display #2 (left most screen).  xterm 
maximizes correctly.  Upon dragging maximized xterm from display #2 to 
display #3 (middle), the window manager/border disappears.  I can no 
longer manipulate the window (minimize, maximize, restore, move) and it 
occupies the full screen.  I have to suspend the session, undock, and 
then resume the session in order to regain control of the window.  
Simple suspend/resume does not work.  Applications launched from the 
xterm behave the same way (e.g. lose window control over gvim session).

The problem is not there with client 4.0.2.1+hotfix1+build6.  Everything works as 
expected.  The maximized window correctly snaps between displays.  I do not have x2goserver settings or version information available.

---

From: [email-masked]
Date: Mon, 19 Jan 2015 14:23:02 +0100

I tested x2go 4.0.3.1 with several version of external VcXsrv (1.15.0.2, 
1.15.1, 1.16.1, 1.16.2) without problem.
(command line option: -multiwindow -notrayicon -clipboard)

When I switch back to internal X server and problem is back too.