Subject: Keyboard layout is wrong

From: "Albrecht, Daniel S." <[email-masked]>
Date: Fri, 7 Nov 2014 16:49:12 +0000

Package: keyboard layout
Version. 2.7.7

Just yesterday, I attempted to connect remotely to my work desktop using X2go and the keyboard layout was completely erratic (e = backspace, enter = j, etc.).  When I attempt to change the keyboard layout in preferences, no matter what input I choose, I get the following error:

Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation
70000000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

When I use an X11 terminal to run the xprop and gconftrool-2, I get the following responses:

bash-3.2$ xprop -root|grep XKB
_XKB_RULES_NAMES(STRING) = "base", "empty", "empty", "", ""

bash-3.2$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
bash: gconftool-2: command not found

I'm also having some connectivity issues, where X2go closes unexpectedly at least once before I'm able to log on, I don't know if that issue is related to the keyboard one or not.  Thank you,

Dan Albrecht

The information in this e-mail is intended only for the person to whom it is
addressed. If you believe this e-mail was sent to you in error and the e-mail
contains patient information, please contact the Partners Compliance HelpLine at
http://www.partners.org/complianceline . If the e-mail was sent to you in error
but does not contain patient information, please contact the sender and properly
dispose of the e-mail.

---

From: Mike Gabriel <[email-masked]>
Date: Fri, 07 Nov 2014 21:01:02 +0000

Control: reassign -1 wiki.x2go.org
Control: retitle -1 better document different keyboard setups
Control: severity -1 wishlist

Hi Daniel,

On  Fr 07 Nov 2014 17:49:12 CET, Albrecht, Daniel S. wrote:

> Package: keyboard layout
> Version. 2.7.7
>
> Just yesterday, I attempted to connect remotely to my work desktop  
> using X2go and the keyboard layout was completely erratic (e =  
> backspace, enter = j, etc.).  When I attempt to change the keyboard  
> layout in preferences, no matter what input I choose, I get the  
> following error:
>
> I'm also having some connectivity issues, where X2go closes  
> unexpectedly at least once before I'm able to log on, I don't know  
> if that issue is related to the keyboard one or not.  Thank you,
>
> Dan Albrecht

I am not sure that this really is a bug. It surely could be handled in  
a better way in X2Go, but basically, what you do is:

   (a) you tell X2Go Client to set some specific keyboard set up for  
the session
   (b) have a special keyboard setting configured by the desktop environment

Both approaches do not go well together. In X2Go, we recommend to  
disable all keyboard settings made by the desktop shell, but let X2Go  
Client set up the keyboard model, layout and variant.

I reassigned this issue to wiki.x2go.org as it rather requires  
documentation in the FAQ than a fix in the software.

Greets,
Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb