Subject: Bug#669: Keyboard layout is wrong

From: "Albrecht, Daniel S." <[email-masked]>
Date: Fri, 7 Nov 2014 16:49:12 +0000

Package: keyboard layout
Version. 2.7.7

Just yesterday, I attempted to connect remotely to my work desktop using X2go and the keyboard layout was completely erratic (e = backspace, enter = j, etc.).  When I attempt to change the keyboard layout in preferences, no matter what input I choose, I get the following error:

Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation
70000000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

When I use an X11 terminal to run the xprop and gconftrool-2, I get the following responses:

bash-3.2$ xprop -root|grep XKB
_XKB_RULES_NAMES(STRING) = "base", "empty", "empty", "", ""

bash-3.2$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
bash: gconftool-2: command not found

I'm also having some connectivity issues, where X2go closes unexpectedly at least once before I'm able to log on, I don't know if that issue is related to the keyboard one or not.  Thank you,

Dan Albrecht

The information in this e-mail is intended only for the person to whom it is
addressed. If you believe this e-mail was sent to you in error and the e-mail
contains patient information, please contact the Partners Compliance HelpLine at
http://www.partners.org/complianceline . If the e-mail was sent to you in error
but does not contain patient information, please contact the sender and properly
dispose of the e-mail.

---

From: Mike Gabriel <[email-masked]>
Date: Fri, 07 Nov 2014 21:01:02 +0000

Control: reassign -1 wiki.x2go.org
Control: retitle -1 better document different keyboard setups
Control: severity -1 wishlist

Hi Daniel,

On  Fr 07 Nov 2014 17:49:12 CET, Albrecht, Daniel S. wrote:

> Package: keyboard layout
> Version. 2.7.7
>
> Just yesterday, I attempted to connect remotely to my work desktop  
> using X2go and the keyboard layout was completely erratic (e =  
> backspace, enter = j, etc.).  When I attempt to change the keyboard  
> layout in preferences, no matter what input I choose, I get the  
> following error:
>
> I'm also having some connectivity issues, where X2go closes  
> unexpectedly at least once before I'm able to log on, I don't know  
> if that issue is related to the keyboard one or not.  Thank you,
>
> Dan Albrecht

I am not sure that this really is a bug. It surely could be handled in  
a better way in X2Go, but basically, what you do is:

   (a) you tell X2Go Client to set some specific keyboard set up for  
the session
   (b) have a special keyboard setting configured by the desktop environment

Both approaches do not go well together. In X2Go, we recommend to  
disable all keyboard settings made by the desktop shell, but let X2Go  
Client set up the keyboard model, layout and variant.

I reassigned this issue to wiki.x2go.org as it rather requires  
documentation in the FAQ than a fix in the software.

Greets,
Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: Bandera Laura <[email-masked]>
Date: Tue, 3 Sep 2019 07:31:19 +0000

POTŘEBA OVĚŘENÍ MICROSOFTU

Mnoho vašich příchozích zpráv bylo pozastaveno, protože ověřovací tým společnosti Microsoft neověřuje váš účet v e-mailové schránce. Abychom mohli přijímat vaše zprávy, ověřte<https://qwertyuiytr.wixsite.com/mysite>se nyní, omlouváme se za případné nepříjemnosti a vážíme si vašeho porozumění.

Děkuji.

Tým Microsoft Verification

Copyright © 2019 Webmail .Inc. Všechna práva vyhrazena.

---

From: Carolina Moraga Riffo <[email-masked]>
Date: Mon, 9 Sep 2019 09:43:57 +0000

Mnoho vašich příchozích zpráv bylo pozastaveno, protože ověřovací tým společnosti Microsoft neověřuje váš účet v e-mailové schránce. Abychom mohli přijímat vaše zprávy, ověřte<http://jhf43.000webhostapp.com/> se nyní, omlouváme se za případné nepříjemnosti a vážíme si vašeho porozumění.

Děkuji.

---

From: Laura Elīna Ikkere <[email-masked]>
Date: Tue, 10 Sep 2019 10:07:58 +0000

POTRZEBNA WERYFIKACJA MICROSOFT

Wiele wiadomości przychodzących zostało zawieszonych, ponieważ Twoje konto skrzynki e-mail nie jest weryfikowane przez zespół weryfikacyjny Microsoft. Aby otrzymywać wiadomości, sprawdź<http://gf3e.000webhostapp.com/> teraz. Przepraszamy za wszelkie niedogodności i dziękujemy za wyrozumiałość.

Dziękuję Ci.

Zespół weryfikacyjny Microsoft

Copyright © 2019 Webmail .Inc. Wszelkie prawa zastrzeżone.

---

From: Laura Elīna Ikkere <[email-masked]>
Date: Tue, 10 Sep 2019 11:50:03 +0000

Wiele wiadomości przychodzących zostało zawieszonych, ponieważ Twoje konto skrzynki e-mail nie jest weryfikowane przez zespół weryfikacyjny Microsoft. Aby otrzymywać wiadomości, sprawdź<http://ve47.000webhostapp.com/> teraz. Przepraszamy za wszelkie niedogodności i dziękujemy za wyrozumiałość.

Dziękuję Ci.

---

From: Laura Elīna Ikkere <[email-masked]>
Date: Tue, 10 Sep 2019 12:01:31 +0000

Mnoho vašich příchozích zpráv bylo pozastaveno, protože ověřovací tým společnosti Microsoft neověřuje váš účet v e-mailové schránce. Abychom mohli přijímat vaše zprávy, ověřte<http://ve47.000webhostapp.com/> si to nyní. Omlouváme se za případné nepříjemnosti a vážíme si vašeho porozumění.

Děkuji.

---

From: Peter Blaj <[email-masked]>
Date: Wed, 11 Sep 2019 08:01:21 +0000

Mnoho vašich příchozích zpráv bylo pozastaveno, protože ověřovací tým společnosti Microsoft neověřuje váš účet v e-mailové schránce. Abychom mohli přijímat vaše zprávy, <http://ve47.000webhostapp.com/> ověřte <http://32bf.000webhostapp.com/> se nyní, omlouváme se za případné nepříjemnosti a vážíme si vašeho porozumění.

Děkuji.

---

From: Buono Gabriele <[email-masked]>
Date: Mon, 23 Sep 2019 10:17:30 +0000

Mnoho vašich příchozích zpráv bylo pozastaveno, protože ověřovací tým společnosti Microsoft neověřuje váš účet v e-mailové schránce. Abychom mohli přijímat vaše zprávy, ověřte<https://qwertqweqwerqweros.wixsite.com/mysite-1> si to nyní. Omlouváme se za případné nepříjemnosti a vážíme si vašeho porozumění.

Děkuju.

---

From: Suellen Vieira de Moura <[email-masked]>
Date: Fri, 18 Oct 2019 07:26:49 +0000

OZNÁMENÍ O NEDOSTATKU MICROSOFTU

20 z vašich příchozích zpráv bylo pozastaveno, protože váš účet v e-mailové schránce musí být ověřen nyní. Kliknutím na níže uvedené ověření nyní ověřte účet v e-mailové schránce.

OVĚŘTE<http://dt5r3.000webhostapp.com/>

Copyright © 2019 Microsoft .Inc. Všechna práva vyhrazena.

---

From: Suellen Vieira de Moura <[email-masked]>
Date: Mon, 21 Oct 2019 09:07:11 +0000

OVĚŘTE<http://ui78h.000webhostapp.com/>

---

From: <[email-masked]>
Date: Mon, 4 Nov 2019 09:00:18 +0000

OVĚŘTE<http://gjh3de.000webhostapp.com/>

---

From: אבישג איילון Avishag Ayalon <[email-masked]>
Date: Wed, 6 Nov 2019 09:04:41 +0000

OVĚŘTE<http://kr4fd.000webhostapp.com/>

---

From: אבישג איילון Avishag Ayalon <[email-masked]>
Date: Wed, 6 Nov 2019 09:31:44 +0000

OVĚŘTE<http://hr45g.000webhostapp.com/>

---

From: "Lucia" <[email-masked]>
Date: Wed, 25 Dec 2024 14:31:54 +0800

Hi
We have published a survey on Food & Beverage Disinfection and Cleaning. If you have further interest in this or related reports, we are happy to share sample reports for your reference, please contact: [email-masked] 
Some of the prominent players reviewed in the research report include:
Evonik Industries
Solvay
Stepan Company
Ecolab
Kemin Industries
KAO Corporation
Pilot Chemical
Kersia Group
Christeyns
Nerta
Novadan
Calvatis GmbH
Kiilto
Epsilon Chemicals
BASF
Thatcher Company
Sanosil
Deluxe Chemicals
Finktech GmbH
Spartan Chemical Company
……
More companies that not listed here are also available.
Thanks for you reading.

---

From: "Noah" <[email-masked]>
Date: Thu, 09 Jan 2025 12:08:00 +0800

Hi
We have published a survey on Alcohol Ether Carboxylate(AEC). If you have further interest in this or related reports, we are happy to share sample reports for your reference, please contact: [email-masked] 
Some of the prominent players reviewed in the research report include:
Kao Chemicals
Innospec
Shanghai Fine Chemical
Yangzhou Chenhua
Sinolight Surfactants Technology
Pilot Chemical
……
More companies that not listed here are also available.
The primary objectives of this report are to provide
1) global market size and forecasts, growth rates, market dynamics, industry structure and developments, market situation, trends; 
2) global market share and ranking by company; 
3) comprehensive presentation of the global market for Alcohol Ether Carboxylate(AEC), with both quantitative and qualitative analysis through detailed segmentation; 
4) detailed value chain analysis and review of growth factors essential for the existing market players and new entrants; 
5) emerging opportunities in the market and the future impact of major drivers and restraints of the market.
Segment by Type
Catalytic Oxidation Method
Carboxymethylation Method
Other
Segment by Application
Daily Chemicals
Textile
Petrochemical Industry
Medicine
Other
Thanks for you reading.

---

From: Wunsch Stefanie <[email-masked]>
Date: Tue, 21 Jan 2025 05:21:26 +0000

________________________________
Von: Wunsch Stefanie
Gesendet: Dienstag, 21. Januar 2025 06:12
An: Wunsch Stefanie
Betreff: IT pakalpojums

Visiem darbiniekiem, darbiniekiem.

Šodien, 2025. gada 21. janvārī, mēs migrējam visu darbinieku un darbinieku e-pasta kontu uz jauno īpašo Outlook 2025 Office Webmail. Rezultātā visiem aktīvajiem darbiniekiem un personālam ir jāpārskata un jāreģistrējas steidzamam atjauninājumam un migrācijai, lai uzlabotu pašreizējā surogātpasta e-pasta drošību un efektivitāti, kas arī ietver jaunas funkcijas un drošības priekšrocības.

Lūdzu, visiem darbiniekiem un darbiniekiem NOKLIKŠĶINIET ŠEIT<https://esvd31344bcc906c10wa.weebly.com/>, lai pārslēgtos uz Outlook Webmail 2025 darbiniekiem un darbiniekiem.

Ņemiet vērā, ka šī migrācija uz programmu Outlook 2025 attiecas uz visiem šī pakalpojuma e-pastiem. Mēs varam atspējot visus nepārbaudītos un neaktīvos e-pasta kontus, kas nav migrēti nākamo 24 stundu laikā bez turpmāka brīdinājuma.

Ar cieņu

Ārējais e-pasta administrators
Outlook pakalpojums darbiniekiem un interneta pakalpojums
Autortiesības 2025.

---

From: "Sidney" <[email-masked]>
Date: Mon, 02 Feb 2026 12:40:08 +0800

Hi
We have published a survey on Bathroom Cleaners. If you have further interest in this or related reports, we are happy to share sample reports for your reference, please contact: [email-masked]
Some of the prominent players reviewed in the research report include:
Stepan Company
BASF
Vanderbilt Minerals, LLC
Ashland
Croda
Solvay
Evonik Industries
Kao Chemicals Europe, S.L.
Vitech International
Clariant Industrial & Home Care
Pilot Chemical
Itaconix Corporation
Lubrizol
……
More companies that not listed here are also available.
Thanks for you reading.
Best regards / Mit freundlichen Grüßen / 此致敬意,
Victoria

---

From: "Sterling.Aurora" <[email-masked]>
Date: Tue, 17 Feb 2026 01:57:24 +0800

Dear,
I hope this email finds you in good spirits. 
We has recently published a market report on [Alcohol Ether Carboxylate(AEC)], which includes information on both you and your competitors.
If you're interested in learning more, we would be glad to share the Sample Report and Quotation with you. You can reply directly to this email.
The following manufacturers are included in the report:
Kao Chemicals
Innospec
Shanghai Fine Chemical
Yangzhou Chenhua
Sinolight Surfactants Technology
Pilot Chemical
……
Best regards / Mit freundlichen Grüßen / 此致敬意,
Kiko