Subject: session connect with Python X2Go freezes if gevent 0.13.6 is used

From: Mike Gabriel <[email-masked]>
Date: Thu, 30 Oct 2014 14:41:58 +0000

Package: python-x2go
Sevrity: important

Hi Pavel, Jan,

TL;DR; for the bug tracker... Python X2Go 0.5.0.x freezes during  
X2GoControlSession.connect() when used with gevent 0.13.6. With Python  
0.4.0.x no such freeze could be observed.

On  Mi 29 Okt 2014 10:24:53 CET, Mike Gabriel wrote:

> Hi Pavel, hi Jan,
>
> On  Di 28 Okt 2014 16:00:34 CET, Mike Gabriel wrote:
>
>> Hi,
>>
>> On  Di 28 Okt 2014 15:28:53 CET, hanak wrote:
>>
>>>> Hi all,
>>>>
>>>> I have a problem with an newly installed pyhoca-gui
>>>>
>>>> while I can connect from an debian-wheezy with pyhoca-gui 0.4.0.9
>>>> without problems, an newly installed pyhoca-gui at another computer with
>>>> version 0.5.0.2 pyhoca-gui freezes at the moment when it tries to
>>>> establish the ssh connection.
>>>
>>> I confirm exactly the same behavior on debian-wheezy when running
>>> pyhoca-cli.
>>>
>>> While on pyhoca-cli 0.4.0.2-1 (pyhoca-x2go 0.4.0.9-1) everything works
>>> without problems, on pyhoca-cli 0.5.0.1-1 (python-x2go 0.5.0.1-1)
>>> connection freezes with exactly the same debug...
>>>
>>> Best regards
>>>
>>> Pavel
>>
>> can anyone of you send me an obfuscated ~/.x2goclient/sessions file?
>>
>> Plus: what openSSH server version is installed on the X2Go Server?
>>
>> Mike
>
> I am so sorry, guys, but I cannot reproduce the issue here. As I  
> said earlier. I observed those hangs once or twice, but wasn't able  
> to reproduce them.
>
> I tested pyhoca-gui on jessie and on wheezy (+ some backports) and  
> things worked out fine.
>
> I connected to servers of several Debian and Ubuntu versions.
>
> A bit clueless, sorry...
>
> Mike

I have a system that exhibits the same behaviour, as described by you!  
A Ubuntu precise system with python-gevent (I obviously did not  
provide a newer gevent version for precise in our X2Go PPA on  
Launchpad).

I will join in to get this narrowed down.

Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: Mike Gabriel <[email-masked]>
Date: Sat, 31 Jan 2015 14:33:53 +0000

Control: close -1

Hi all,

On  Do 30 Okt 2014 15:41:58 CET, Mike Gabriel wrote:

> X2GoControlSession.connect() when used with gevent 0.13.6. With  
> Python 0.4.0.x no such freeze could be observed.

On packages.x2go.org and Launchpad I have now provided a more recent  
version of python-gevent (1.0.1) and python-greenlet (0.4.5). The  
newer versions had to be provided for Debian wheezy and Ubuntu  
precise. All more recent versions of Debian/Ubuntu already contain a  
version of python-gevent that should work fine.

On my Debian wheezy systems, this works well. For Debian/Ubuntu based  
distros the issue can be considered fixed.

If the issue occurs on other distros, please reopen this bug and give  
feedback.

Mike

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy: