Subject: X2Go issue (in src:pyhoca-gui) has been marked as closed

From: Mike DePaulo <[email-masked]>
Date: Sat, 24 Jan 2015 17:44:41 +0100 (CET)

close #649
thanks

Hello,

we are very hopeful that X2Go issue #649 reported by you
has been resolved in the new release (0.5.0.3) of the
X2Go source project »src:pyhoca-gui«.

You can view the complete changelog entry of src:pyhoca-gui (0.5.0.3)
below, and you can use the following link to view all the code changes
between this and the last release of src:pyhoca-gui.

    http://code.x2go.org/gitweb?p=pyhoca-gui.git;a=commitdiff;h=03b4e45f1288d21d8c598a3ca71a1fbc6014879f;hp=b3fa2d7b41f65901154478afc7169ee0c7e96b45

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:pyhoca-gui.

Thanks a lot for contributing to X2Go!!!

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
X2Go Component: src:pyhoca-gui
Version: 0.5.0.3-20150124
Status: RELEASE
Date: Sat, 24 Jan 2015 11:03:07 -0500
Fixes: 108 649
Changes: 
 pyhoca-gui (0.5.0.3-20150124) RELEASED; urgency=medium
 .
   [ Mike DePaulo ]
   * New upstream version (Windows Only) (0.5.0.3-20150124):
     - Fix win32 build (missing win32gui.pyd) (Fixes: #649)
     - Windows: Install VcXsrv "misc" fonts by default, and make all 4 font
       groups optional: misc, 75dpi, 100dpi and others (Fixes: #108)
       Note: The fact that all the fonts are included makes the installer about
       30MB larger.
     - Windows: Upgrade from VcXsrv-xp 1.14.3.2 to
       VcXsrv 1.15.2.2-xp+vc2013+x2go1
       This new major version includes security fixes such as:
       OpenSSL update to 1.0.1k
       xorg-server CVE-2014-8091..8103 fixes
     - Windows: Update nxproxy's Cygwin libraries from the
       latest versions as of 2014-06-09 to the
       latest versions as of 2014-10-18.

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Sat, 24 Jan 2015 16:50:02 +0000

This is an automatic notification regarding your Bug report
which was filed against the pyhoca-gui package:

#649: PyHoca-GUI 0.5.0.0 for Windows fails to start

It has been closed by Mike DePaulo <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike DePaulo <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go issue (in src:pyhoca-gui) has been marked as closed
From: Mike DePaulo <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Sat, 24 Jan 2015 17:44:41 +0100 (CET)

close #649
thanks

Hello,

light+love

---

Subject: PyHoca-GUI 0.5.0.0 for Windows fails to start
From: Mike DePaulo <[email-masked]>
To: [email-masked]
Date: Mon, 20 Oct 2014 17:45:12 -0400

package: pyhoca-gui
version: 0.5.0.0

I am fairly certain I followed the build instructions[1] correctly.
When I try to run Pyhoca-GUI via either the steps listed below (under Git Bash) or via the NSIS-installed start menu shortcut, neither the splash screen nor the tray icon appears.

 mike@EXECUTOR:/c/x2gobuilds/pyhoca-gui/dist :( [29] $ pyhoca-gui.exe
 mike@EXECUTOR:/c/x2gobuilds/pyhoca-gui/dist :) [40] $ pyhoca-gui.exe --debug --libdebug
 mike@EXECUTOR:/c/x2gobuilds/pyhoca-gui/dist :( [30] $ pyhoca-gui.exe --help
 mike@EXECUTOR:/c/x2gobuilds/pyhoca-gui/dist :( [31] $ pyhoca-gui.exe --version
 mike@EXECUTOR:/c/x2gobuilds/pyhoca-gui/dist :( [32] $ cd ..
 mike@EXECUTOR:/c/x2gobuilds/pyhoca-gui :) [33] $ which python
/c/Python27/python
 mike@EXECUTOR:/c/x2gobuilds/pyhoca-gui :) [34] $ python pyhoca-gui
Traceback (most recent call last):
  File "pyhoca-gui", line 46, in <module>
    app.main(args=args, logger=logger, liblogger=liblogger)
  File "c:\x2gobuilds\pyhoca-gui\pyhoca\wxgui\launcher.py", line 380, in main
    lang = gettext.translation('PyHoca-GUI', localedir=basepath.locale_basepath, languages=[args.lang], )
  File "c:\Python27\lib\gettext.py", line 469, in translation
    raise IOError(ENOENT, 'No translation file found for domain', domain)
IOError: [Errno 2] No translation file found for domain: 'PyHoca-GUI'
Exception KeyError: KeyError(37756240,) in <module 'threading' from 'c:\Python27\lib\threading.pyc'> ignored
 mike@EXECUTOR:/c/x2gobuilds/pyhoca-gui :) [38] $ python pyhoca-gui --debug --libdebug
Traceback (most recent call last):
  File "pyhoca-gui", line 46, in <module>
    app.main(args=args, logger=logger, liblogger=liblogger)
  File "c:\x2gobuilds\pyhoca-gui\pyhoca\wxgui\launcher.py", line 380, in main
    lang = gettext.translation('PyHoca-GUI', localedir=basepath.locale_basepath, languages=[args.lang], )
  File "c:\Python27\lib\gettext.py", line 469, in translation
    raise IOError(ENOENT, 'No translation file found for domain', domain)
IOError: [Errno 2] No translation file found for domain: 'PyHoca-GUI'
Exception KeyError: KeyError(39202128,) in <module 'threading' from 'c:\Python27\lib\threading.pyc'> ignored
 mike@EXECUTOR:/c/x2gobuilds/pyhoca-gui :) [36] $ python pyhoca-gui --version

pyhoca-gui[6312] - an X2Go GUI client written in Python
- ----------------------------------------------------------------------
developed by Mike Gabriel <[email-masked]>
sponsored by Dick Kniep <[email-masked]> (2010-2013)

VERSION: 0.5.0.0

Exception KeyError: KeyError(38477136,) in <module 'threading' from 'c:\Python27\lib\threading.pyc'> ignored

[1] http://wiki.x2go.org/doku.php/wiki:development:build-howto-mswin:pyhoca-gui