Subject: X2Go issue (in src:x2goserver) has been marked as closed

From: Mike Gabriel <[email-masked]>
Date: Mon, 6 Oct 2014 23:29:33 +0200 (CEST)

close #630
thanks

Hello,

we are very hopeful that X2Go issue #630 reported by you
has been resolved in the new release (4.0.1.18) of the
X2Go source project »src:x2goserver«.

You can view the complete changelog entry of src:x2goserver (4.0.1.18)
below, and you can use the following link to view all the code changes
between this and the last release of src:x2goserver.

    http://code.x2go.org/gitweb?p=x2goserver.git;a=commitdiff;h=8af2d72466b1ea3c8bc7fc247dcbb49f61c742c3;hp=9c4a4495d84f3508674a8aa4d7b307277f31589b

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:x2goserver.

Thanks a lot for contributing to X2Go!!!

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
X2Go Component: src:x2goserver
Version: 4.0.1.18-0x2go1
Status: RELEASE
Date: Mon, 06 Oct 2014 22:27:42 +0200
Fixes: 630
Changes: 
 x2goserver (4.0.1.18-0x2go1) RELEASED; urgency=medium
 .
   [ Horst Schirmeier ]
   * New upstream release (4.0.1.18):
     - Remove stale X11 lock files in cases where x2goagent mysteriously
       disappeared (e.g., due to kill -9 or a crash). (Fixes: #630).

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Mon, 06 Oct 2014 21:30:02 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2goserver package:

#630: clean up stable /tmp/.X<disp>-lock files

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go issue (in src:x2goserver) has been marked as closed
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Mon, 6 Oct 2014 23:29:33 +0200 (CEST)

close #630
thanks

Hello,

light+love

---

Subject: NX agent dies not reliably remove socket files under /tmp/.X11-unix
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Date: Thu, 02 Oct 2014 18:05:23 +0200

Package: nxagent
Version: 3.5.0.27
Severity: important

17:02 < bigfoot-> hmmm.  x2goagent is started with  -extension XFIXES 
                  -nolisten tcp -nolisten tcp -dpi 96 -D -auth 
                  /fs/staff/hsc/.Xauthority -geometry 800x600 -name 
                  X2GO-hsc-51-1412262126_stDmyxfce_dp24 :51
17:02 < bigfoot-> :50 is the already running (first) session
17:03 < bigfoot-> and x2goagent dies with 
                  https://pbot.rmdir.de/tt64QL-NNXqZomZoahDhJg

[...]

17:08 < bigfoot-> woglinde: I had to remove remaining /tmp/.X*-lock and 
                  /tmp/.X11-unix/X* that were owned by other users.  Works 
                  like a charm again now.
17:09 < bigfoot-> iow, a reboot would've helped, too (if it cleans up /tmp, 
                  that is).  but that's a non-option on this machine.

[...]

17:23 <@sunweaver> please report it as a bug!!!!
17:24 < bigfoot-> I'm still investigating; seeing this issue again now.  The 
                  process is as follows:
17:25 < bigfoot-> - some user logs in, gets :50
17:25 < bigfoot-> - some user logs in, gets :50
17:25 < bigfoot-> - /tmp/.X50-lock and /tmp/.X11-unix/X50 are owned by him now
17:25 < bigfoot-> - user logs out, which doesn't succeed completely (due to 
                  some yet unknown reason; he's got a default xfce setup in 
                  his home)
17:26 < bigfoot-> - user logs in via ssh and kills all his processes via  
                  killall -u username
17:26 < bigfoot-> afterwards, x2go seems to assume :50 is free, but the two 
                  aforementioned files still exist
17:26 < bigfoot-> the next user gets assigned :50, but this fails as the user 
                  doesn't have the permissions to access these files
17:27 < bigfoot-> So, who (or, which part of x2go) is responsible for removing 
                  these files?  When does/should this happen?

17:51 < bigfoot-> sunweaver: this change seemingly only changes the output, 
                  does this have an effect on the cleanup stuff?
17:51 <@sunweaver> no
17:51 <@sunweaver> the fix is four smoothing out mkigration from 4.0.1.15 to 
                   higher...
17:52 <@sunweaver> though there could be unexpected side effects...
17:52 <@sunweaver> there also is a patch in NX I introduced lately...
17:53 < bigfoot-> ok, but how should the new x2golistsessions and 
                  x2golistsessions_root affect my issue with cleanup?
17:55 <@sunweaver> http://code.x2go.org/gitweb?p=nx-libs.git;a=blob;f=debian/patches/027_nxcomp_abstract-X11-socket.full%2Blite.patch;h=4f614338cd51e19e05de87d097d623065d826d56;hb=bddc7e0ba4cef393ce56f75d1eb03255fe5ac6e1

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976148

GnuPG Key ID 0x25771B13
mail: [email-masked], http://das-netzwerkteam.de