Subject: Current Cairo test suite segfaults x2goagent

From: Moritz Struebe <[email-masked]>
Date: Wed, 28 Nov 2012 17:59:19 +0100

Package: x2goagent
Version: 3.5.0.16-0

x2goagant segfaults when running the cairo test suite. (The current
version only compiles on Wheezy)

This can be reproduced running:
git clone git://anongit.freedesktop.org/git/cairo
cd cairo
./autogen.sh
./configure
make
make test

As quite few tests fail Bugs #62 and #35 might be related to Cairo.

---

From: Mike Gabriel <[email-masked]>
Date: Mon, 13 Jun 2016 22:47:31 +0000

Control: tags -1 fixed-upstream
Control: fixed -1 3.5.99.0

Hi Morty,

long time not seen.

> As quite few tests fail Bugs #62 and #35 might be related to Cairo.

I am currently grilling my notebook by running the Cairo test cases  
against an nxagent with RANDR 1.5 support. I don't see anymore crashes.

However, still various of the test cases do fail. This seems to be a  
less severe issue, for tracking it, I have filed an "upstream" bug  
here [1].

Mike

[1] https://github.com/ArcticaProject/nx-libs/issues/140
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
mobile: +49 (1520) 1976 148
landline: +49 (4354) 8390 139

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/mailxchange/kronolith/fb.php?u=m.gabriel%40das-netzwerkteam.de