Subject: RE: Bug#628: (x2goclient can not be compiled on Raspberry PI)

From: Office NextITLevel GmbH <[email-masked]>
Date: Sun, 1 Feb 2015 19:44:52 +0000

Dear X2Go Developer,

please reopen this case:

I am using Raspian, which is the Debian Wheezy version.
I downloaded the x2goclient package from 
http://archive.raspbian.org/raspbian/pool/main/x/x2goclient/x2goclient_4.0.3.1-3_armhf.deb
and then I tried to install, but it failed.  This download version is for Debian Jessie.

 sudo dpkg -i x2goclient_4.0.3.1-3_armhf.deb
(Reading database ... 71974 files and directories currently installed.)
Preparing to replace x2goclient 4.0.3.1-3 (using x2goclient_4.0.3.1-3_armhf.deb) ...
Unpacking replacement x2goclient ...
dpkg: dependency problems prevent configuration of x2goclient:
 x2goclient depends on libc6 (>= 2.15); however:
  Version of libc6:armhf on system is 2.13-38+rpi2+deb7u7.
 x2goclient depends on libssh-4 (>= 0.5.4-2~); however:
  Version of libssh-4:armhf on system is 0.5.4-1+deb7u1.

dpkg: error processing x2goclient (--install):
 dependency problems - leaving unconfigured
Processing triggers for hicolor-icon-theme ...
Processing triggers for desktop-file-utils ...
Processing triggers for man-db ...
Errors were encountered while processing:
 x2goclient
----------------

And this is the compile script - and it should be fine

################################################################################
# build x2goclient
################################################################################

mkdir -p $HOME/x2go
cd $HOME/x2go

sudo apt-get update
# build deps of both nx-libs and x2goclient
sudo apt-get install -y libldap2-dev libssh-dev libx11-dev libxpm-dev
sudo apt-get install -y debhelper libpng-dev libjpeg-dev zlib1g-dev quilt libfontconfig1-dev libfontenc-dev libfreetype6-dev libxmltok1-dev libxml2-dev autoconf pkg-config x11proto-core-dev man2html-base
sudo apt-get install -y expat x11proto-kb-dev libssh-dev libcups2-dev
sudo apt-get install -y autotools-dev libqt4-gui libglib2.0-dev m4 qt4-qmake libqt4-dev dh-autoreconf

echo "Getting nx-libs and compiling ..."
git clone http://code.x2go.org/git/nx-libs.git
cd nx-libs
# git checkout redist-server/3.5.0.27
# This will take about 1 hour or so.
dpkg-buildpackage -us -uc
cd ..

# No new depenendcies for cups-x2go
echo "Getting cups-x2go and compiling ..."
git clone git://code.x2go.org/cups-x2go.git
cd cups-x2go
# git checkout 3.0.1.0
dpkg-buildpackage -us -uc
cd ..

echo "Getting x2goclient and compiling ..."
git clone http://code.x2go.org/git/x2goclient.git
cd x2goclient
# This will take a few minutes
dpkg-buildpackage -us -uc
cd ..

-------------------------------------------

So I used the newest code and compiled today and still I get:

Getting x2goclient and compiling ...
fatal: destination path 'x2goclient' already exists and is not an empty directory.
dpkg-buildpackage: source package x2goclient
dpkg-buildpackage: source version 4.0.3.2-0x2go1
dpkg-buildpackage: source changed by Mike Gabriel <[email-masked]>
 dpkg-source --before-build x2goclient
dpkg-buildpackage: host architecture armhf
dpkg-checkbuilddeps: Unmet build dependencies: libssh-dev (>= 0.5.4-2~)
dpkg-buildpackage: warning: build dependencies/conflicts unsatisfied; aborting
dpkg-buildpackage: warning: (Use -d flag to override.)

---

Debian Jessie is still not finished, so I have to use Debian Wheezy.

Have a nice day,
Franz Lückl

Next IT Level GmbH
Paul Tillich Str. 14
60528 Frankfurt
Handelsregister HRB 94885, Frankfurt am Main 
Finanzamt: Frankfurt/M. – USt-ID: DE285327933

Mobil DE:               	+49 152 3437 5620
Mobil AT:              	          +43 676 37 00 299
Mobiles Landline:    	+49 69 3487 8985

mailto:[email-masked] 
Internet Home Page:  http://www.nextitlevel.de

---

From: Mike Gabriel <[email-masked]>
Date: Mon, 02 Feb 2015 09:47:33 +0000

Hi Franz,

> dpkg-checkbuilddeps: Unmet build dependencies: libssh-dev (>= 0.5.4-2~)

Please get libssh >= 0.6.2 from Debian testing and build it from  
source on your rasbian system. Install the freshly built libssh-4 and  
libssh-dev on your build system.

   dget http://ftp.debian.org/debian/pool/main/libs/libssh/libssh_0.6.3-4.dsc
   cd libssh-0.6.3
   dpkg-buildpackage -uc -us
   cd ..
   sudo dpkg -i libssh*.deb

Then build X2Go Client as you already tried to.

Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb