Subject: Bug#620: x2goclient hides KDE kickoff start panel before application selection if panel auto hide option selected

From: Diego COSTE <[email-masked]>
Date: Wed, 24 Sep 2014 18:32:15 +0200

Package: x2goclient.x86_64
Version: 4.0.2.1-1.fc20

OS: KDE 4 on Fedora core 20 x86_64, yum-updated on Sept 23rd 2014 (both
client and server)

Description: This is now only a minor problem, as while writing this bug
report I found a way to work-around the issue.
By default I configure the main KDE panel to auto-hide: main panel (=
window manager status bar with main menu) shows only if I move the mouse
to the bottom of the screen (there is a similar option available in
Windows 95...7).

If I then access the Kickoff application launcher (start menu) with the
mouse, the menu closes after 1 or 2 seconds, before I select any
application or click on anything, so I can not access any app, except
the favourites which are available on the first menu page.
Problem does not occur when locally logging onto this server.
Problem does not occur on client's own KDE menu.
Once every 10-20 times, problem will not occur.
Problem does not occur if KDE panel is always shown (not auto-hidden) =>
Chosen work-around.

I have not found any similar bug report, but I also did not find any
easy way to search the bug reports (looking for KDE for ex).

Thank you for your kind help,
Diego

Client side:
Installed Packages
x2goagent.x86_64                                                                 
3.5.0.27-1.fc20                                              
@updates         
x2goclient.x86_64                                                                
4.0.2.1-1.fc20                                               
@updates         
x2goplugin.x86_64                                                                
4.0.2.1-1.fc20                                               
@updates         
x2goserver.x86_64                                                                
4.0.1.15-1.fc20                                              
@updates         
x2goserver-debuginfo.x86_64                                                      
4.0.1.15-1.fc20                                              
@updates-debuginfo
x2goserver-fmbindings.x86_64                                                     
4.0.1.15-1.fc20                                              
@updates         
x2goserver-printing.x86_64                                                       
4.0.1.15-1.fc20                                              
@updates         
x2goserver-xsession.x86_64                                                       
4.0.1.15-1.fc20                                              
@updates         

Server side:
Installed Packages
x2goagent.x86_64                                                               
3.5.0.27-1.fc20                                                     @updates
x2goserver.x86_64                                                              
4.0.1.15-1.fc20                                                     @updates

---

From: Mike Gabriel <[email-masked]>
Date: Wed, 24 Sep 2014 19:15:48 +0000

Control: reassign -1 x2goclient
Control: found 4.0.2.1

Hi Diego,

> Problem does not occur if KDE panel is always shown (not auto-hidden) =>

Is this maybe a duplicate of the freshly reported issue #618 [1]?  
Hmmm... now that I read the complete subject of your original mail, I  
guess not.

> easy way to search the bug reports (looking for KDE for ex).

Mike

[1] http://bugs.x2go.org/618

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: Diego COSTE <[email-masked]>
Date: Thu, 25 Sep 2014 11:08:22 +0200

Hi Mike,

this is not the same problem.
The panel always gets displayed when I move to the bottom of the screen,
but not long enough.
I suppose that at this moment KDE considers that the mouse cursor is not
over the menu any more and therefore auto-hides it.
I suspect there might be some special moves of the cursor right after
initial display of the panel that enable persistent display of the menu,
but I did not manage to guess any logic that would consistently lead to
this expected behaviour.
When it occurs though, the menu may remain displayed indefinitely.

Diego

---

From: Mike Gabriel <[email-masked]>
Date: Thu, 25 Sep 2014 09:57:49 +0000

Control: reassign -1 nxagent
Control: forcemerge -1 #492

Hi Diego,

> When it occurs though, the menu may remain displayed indefinitely.

Ohhhh, now I get what you mean... We actually have a bug report like that:

I guess your issue and #492 [1] boil down to the same reason.

The problem is that NX in windowed desktop session mode does not  
handle it well, when the mouse pointer leaves the window / crosses the  
NX desktop window border.

Can you please do one thing for me? -> Launch a KDE session in Xephyr,  
using the same user profile. How does Xephyr handle it when the mouse  
pointer is moved to the bottom border of the windowed X11/Xephyr  
session?

Mike

[1] http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=492

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

---

From: Diego COSTE <[email-masked]>
Date: Fri, 26 Sep 2014 11:29:44 +0200

Hi Mike,

please remember this is only a minor problem, so do not waste too much time on it.
Anyway, here is my feedback:

On 25/09/14 11:57, Mike Gabriel wrote:
Ohhhh, now I get what you mean... We actually have a bug report like that:

The problem is that NX in windowed desktop session mode does not handle it well, when the mouse pointer leaves the window / crosses the NX desktop window border.

=> Not sure it is the same issue as in my case the x2go window occupies one full screen (without window decorations), so the bottom of the screen is the bottom of the remote desktop, and I can not go further. When moving to the bottom of the screen in that mode the menu bar always gets displayed.

The problem occurs the same whether x2go is set to full screen or windowed mode.

Something strange: if I leave the screen or window by the proper edge (bottom left corner), the menu window:
 will disappear after the usual 1-2 seconds of this problem, but the menu bar:
remains displayed indefinitely instead of auto-hiding, as if the cursor was still stuck at the bottom left of the desktop.

Can you please do one thing for me? -> Launch a KDE session in Xephyr, using the same user profile. How does Xephyr handle it when the mouse pointer is moved to the bottom border of the windowed X11/Xephyr session?
Ok, I have tried
  Xephyr :1 -ac -screen 800x600 &
  export DISPLAY=:1
  dbus-launch /usr/bin/startkde
The default start menu is still set to auto-hide, but in Xephyr I have no problem: the menu remains open as long as the cursor stays on top of it.
I can even leave the Xephyr window by the bottom left corner and the menu remains displayed indefinitely together with the menu bar.

Thank you for your kind help
Diego