Subject: Bug#62:

From: <[email-masked]>
Date: Thu, 19 Mar 2015 10:18:45 +0000

We're encountering the same problem here.

gnome-control-center

(gnome-control-center:28288): Gdk-WARNING **: The program 'gnome-control-center' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadLength (poly request too large or internal Xlib length erro'.
  (Details: serial 153 error_code 16 request_code 147 minor_code 1)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 7.6 (wheezy)
Release:        7.6
Codename:       wheezy

dpkg -l x2go\* nx\* gnome-session-fallback gnome-control-center | grep ^ii
ii  gnome-control-center                  1:3.4.3.1-2                                     amd64        utilities to configure the GNOME desktop
ii  gnome-session-fallback                3.4.2.1-4                                       all          GNOME Session Manager - GNOME fallback session
ii  nxagent                               2:3.5.0.28-0x2go1+git20141113.546+wheezy.main.1 amd64        NX agent
ii  x2goagent                             2:3.5.0.28-0x2go1+git20141113.546+wheezy.main.1 all          X2Go agent
ii  x2goserver                            4.0.1.18-0x2go1+git20141006.949+wheezy.main.1   amd64        X2Go server daemon scripts
ii  x2goserver-extensions                 4.0.1.18-0x2go1+git20141006.949+wheezy.main.1   all          X2Go server daemon scripts (extensions)
ii  x2goserver-fmbindings                 4.0.1.18-0x2go1+git20141006.949+wheezy.main.1   all          Generic (freedesktop-based) file manager bindings for X2Go
ii  x2goserver-pyhoca                     4.0.1.18-0x2go1+git20141006.949+wheezy.main.1   all          X2Go server daemon scripts (add-ons for pyhoca client)
ii  x2goserver-xsession                   4.0.1.18-0x2go1+git20141006.949+wheezy.main.1   all          X2Go server daemon scripts (Xsession runner)

Is there a workaround we could use to be able to launch gnome-control-center while you're working on a fix ?

---

From: Mike Gabriel <[email-masked]>
Date: Fri, 15 May 2015 12:16:33 +0000

Control: retitle -1 BadLength (poly request too large or internal Xlib  
length error)

On  Do 19 Mär 2015 11:18:45 CET, Yvan.Broccard wrote:

> (gnome-control-center:28288): Gdk-WARNING **: The program  
> 'gnome-control-center' received an X Window System error.
> gnome-control-center while you're working on a fix ?

We will get to fixing this issue soon.

Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: Mike Gabriel <[email-masked]>
Date: Fri, 15 May 2015 12:25:46 +0000

Control: tags -1 moreinfo

HI again,

>    backtrace from your debugger if you break on the gdk_x_error() function.)

I actually just tested this on a Debian jessie X2Go Server.

I use MATE desktop, so I launched gnome-control-center inside the MATE  
session from the command line.

If GLX in x2goagent is disabled [1], then gnome-control-center  
launches successfully.

If GLX in x2goagent is enabled, then gnome-control-center crashes,  
because it cannot load clutter. This, however, I consider a bug in  
gnome-control-center. If a GNOME application cannot load clutter due  
to lack of sufficient GLX support, the GNOME application (i.e.,  
gnome-control-center) should fall-back to a non-GLX mode.

Could you provide the exact steps for reproducing this issue?

Thanks,
Mike
-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy: