Subject: Bug#604: Windows: VcXsrv lacking minimize, maximize and close buttons under certain conditions

From: Michael DePaulo <[email-masked]>
Date: Sat, 13 Sep 2014 18:05:45 -0400

Package: x2goclient
Version:4.0.3.0-2014.09.13-0d99760
Severity: normal
Tags: + build-win32

Compare images 1 and 2 here:
http://imgur.com/a/0FP4c

I've observed that when I configure the session to have a resolution
of 2046x1150 (2048x1152 minus 2x2) or higher, the mimize, maximize and
close buttons are missing.

When I configure the session to have a resolution of 2000x1100 or
smaller, the buttons do show up (and do work.)

It's also worth noting that the title bar is a different color, and
that when the buttons are missing, the X2Go icon is also missing in
the title bar.

I have not narrowed down what the exact threshold is.

This is probably relevant to my monitor config. Notice that my
secondary monitor is on the left, and its resolution is 2048x1152.

My monitor config is shown on images 3 and 4 under the same link as before:
http://imgur.com/a/0FP4c

I'm thinking that this bug is related to Alex's winmultiwindow.patch
for VcXsrv that was included as part of bug #568

Further test configuration details:

Client:
- Observed on both MinGW 4.4 + Qt 4.8.5 and MinGW 4.8.2 + Qt 4.8.6 builds.
- Client machine is Windows 8.1 64-bit with all available updates installed.
- As specified, the X2Go Client version is 4.0.3.0-2014.09.13-0d99760.
This build includes VcXsrv 1.15.2.0-xp+vc2013+x2go1 , which includes
winmultiwindow.patch.
- Session is set to windowed mode (this is implied by the fact that I
am setting the resolution)
- Xinerama is enabled in the client

Server:
- Ubuntu 14.04.1 64-bit
- x2goserver 4.0.1.15-0~847~ubuntu14.04.1
- x2goserver-xsession 4.0.1.15-0~847~ubuntu14.04.1
- nxagent 2:3.5.0.27-0~446~ubuntu14.04.1

---

From: Sophia jasper <[email-masked]>
Date: Thu, 11 Feb 2021 12:56:05 +0000

Greetings I am  Sophia jasper. I hope we can start a relationship please reply me