X2Go Bug report logs - #591
No system tray for remote applications

version graph

Package: nxagent; Maintainer for nxagent is X2Go Developers <x2go-dev@lists.x2go.org>; Source for nxagent is src:nx-libs.

Reported by: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>

Date: Tue, 2 Sep 2014 17:00:01 UTC

Severity: normal

Found in version 3.5.0.27

Full log


🔗 View this message in rfc822 format

X-Loop: owner@bugs.x2go.org
Subject: Bug#591: Works under certain configurations, not others
Reply-To: Tristan Miller <psychonaut@nothingisreal.com>, 591@bugs.x2go.org
Resent-From: Tristan Miller <psychonaut@nothingisreal.com>
Resent-To: x2go-dev@lists.x2go.org
Resent-CC: X2Go Developers <x2go-dev@lists.x2go.org>
X-Loop: owner@bugs.x2go.org
Resent-Date: Mon, 08 Sep 2014 07:50:01 +0000
Resent-Message-ID: <handler.591.B591.141016231621534@bugs.x2go.org>
Resent-Sender: owner@bugs.x2go.org
X-X2Go-PR-Message: followup 591
X-X2Go-PR-Package: nxagent
X-X2Go-PR-Keywords: 
Received: via spool by 591-submit@bugs.x2go.org id=B591.141016231621534
          (code B ref 591); Mon, 08 Sep 2014 07:50:01 +0000
Received: (at 591) by bugs.x2go.org; 8 Sep 2014 07:45:16 +0000
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=0.8 required=5.0 tests=BAYES_50,T_DKIM_INVALID
	autolearn=ham version=3.3.2
X-Greylist: delayed 541 seconds by postgrey-1.34 at ymir.das-netzwerkteam.de; Mon, 08 Sep 2014 09:45:13 CEST
Received: from hapkido.dreamhost.com (hapkido.dreamhost.com [66.33.216.122])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTP id D5F1F5DEA7
	for <591@bugs.x2go.org>; Mon,  8 Sep 2014 09:45:13 +0200 (CEST)
Received: from homiemail-a35.g.dreamhost.com (sub4.mail.dreamhost.com [69.163.253.135])
	by hapkido.dreamhost.com (Postfix) with ESMTP id 39ADC8CEA4
	for <591@bugs.x2go.org>; Mon,  8 Sep 2014 00:36:10 -0700 (PDT)
Received: from homiemail-a35.g.dreamhost.com (localhost [127.0.0.1])
	by homiemail-a35.g.dreamhost.com (Postfix) with ESMTP id A2F1B5405B;
	Mon,  8 Sep 2014 00:36:08 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha1; c=relaxed; d=nothingisreal.com; h=from
	:to:subject:date:cc:references:in-reply-to:mime-version
	:content-type:content-transfer-encoding:message-id; s=
	nothingisreal.com; bh=ENvpgPRT18Bchu7exOsCFxPFR0U=; b=GZ5fWEN1WT
	/Fj9f3wpQY7R5ven69D8mk35erjV+8WQGQgGxZD/E8Y/luUO72yxfs4qsyQYg3Eb
	cWzR5uB0tSs6UIZwDO7YXW8Dbvp8VEuxFZtEDdkBqW9rebhTdZu2ZRDsqvHp2FRt
	waIeKlSAlqYZDNNw410O5d3ejVLYweoeM=
Received: from ferret.nothingisreal.com (unknown [5.146.55.210])
	(Authenticated sender: psychonaut@nothingisreal.com)
	by homiemail-a35.g.dreamhost.com (Postfix) with ESMTPA id 760B154057;
	Mon,  8 Sep 2014 00:36:08 -0700 (PDT)
Received: by ferret.nothingisreal.com (Postfix, from userid 1000)
	id 401471E397D; Mon,  8 Sep 2014 09:36:07 +0200 (CEST)
From: Tristan Miller <psychonaut@nothingisreal.com>
Organization: http://www.nothingisreal.com/
To: Michael DePaulo <mikedep333@gmail.com>
Date: Mon, 8 Sep 2014 09:36:02 +0200
User-Agent: KMail/1.13.6 (Linux/3.0.101-87-desktop; KDE/4.6.0; x86_64; ; )
Cc: 591@bugs.x2go.org
References: <CAMKht8hKZDwaoPhQ6GwqUQGdZQYEb6EoeigNZ_mXZr6984epZA@mail.gmail.com>
In-Reply-To: <CAMKht8hKZDwaoPhQ6GwqUQGdZQYEb6EoeigNZ_mXZr6984epZA@mail.gmail.com>
X-Face: +'.$MW;WL+15WP2[f8|r8O\S#>m6}ktRO.amg`O6Aa)Q9tIzDR%$k
X-Accept-Language: en-ca, en-gb, en-us, en, fr, de, ia, x-folkspraak, is, hu
MIME-Version: 1.0
Content-Type: multipart/signed;
  boundary="nextPart4028610.li5ofmF6F9";
  protocol="application/pgp-signature";
  micalg=pgp-sha1
Content-Transfer-Encoding: 7bit
Message-Id: <201409080936.06612.psychonaut@nothingisreal.com>
[Message part 1 (text/plain, inline)]
Greetings.

On Sunday 07 September 2014, Michael DePaulo wrote:
> 1. I was *able* to reproduce this bug under X2Go Client for Windows.
> To be perfectly clear, it only happens when you are launching a remote
> application ("Single Application" or "Published Application"), not
> when you are launching a KDE session.

Yes, that's right.  Sorry for not mentioning this; I never launch entire 
desktop sessions so I'd forgotten to test that.  I can also confirm that 
for me the system tray icon has always appeared as expected when launching 
the applications over a regular OpenSSH session with X11 forwarding.  It's 
only when launching a single application from x2go that the problem occurs.

Regards,
Tristan

-- 
   _
  _V.-o         Tristan Miller          ><  Space is limited
 / |`-'  -=-=-=-=-=-=-=-=-=-=-=-=-=-=-  <>  In a haiku, so it's hard
(7_\\    http://www.nothingisreal.com/  ><  To finish what you
[signature.asc (application/pgp-signature, inline)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Thu Apr 18 22:44:38 2024; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.