Subject: Bug#585: X2Go issue (in src:nx-libs) has been marked as closed

From: Mike Gabriel <[email-masked]>
Date: Thu, 13 Nov 2014 21:56:45 +0100 (CET)

close #585
thanks

Hello,

we are very hopeful that X2Go issue #585 reported by you
has been resolved in the new release (2:3.5.0.28) of the
X2Go source project »src:nx-libs«.

You can view the complete changelog entry of src:nx-libs (2:3.5.0.28)
below, and you can use the following link to view all the code changes
between this and the last release of src:nx-libs.

    http://code.x2go.org/gitweb?p=nx-libs.git;a=commitdiff;h=39202bb0cfad1a5d78135a205033398003769997;hp=aeb5e8ad5491b9f950cb038ca6eb6b1e15fef05a

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:nx-libs.

Thanks a lot for contributing to X2Go!!!

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
X2Go Component: src:nx-libs
Version: 2:3.5.0.28-0x2go1
Status: RELEASE
Date: Thu, 13 Nov 2014 21:39:24 +0100
Fixes: 269 578 585 610 621
Changes: 
 nx-libs (2:3.5.0.28-0x2go1) RELEASED; urgency=medium
 .
   [ Mike Gabriel ]
   * Provide COPYING file in tarball. Update debian/copyright.
   * Add 025_nxcomp-fix-ftbfs-against-jpeg9a.full+lite.patch. Fix FTBFS when
     built against libjpeg9a. Thanks to Gabriel Marcano for sending this in.
     (Fixes: #578).
   * Update 027_nxcomp_abstract-X11-socket.full+lite: Add patch header
     (Description: and Author: field).
   * Add 607_nxcomp_macosx-X11-launcher-in-private-tmp.full+lite.patch. Fix check
     for launchd socket path in $DISPLAY on recent Mac OS X systems.
   * Rename 605_nxcomp_Types.h-dont-use-STL-internals-on-libc++.full.patch to
     605_nxcomp_Types.h-dont-use-STL-internals-on-libc++.full+lite.patch. It is
     an nxcomp patch that needs to be applied in the nx-libs-lite _and_ the
     nx-libs-full tarball release.
   * debian/libnx-x11.postinst:
     + Don't use dpkg-architecture (bin:package dpkg-dev) in postinst script.
       Instead prep a libnx-x11.postinst script at build time. (Fixes:
       #621).
   * debian/rules:
     + No such option for dh_auto_build: --with quilt."
   * nx-libs.spec:
     + Adapt installation of debian/VERSION as VERSION.x2goagent and
       nxcomp/VERSION to latest changes introduced by
       400_nxcomp-version.full+lite.patch.
     + Additionally adapt to building on openSUSE/SLES.
     + SUSE hack for linking to files in libX11-6 and libXext6.
     + Make sure all package directories are owned by one of the
       built bin:packages.
     + Fix Xinerama symlink installation into RPM bin:package
       libNX_Xinerama. (Fixes: #269).
 .
   [ Nito Martinez ]
   * Add 400_nxcomp-version.full+lite.patch. Allow 4-digit version comparison
     during NX session handshake. (Fixes: #610).
 .
   [ Ulrich Sibiller ]
   * Add 207_nxagent_fix-xfixes-selection.full.patch. Fix selection handling
     when XFIXES is enabled. (Fixes: #585).

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Thu, 13 Nov 2014 21:00:18 +0000

This is an automatic notification regarding your Bug report
which was filed against the nx-libs package:

#585: Clipboard handling with XFIXES broken

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go issue (in src:nx-libs) has been marked as closed
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Thu, 13 Nov 2014 21:56:45 +0100 (CET)

close #585
thanks

Hello,

light+love

---

Subject: Clipboard handling with XFIXES broken
From: Ulrich Sibiller <[email-masked]>
To: [email-masked]
Date: Wed, 27 Aug 2014 23:31:39 +0200

Package: nx-xlibs
Version: 3.5.0-27

I have found a clipboard problem which only occurs when the XFIXES
extension is active. Sometimes qt applications running inside the
session cannot paste what has been selected outside the session.

Steps to reproduce:
1. start a new session (rootless or desktop, does not matter)
2. start at qt application within the session (I tried konsole and kedit)
3. start an xterm outside the session
4. select/mark some text in the qt app
5. paste the selection in the xterm with middle mouse button -> works
6. select/mark something in the xterm
7. paste the xterm selection with middle mouse button in the qt app ->
does not work, the text selected in step 4 gets pasted instead

I have tried that on Ubuntu 14.04, CentOS 6.5 and OpenSuse 11.4. These
all have different QT (and KDE) versions. I could provoke this on all
versions.

Workaround: turn off XFIXES extension

Some further observation:

If you run xfixes-selection.pl
(http://cpansearch.perl.org/src/KRYDE/X11-Protocol-Other-29/examples/xfixes-selection.pl)
both inside and outside the x2go/nx session while reproducing this you
can see that the SetSelectionOwner event of the XFIXES extension does
not reach the x2goagent when something is selected in the xterm but
both sides receive that event wehn something is selected in the qt
app.