Subject: x2go Session Broker don't work with shadow sessions

From: KeRo <[email-masked]>
Date: Tue, 26 Aug 2014 19:08:26 +0200

Package: x2gobroker

Version: 0.0.3.0

I have two type of broker session configured, MATE for normal desktop use
and a SHADOW session for support and presentation. MATE sessions work fine
but SHADOW session show Access Denied throw broker (Direct shadow session
configured in x2go client work fine)

The session displays of shadow connection dont appear throw broker :S

x2go Server is a Ubuntu Desktop 14.04 with MATE

Error in x2go Server syslog:

NOVEA-desk /usr/bin/x2gostartagent: user ,,pam'' requests desktop sharing
from user ,,'' for desktop ,,''
NOVEA-desk /usr/bin/x2gostartagent: ERROR: user  denied desktop sharing
session

Broker sessions config:

[DEFAULT]
command=TERMINAL
defsndport=true
useiconv=false
iconvfrom=UTF-8
height=768
export=
quality=9
fullscreen=false
layout=es
useexports=true
width=1024
speed=2
soundsystem=pulse
print=true
type=pc105/es
sndport=4713
xinerama=true
variant=
usekbd=true
fstunnel=true
applications=TERMINAL,WWWBROWSER,MAILCLIENT,OFFICE
multidisp=false
sound=true
rootless=true
iconvto=UTF-8
soundtunnel=true
dpi=96
sshport=22
setdpi=0
pack=16m-jpeg
directrdp=false
user=BROKER_USER
usesshproxy=true
sshproxytype=SSH
sshproxyhost=broker.test.com
sshproxyport=22
sshproxyautologin=false
sshproxysamepass=true
sshproxysameuser=true

[NOVEA-pim-access]
name=NOVEA ACCESS
host=172.16.110.101
command=MATE
acl-users-allow=pim
acl-users-deny=ALL
acl-clients-deny=ALL
acl-clients-allow=0.0.0.0/0
acl-any-order=deny-allow

[NOVEA-pim-support]
name=NOVEA Support
host=172.16.110.101
command=SHADOW
acl-users-allow=pim
acl-users-deny=ALL
acl-clients-deny=ALL
acl-clients-allow=0.0.0.0/0
acl-any-order=deny-allow

[NOVEA-pam-access]
name=NOVEA ACCESS
host=172.16.110.101
command=MATE
acl-users-allow=pam
acl-users-deny=ALL
acl-clients-deny=ALL
acl-clients-allow=0.0.0.0/0
acl-any-order=deny-allow

[NOVEA-pam-support]
name=NOVEA Support
host=172.16.110.101
command=SHADOW
acl-users-allow=pam
acl-users-deny=ALL
acl-clients-deny=ALL
acl-clients-allow=0.0.0.0/0
acl-any-order=deny-allow

Thanks for your help.

---

From: Mike Gabriel <[email-masked]>
Date: Wed, 27 Aug 2014 07:25:47 +0000

Hi KeRo,

> acl-clients-allow=0.0.0.0/0

This one is an interesting bug. Of course, shadow sessions should be  
supported by the broker. Will take a look soon.

Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: Mike Gabriel <[email-masked]>
Date: Tue, 17 Mar 2015 16:57:51 +0000

Control: reassign -1 x2goclient
Control: found -1 4.0.4.0

Hi,

> configured in x2go client work fine)

I just played with the broker, the SHADOW session command and PyHoca-GUI.

With PyHoca-GUI, I can launch desktop sharing sessions just like  
normal sessions.

Thus, reassigning to X2Go Client.

Fixing this issue is subject to contracted work which I will do during  
this week.

Mike
-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

---

From: Mike Gabriel <[email-masked]>
Date: Thu, 19 Mar 2015 01:09:50 +0000

Control: tags -1 patch

Hi Mihai,

On  Di 17 Mär 2015 17:57:51 CET, Mike Gabriel wrote:

> Fixing this issue is subject to contracted work which I will do  
> during this week.
>
> Mike

Can you please review [1] and merge to master?

Thanks,
Mike

[1]  
http://code.x2go.org/gitweb?p=x2goclient.git;a=commitdiff;h=282be1c1b5362e1a3e27932e3bfbd960d1753a1f
-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy: