X2Go Bug report logs - #583
Windows client closes session when inactive

version graph

Package: x2goclient; Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: Pavel Hanák <hanak@is-it.eu>

Date: Tue, 26 Aug 2014 13:50:01 UTC

Severity: normal

Found in version 4.2.0.1+hotfix1+build3

Done: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>

Bug is archived. No further changes may be made.

Full log


Message #10 received at 583@bugs.x2go.org (full text, mbox, reply):

Received: (at 583) by bugs.x2go.org; 27 Aug 2014 13:18:56 +0000
From mikedep333@gmail.com  Wed Aug 27 15:18:55 2014
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=0.8 required=5.0 tests=BAYES_50,FREEMAIL_FROM,
	T_DKIM_INVALID autolearn=ham version=3.3.2
Received: from mail-we0-f179.google.com (mail-we0-f179.google.com [74.125.82.179])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id 2150D5DB3E
	for <583@bugs.x2go.org>; Wed, 27 Aug 2014 15:18:55 +0200 (CEST)
Received: by mail-we0-f179.google.com with SMTP id u57so207220wes.10
        for <583@bugs.x2go.org>; Wed, 27 Aug 2014 06:18:51 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=gmail.com; s=20120113;
        h=mime-version:date:message-id:subject:from:to:content-type;
        bh=fksDPpoBHxfyr1vqKSXbA00tvwGk/M8OpSTeRrTuOZg=;
        b=cXKbSLS3Qis6Gv5ieZmW5vqcywyRgObdsmJGSORbdBzgDra2CHIHAoG45EKMaaSkkM
         AAbYCDBF02ltKXgzeNj/bfk5Lo+6Op6UiH9YSivyVGwWXG0wPKR+ulIcnoYY5kXJeAgH
         mGtJr0NjRuNr7rTaXtrO/xdpXg2u8lder1J+0lXPM5YsSk1cYmKJly5dHwjl7VJfqdU1
         eiW8dkS7nSIPPI2O7KHeM8IzMCJrM8NN/kUrmmSkf8MKZENQpH9H9YEACY076hM7150R
         TalA7MjHUBb557i2XRO+2zrEfGdxc9aeQQXmtEz+NhNwm4GWw1aIKWTFu1Jy521uRWla
         XjLg==
MIME-Version: 1.0
X-Received: by 10.180.73.142 with SMTP id l14mr9781160wiv.83.1409145531037;
 Wed, 27 Aug 2014 06:18:51 -0700 (PDT)
Received: by 10.180.238.66 with HTTP; Wed, 27 Aug 2014 06:18:50 -0700 (PDT)
Date: Wed, 27 Aug 2014 09:18:50 -0400
Message-ID: <CAMKht8iZVrFebgs2o92U3oC1j5xiVzuUJj3FiFz3JsnFJVtxMw@mail.gmail.com>
Subject: affects me too
From: Michael DePaulo <mikedep333@gmail.com>
To: 583@bugs.x2go.org
Content-Type: text/plain; charset=UTF-8
I think I'm seeing this bug at work on one specific client and one
specific server. We were purposely using an old version of x2goclient
(4.0.0.3) and x2goserver/nx-libs. I haven't investigated it further
because the funding for this specific use case is about to end.

However, note that I think this happens when the vcxsrv.exe process's
window (the actual remote desktop window) is minimized, not when the
x2goclient.exe QT4 window is minimized. Also, it seems to happen after
about 10-30 seconds of the window being minimized, not 7-12 minutes.
And when I try to reconnect, it works, but the session is suspended,
so I have to resume it 1st. The need to resume it might be bug #511.


Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Fri Dec 13 21:50:02 2019; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.