Subject: X2Go issue (in src:x2goclient) has been marked as pending for release

From: Mike DePaulo <[email-masked]>
Date: Wed, 3 Sep 2014 06:36:12 +0200 (CEST)

tag #568 pending
fixed #568 4.0.3.0
thanks

Hello,

X2Go issue #568 (src:x2goclient) reported by you has been
fixed in X2Go Git. You can see the changelog below, and you can
check the diff of the fix at:

    http://code.x2go.org/gitweb?p=x2goclient.git;a=commitdiff;h=e7b1df8

The issue will most likely be fixed in src:x2goclient (4.0.3.0).

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
commit e7b1df823c35f5fd998ad8c568285418cd2be804
Author: Mike DePaulo <[email-masked]>
Date:   Wed Sep 3 00:36:03 2014 -0400

    Windows: Bundle new version of VcXsrv: 1.15.2.0-xp+vc2013+x2go1 (Fixes: #568)

diff --git a/debian/changelog b/debian/changelog
index 7886078..9b6f136 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -47,6 +47,11 @@ x2goclient (4.0.3.0-0x2go1) UNRELEASED; urgency=low
       groups optional: misc, 75dpi, 100dpi and others (Fixes: #108)
       Note: The fact that all the fonts are included makes the installer about
       30MB larger.
+    - Windows: Bundle new version of VcXsrv: 1.15.2.0-xp+vc2013+x2go1
+      This new version is based on upstream VcXsrv 1.15.2.0, but still
+      compatible with Windows XP. It is compiled with Microsoft Visual C++ 2013
+      and contains 1 X2Go-specific change, winmultiwindow.patch
+      (Thanks Oleksandr Shneyder for the patch) (Fixes: #568)
     - Windows: Fix missing VcXsrv/zlib1.dll . The impact of this bug was that
       VcXsrv would not start if the cwd was changed from the x2goclient
       directory. (The start menu and desktop shortcuts do have the x2goclient

---

From: Mike Gabriel <[email-masked]>
Date: Fri, 05 Sep 2014 07:21:29 +0000

Hi Mike#2, hi Alex,

> +      (Thanks Oleksandr Shneyder for the patch) (Fixes: #568)

has anyone of you upstreamed that winmultiwindow.patch? If not, does  
it make sense to do so?

Thanks+Greets,
Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: Michael DePaulo <[email-masked]>
Date: Fri, 5 Sep 2014 06:14:48 -0400

On Fri, Sep 5, 2014 at 3:21 AM, Mike Gabriel
<[email-masked]> wrote:
> has anyone of you upstreamed that winmultiwindow.patch? If not, does it make
> sense to do so?
>
> Thanks+Greets,
> Mike
[...]

Hi Mike#1

1. in a private email convo (I am not sure why Alex didn't CC
x2go-dev), Alex wrote:
On Tue, Sep 2, 2014 at 8:29 AM, Oleksandr Shneyder
<[email-masked]> wrote:
> I didn't found a bug itself but was able to creat a workaround, which
> makes x2goclient to work properly. See the patch in attachment.
For this reason, I assumed that winmultiwindow.patch was an
X2Go-specific change and could not be upstreamed.

2. I did also make the change of updating OpenSSL from 1.0.1h to
1.0.1i and attempt to upstream it:
https://sourceforge.net/u/mikedep333/vcxsrv/ci/268dab3031388bf198f48d0987c3e116cd7fb5c6/log/?path=
It seems like SourceForge's "Merge Request" feature is broken.
However, I have yet to receive a response from upstream anyway:
https://sourceforge.net/p/vcxsrv/code/merge-requests/1/
(Actually submitted on September 1st. The fact that I posted a comment
just now caused SourceForge to miscalculate the age of the Merge
Request. That's another bug with SourceForge :( ).
https://sourceforge.net/p/vcxsrv/code/merge-requests/3/