Subject: Bug#564: x2goclient for windows 4.0.2.1+hotfix1+build2 gives error dialog "Connection failed Can not open file -"

From: Michael DePaulo <[email-masked]>
Date: Thu, 7 Aug 2014 23:28:24 -0400

package: x2goclient
version: 4.0.2.1+hotfix1+build2

Even though the only differences between X2Go Client for Windows
4.0.2.1+hotfix1 and 4.0.2.1+hotfix1+build2 are the versions of these 3
files, which are unmodified from upstream:
cygcrypto-1.0.0.dll
libeay32.dll
ssleay32.dll
(They were upgraded from openssl 1.0.1h to openssl 1.0.1i)
Much to my surprise, a regression was introduced.

When you I connect to an existing session or a new session, I now get
an error dialog with the following text in bold:
Connection failed
and  then the following text not in bold, separated by a space:
Can not open file -
The session still however opens. I haven't tested how well it works though.

Screenshot:
http://imgur.com/QJWeJGp

IIRC, I got this error in the past when I had not applied our patch to
cygwin openssh:
http://code.x2go.org/releases/source/openssh-cygwin/
Perhaps cygwin openssh needs to be rebuilt against the updated openssl?

Client:
Windows 8.1 64-bit with Update 1 and most updates installed (only 1
optional update not installed, KB2967917)
x2goclient version specified above

Server:
Ubuntu 14.04 64-bit with latest bugfix and security updates
MATE 1.8.0 from packages.mate-desktop.org repo
MATE session
x2goserver 4.0.1.15-0~847~ubuntu14.04.1
x2goserver-xsession 4.0.1.15-0~847~ubuntu14.04.1
x2ogoagent 2:3.5.0.27-0~446~ubuntu14.04.1
nxagent 2:3.5.0.27-0~446~ubuntu14.04.1

---

From: Mike Gabriel <[email-masked]>
Date: Fri, 08 Aug 2014 10:51:16 +0000

Hi Michael,

> Perhaps cygwin openssh needs to be rebuilt against the updated openssl?

without knowing much about details on cygwin. In gernal, rebuilds are  
necessary if any of the related components is statically linked. If  
you do dynamic linking all over the place, then there should be no  
need to rebuild.

Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Sun, 10 Aug 2014 14:00:02 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2goclient package:

#564: x2goclient for windows 4.0.2.1+hotfix1+build2 gives error dialog "Connection failed Can not open file -"

It has been closed by Michael DePaulo <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Michael DePaulo <[email-masked]> by
replying to this email.

-- 
564: http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=564
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: fixed
From: Michael DePaulo <[email-masked]>
To: [email-masked]
Date: Sun, 10 Aug 2014 09:55:18 -0400

Package: x2goclient
Version: 4.0.2.1+hotfix1+build3

Subject: x2goclient for windows 4.0.2.1+hotfix1+build2 gives error dialog "Connection failed Can not open file -"
From: Michael DePaulo <[email-masked]>
To: [email-masked]
Date: Thu, 7 Aug 2014 23:28:24 -0400

package: x2goclient

Screenshot:
http://imgur.com/QJWeJGp

Client:

Server: