Subject: Bug#562: python-x2gobroker RPM package should use python-pam

From: Bengt Giger <[email-masked]>
Date: Wed, 6 Aug 2014 15:35:38 +0200

Package: python-x2gobroker
Version: 0.0.3.0

Fedora nightly RPM for python-x2gobroker has dependency "python-pampy". This package exists but is named differently: "python-pam".

Don't be confused by the fact that Debian has a python-pam that is made from different sources! Debian python-pam is a GPL licensed package by Rob Riggs, while Debian python-pampy and Fedora python-pam are the MIT licensed package by Chris AtLee. Fedora 20 is currently behind with V0.1.3 but Fedora 21 will ship with V0.1.4.

Regards
Bengt

---

From: Mike Gabriel <[email-masked]>
Date: Wed, 06 Aug 2014 16:52:26 +0000

Hi Bengt,

On  Mi 06 Aug 2014 15:35:38 CEST, Bengt Giger wrote:

> Fedora nightly RPM for python-x2gobroker has dependency  
> "python-pampy". This package exists but is named differently:  
> "python-pam".
>
> Don't be confused by the fact that Debian has a python-pam that is  
> made from different sources! Debian python-pam is a GPL licensed  
> package by Rob Riggs, while Debian python-pampy and Fedora  
> python-pam are the MIT licensed package by Chris AtLee. Fedora 20 is  
> currently behind with V0.1.3 but Fedora 21 will ship with V0.1.4.
>
> Regards
> Bengt

Thanks for pointing that out.

I will start working on our upstream-provided RPMs probably at the end  
of this week or on Monday next week.

Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: Mike Gabriel <[email-masked]>
Date: Thu, 07 Aug 2014 06:41:15 +0000

Hi Bengt,

> currently behind with V0.1.3 but Fedora 21 will ship with V0.1.4.

Is there any chance to get python-pam into Fedora 19? And is there any  
chance to get it into EPEL-6 (and -7)?

Mike
-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

---

From: Orion Poplawski <[email-masked]>
Date: Thu, 07 Aug 2014 15:57:29 -0600

On 08/07/2014 12:41 AM, Mike Gabriel wrote:
>> Fedora nightly RPM for python-x2gobroker has dependency "python-pampy". This
>> package exists but is named differently: "python-pam".
>>
>> Don't be confused by the fact that Debian has a python-pam that is made from
>> different sources! Debian python-pam is a GPL licensed package by Rob Riggs,
>> while Debian python-pampy and Fedora python-pam are the MIT licensed package
>> by Chris AtLee. Fedora 20 is currently behind with V0.1.3 but Fedora 21 will
>> ship with V0.1.4.
>
> Is there any chance to get python-pam into Fedora 19? And is there any chance
> to get it into EPEL-6 (and -7)?
>
> Mike

It already is in F19.

I've requested the current python-pam maintainer for an EPEL-6/7 branch here: 
https://bugzilla.redhat.com/show_bug.cgi?id=982585

Bengt - would you be willing to be the maintainer for it in EPEL if Juan does 
not want it, or a co-maintainer if he does?

-- 
Orion Poplawski
Technical Manager                     303-415-9701 x222
NWRA, Boulder/CoRA Office             FAX: 303-415-9702
3380 Mitchell Lane                       [email-masked]
Boulder, CO 80301                   http://www.nwra.com