Subject: Bug#554: Disable local screensaver when x2go session is in fullscreen mode

From: Reinhard Tartler <[email-masked]>
Date: Sun, 20 Jul 2014 10:56:21 -0400

Package: nxproxy
Severity: serious

I noticed that the when nxproxy is in fullscreen mode, it (by design)
captures all keyboard strokes. This is in general great because this
way all keyboard shortcuts on the remote work.

However, the local screen saver might still kick in and require a
password. Because the nxproxy captures all input, a less carefull user
might enter his local password into the current application that is
running in the x2go session. When the remote application happens to be
a chat application, entering your password might have serious security
implications.

I think a fullscreen nxproxy is a good reason to inhibit the local screensaver.

-- 
regards,
    Reinhard

---

From: Mike Gabriel <[email-masked]>
Date: Mon, 29 Feb 2016 09:16:30 +0000

> I think a fullscreen nxproxy is a good reason to inhibit the local  

This issue has been transferred to Github [1] and it will be further  
processed there.

Greets,
Mike

[1] https://github.com/ArcticaProject/nx-libs/issues/95
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/mailxchange/kronolith/fb.php?u=m.gabriel%40das-netzwerkteam.de

---

From: Stefan Baur <[email-masked]>
Date: Tue, 30 Jan 2024 16:14:41 +0100

Control: close -1
Control: archive -1

This bug has long since been moved to the Arctica Project Github issue 
tracker.

Kind Regards,
Stefan Baur
-- 
BAUR-ITCS UG (haftungsbeschränkt)
Geschäftsführer: Stefan Baur
Eichenäckerweg 10, 89081 Ulm | Registergericht Ulm, HRB 724364
Fon/Fax 0731 40 34 66-36/-35 | USt-IdNr.: DE268653243

---

From: "X2Go Bug Tracking System" <[email-masked]>
Date: Tue, 30 Jan 2024 15:15:02 +0000

Thank you for the additional information you have supplied regarding
this Bug report.

This is an automatically generated reply to let you know your message
has been received.

Your message has not been forwarded to the package maintainers or
other interested parties; you should ensure that the developers are
aware of the problem you have entered into the system - preferably
quoting the Bug reference number, #554.

If you wish to submit further information on this problem, please
send it to [email-masked].

Please do not send mail to [email-masked] unless you wish
to report a problem with the Bug-tracking system.

-- 
554: https://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=554
X2Go Bug Tracking System
Contact [email-masked] with problems

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Tue, 30 Jan 2024 15:15:02 +0000

This is an automatic notification regarding your Bug report
which was filed against the nxproxy package:

#554: Disable local screensaver when x2go session is in fullscreen mode

It has been closed by Stefan Baur <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Stefan Baur <[email-masked]> by
replying to this email.

Subject: Closing/Archiving
From: Stefan Baur <[email-masked]>
To: [email-masked]
Date: Tue, 30 Jan 2024 16:14:41 +0100

Control: close -1
Control: archive -1

Kind Regards,
Stefan Baur

Subject: Disable local screensaver when x2go session is in fullscreen mode
From: Reinhard Tartler <[email-masked]>
To: [email-masked]
Date: Sun, 20 Jul 2014 10:56:21 -0400

Package: nxproxy
Severity: serious

-- 
regards,
    Reinhard