X2Go Bug report logs - #539
Missing fonts in X application

version graph

Package: pyhoca-gui; Maintainer for pyhoca-gui is X2Go Developers <x2go-dev@lists.x2go.org>; Source for pyhoca-gui is src:pyhoca-gui.

Reported by: Stephane Mutz <stephane.mutz@blinksight.com>

Date: Wed, 23 Jan 2013 09:03:01 UTC

Severity: normal

Tags: build-win32

Found in versions 0.5.0.0-pre02, 0.4.0.8

Done: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>

Bug is archived. No further changes may be made.

Full log


Message #15 received at 108@bugs.x2go.org (full text, mbox, reply):

Received: (at 108) by bugs.x2go.org; 27 Jan 2014 02:16:43 +0000
From mikedep333@gmail.com  Mon Jan 27 03:16:42 2014
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=-1.9 required=5.0 tests=BAYES_00,FREEMAIL_FROM,
	T_DKIM_INVALID autolearn=ham version=3.3.2
Received: from mail-we0-f173.google.com (mail-we0-f173.google.com [74.125.82.173])
	by ymir (Postfix) with ESMTPS id 45EBF5DB13
	for <108@bugs.x2go.org>; Mon, 27 Jan 2014 03:16:42 +0100 (CET)
Received: by mail-we0-f173.google.com with SMTP id t60so4618756wes.4
        for <108@bugs.x2go.org>; Sun, 26 Jan 2014 18:16:42 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=gmail.com; s=20120113;
        h=mime-version:date:message-id:subject:from:to:content-type;
        bh=0w3WIq7e8faFtxbHyMuAaikrV6OhF7cB6npHeo4yjKc=;
        b=IiNQOLLa3W0Jal0+gKwh5CqyecEUA/PhSI3mFgYPrW9mCF7o+i1Lx2Zup1dgpmZq0K
         P9KvvMxl9mR+FdCzbM9nNRCA4DEmoKuoJgl3NoAziGBbdrg/CgOxaveb1hgWZtFMjQ3e
         FyUQJVcGfCM3lhXmsiens0kzhEE/K0PR4qg0uRZeOQKaQMdTULsLUgSXSiipaUUfy/0C
         FiTOVn8AwVq2IERRzcM4h/2YqBf65BfQJHdqfNJET1yhckOvGgIz71iqJAJX0SFsqTKi
         vZYII+Abo/ptVBohswb7kIKt2PYi1ECQc9YRdXVMc1yMa/VdAxsAJ1bfs21qqUAPAsTp
         hanw==
MIME-Version: 1.0
X-Received: by 10.180.21.244 with SMTP id y20mr10284057wie.37.1390789001924;
 Sun, 26 Jan 2014 18:16:41 -0800 (PST)
Received: by 10.180.82.227 with HTTP; Sun, 26 Jan 2014 18:16:41 -0800 (PST)
Date: Sun, 26 Jan 2014 21:16:41 -0500
Message-ID: <CAMKht8hCeAXbW7OYqf8b+6d+f-um8NOxd+k6M_y_5m1UM_4uuw@mail.gmail.com>
Subject: Re: [X2Go-Dev] Bug#108: Missing fonts in X application
From: Michael DePaulo <mikedep333@gmail.com>
To: 108@bugs.x2go.org
Content-Type: text/plain; charset=ISO-8859-1
Hi Stephane, I'm the new Win32 package maintainer for X2Go Client.

I see that you worked around this issue by copying over VcXsrv's fonts folder:
https://lists.berlios.de/pipermail/x2go-user/2013-January/001253.html

I've experienced this bug too with ClearCase 8.0.0's "xclearcase" GUI.
It is a very old UNIX/Linux GUI and it uses motif.

My successful workaround was to both install a bunch of fonts packages
server-side (including international fonts,) and to copy over the
fonts directory.

Still, I believe that we should take the same approach that NX did and
provide a seperate setup.exe containing the extra fonts. Unless there
are any objections, that will officially be on my to do list as the
win32 package maintainer.

Note that I do not want to include the fonts in the main X2Go Client
setup.exe because:
1. They are 4,673 files, which would add a lot to the installation time
2. They are 32MB compressed with 7-zip, so they would add that much
space or more. (X2goclient 4.0.1.3's setup .exe is only 23MB).

For reference to others who need to copy fonts:
- X2Go Client 4.0.0.3 uses VcXsrv 1.12.0.1
- X2Go Client 4.0.1.2 and 4.0.1.3 use VcXsrv 1.14.2.1.

-Mike#2


Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Sun Oct 20 11:21:55 2019; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.