Subject: X2Go crashes X on SL6.4 from SL6.4 client

From: "James M. Pulver" <[email-masked]>
Date: Tue, 1 Jul 2014 11:44:53 +0000

Package: nxagent
Version: X2Go 4.0.2.0

The issue is that, after xterm window is launched, any attempt to use the keyboard in that xterm causes the xserver to die and the x2go session to terminate.  This happens with emacs as well.  Both tested while using the icewm-session desktop.  The x2go program doesn't crash.

The errors in .xsession-errors file are:

Window manager warning: Invalid WM_TRANSIENT_FOR window 0x7800011 specified for 0x780000f (X2Go - 61).

Window manager warning: Invalid WM_TRANSIENT_FOR window 0x7800011 specified for 0x780000f (X2Go - 71).

Window manager warning: Invalid WM_TRANSIENT_FOR window 0x740001f specified for 0x7400626 (Error).

Window manager warning: Invalid WM_TRANSIENT_FOR window 0x7800011 specified for 0x780000f (X2Go - 76).

Window manager warning: Invalid WM_TRANSIENT_FOR window 0x7800011 specified for 0x780000f (X2Go - 79).

Coredump attached.
On Scientific Linux 6.4

--
James Pulver
CLASSE Computer Group
Cornell University

---

From: Mike Gabriel <[email-masked]>
Date: Tue, 01 Jul 2014 21:43:29 +0000

Hi James,

> The issue is that, after xterm window is launched, any attempt to  
> use the keyboard in that xterm causes the xserver to die and the  
> x2go session to terminate.  This happens with emacs as well.  Both  
> tested while using the icewm-session desktop.  The x2go program  
> doesn't crash.
>

Please let us know what xkeyboard version you have (not sure about the  
package name on RHEL).

Also, please look up the version of the package nxagent.

Thanks,
Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: Mike Gabriel <[email-masked]>
Date: Thu, 03 Jul 2014 20:00:59 +0000

Control: tag -1 not-a-bug
Control: close -1

Hi James,

On  Do 03 Jul 2014 19:31:09 CEST, James M. Pulver wrote:

> We actually tracked this down (finally) and the problem was fixed by  
> removing “export LD_LIBRARY_PATH=/some/user/installed/lib” from  
> ~/.bashrc ...
> --
> James Pulver
> CLASSE Computer Group
> Cornell University

ok. Thanks for notifying us... Closing and tagging issue as "not-a-bug".

Mike

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy: