Subject: Auto log-in (ssh-agent) doesn't work since 4.0.1.2

From: Ilia Shakitko <[email-masked]>
Date: Thu, 5 Jun 2014 12:58:48 +0200

Package: X2Go Client
Version: 4.0.1.2+

I was using 4.0.0.3 version of X2Go Client with 'auto log-in (ssh-agent)'
option using. So basically I have my pageant ssh-agent (Windows 7) running
with a key.

I could connect to my host with X2Go. But once I tried the last version
(4.0.2.0) - it didn't work. It pops up a window dialog with 'enter the
passphrase for the key'. And whatever I write - it doesn't accept. If I
click cancel (or just after a number of failed attemps) I am getting an
empty error window dialog.

I still can connect all other tools (like Putty, Mysql GUI, etc...) using
ssh-agent.

I've also tried all of the available versions between 4.0.0.3 and the
latest one.

4.0.0.3 - works
4.0.1.2 - from this version and higher - it doesn't

-- 
Best regards
Ilia Shakitko
primary     tel. +31-6-86423406
skype: svscorp
LinkedIn:   http://ru.linkedin.com/in/shakitko
Facebook: http://www.facebook.com/shakitko

---

From: Michael DePaulo <[email-masked]>
Date: Tue, 10 Jun 2014 08:49:51 -0400

Hi Ilia.

I've tested 4.0.2.0 and 4.0.2.1-2014.06.10. I think that this bug only
happens when both of these conditions are met:
- You have a key specified in: Use RSA/DSA key for ssh connection
- You have enabled: Try auto login (ssh-agent or default ssh key)

Obviously this is a bug. But can you confirm what I observed?

-Mike

---

From: Michael DePaulo <[email-masked]>
Date: Tue, 10 Jun 2014 08:55:29 -0400

Also, note bug #448:
http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=448

The bug was fixed in the actual release of 4.0.2.0. (Stefan reported
it present in the nightly builds of 4.0.2.0 at the time.)

Long story short, pageant/ssh-agent auth is broken completely in
4.0.1.3 & 4.0.1.3+build2 for Windows.

On Tue, Jun 10, 2014 at 8:50 AM, X2Go Bug Tracking System
<[email-masked]> wrote:
> Thank you for the additional information you have supplied regarding
> this Bug report.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
>  [email-masked]
>
> If you wish to submit further information on this problem, please
> send it to [email-masked].
>
> Please do not send mail to [email-masked] unless you wish
> to report a problem with the Bug-tracking system.
>
> --
> 512: http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=512
> X2Go Bug Tracking System
> Contact [email-masked] with problems