Subject: Fwd: [Bug 1098201] New: [abrt] pyhoca-gui: _file.py:330:to_profile_id:X2GoProfileException: The sessions config file contains multiple session profiles with name: nbecker7

From: Orion Poplawski <[email-masked]>
Date: Thu, 15 May 2014 10:55:45 -0600

Package: python-x2go
Version: 0.4.0.9

Seems like a couple issues:
- pyhoca-gui shouldn't emit a traceback
- How to handle multiple session profiles with the same name?
- Is x2goclient allowing that to happen?

-------- Original Message --------
Subject: [Bug 1098201] New: [abrt] pyhoca-gui: 
_file.py:330:to_profile_id:X2GoProfileException: The sessions config file 
contains multiple session profiles with name: nbecker7
Date: Thu, 15 May 2014 13:16:18 +0000
From: [email-masked]
To: [email-masked]

https://bugzilla.redhat.com/show_bug.cgi?id=1098201

             Bug ID: 1098201
            Summary: [abrt] pyhoca-gui:
                     _file.py:330:to_profile_id:X2GoProfileException: The
                     sessions config file contains multiple session
                     profiles with name: nbecker7
            Product: Fedora
            Version: 20
          Component: pyhoca-gui
           Assignee: [email-masked]
           Reporter: [email-masked]
         QA Contact: [email-masked]
                 CC: [email-masked]

Description of problem:
1st time trying pyhoca-gui (have used x2goclient before)
On icon in tray, left click, then try to connect to existing session

Version-Release number of selected component:
pyhoca-gui-0.4.0.9-1.fc20

Additional info:
reporter:       libreport-2.2.2
cmdline:        pyhoca-gui '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' ''
dso_list:       python-x2go-0.4.0.9-1.fc20.noarch
executable:     /usr/bin/pyhoca-gui
kernel:         3.14.3-200.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
_file.py:330:to_profile_id:X2GoProfileException: The sessions config file
contains multiple session profiles with name: nbecker7

Traceback (most recent call last):
   File "/usr/lib/python2.7/site-packages/pyhoca/wxgui/frontend.py", line 784,
in OnSessionAuthenticate
     if self.session_profiles.get_profile_config(profile_name)['directrdp']:
   File "/usr/lib/python2.7/site-packages/x2go/backends/profiles/_file.py", line
213, in get_profile_config
     _profile_id = profile_id or
self.check_profile_id_or_name(profile_id_or_name)
   File "/usr/lib/python2.7/site-packages/x2go/backends/profiles/_file.py", line
456, in check_profile_id_or_name
     _profile_id = self.to_profile_id(profile_id_or_name)
   File "/usr/lib/python2.7/site-packages/x2go/backends/profiles/_file.py", line
330, in to_profile_id
     raise X2GoProfileException('The sessions config file contains multiple
session profiles with name: %s' % profile_name)
X2GoProfileException: The sessions config file contains multiple session
profiles with name: nbecker7

Local variables in innermost frame:
_profile_ids: ['20131224085249847', '20140403135324010']
self: X2GoIniFile(_cached_profile_ids=['20131224085249847',
'20140403135324010', '20140416095719622'],_cached_profile_names=[u'New
session', u'nbecker7', u'nbecker7'],_profile_metatypes={'20140416095719622':
u'KDE Desktop', '20131224085249847': u'KDE Desktop', '20140403135324010': u'KDE
Desktop'},_profiles_need_profile_id_renewal=[],config_files=['/home/nbecker/.x2goclient/sessions'],defaultValues={},iniConfig=<ConfigParser.SafeConfigParser
instance at 0x239ccf8>,logger=<x2go.log.X2GoLogger object at
0x239e5d0>,session_profiles=['20131224085249847', '20140403135324010',
'20140416095719622'],user_config_file=/home/nbecker/.x2goclient/sessions)
profile_name: u'nbecker7'
p: '20140416095719622'

-- 
You are receiving this mail because:
You are on the CC list for the bug.
You are the assignee for the bug.

---

From: Mike Gabriel <[email-masked]>
Date: Fri, 16 May 2014 11:53:23 +0000

Control: retitle -1 Allow multiple session profiles to have the same  
name (for being compatible with X2Go Client)

Hi Orion,

On  Do 15 Mai 2014 18:55:45 CEST, Orion Poplawski wrote:

> _file.py:330:to_profile_id:X2GoProfileException: The sessions config  
> file contains multiple session profiles with name: nbecker7
>   File  
> "/usr/lib/python2.7/site-packages/x2go/backends/profiles/_file.py",  
> line
>   File  
> "/usr/lib/python2.7/site-packages/x2go/backends/profiles/_file.py",  
> line
>   File  
> "/usr/lib/python2.7/site-packages/x2go/backends/profiles/_file.py",  
> line
> 330, in to_profile_id

I have had a discussion with Alex about this recently, as well. X2Go  
Client allows session profiles that bear the same name, whereas  
PyHoca-GUI (Python X2Go) does not.

I will see how that can be changed in Python X2Go internally...

Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb