Subject: Fwd: [Bug 1097757] New: [abrt] x2goclient: QString(): x2goclient killed by SIGSEGV

From: Orion Poplawski <[email-masked]>
Date: Wed, 14 May 2014 08:53:20 -0600

Package: x2goclient
Version: 4.0.2.0

Looks like:

#1  id (this=0x0) at ../sessionbutton.h:39
No locals.
#2  ONMainWindow::slotSuspendSess (this=this@entry=0x1ad1ab0) at 
../onmainwindow.cpp:4620

             X2goSettings st ( "sessions" );
             QString sid=lastSession->id();

lastSession is null and not being checked.  Probably applies to other parts of 
the code as well.

-------- Original Message --------
Subject: [Bug 1097757] New: [abrt] x2goclient: QString(): x2goclient killed by 
SIGSEGV
Date: Wed, 14 May 2014 13:12:55 +0000
From: [email-masked]
To: [email-masked]

https://bugzilla.redhat.com/show_bug.cgi?id=1097757

             Bug ID: 1097757
            Summary: [abrt] x2goclient: QString(): x2goclient killed by
                     SIGSEGV
            Product: Fedora
            Version: 20
          Component: x2goclient
           Assignee: [email-masked]
           Reporter: [email-masked]
         QA Contact: [email-masked]
                 CC: [email-masked]
              Group: fedora_contrib_private

Description of problem:
clicked on grayed-out resume button, or something like that

Version-Release number of selected component:
x2goclient-4.0.2.0-1.fc20

Additional info:
reporter:       libreport-2.2.2
backtrace_rating: 4
cmdline:        /usr/bin/x2goclient
crash_function: QString
executable:     /usr/bin/x2goclient
kernel:         3.14.2-200.fc20.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
  #0 QString at /usr/include/QtCore/qstring.h:725
  #1 id at ../sessionbutton.h:39
  #2 ONMainWindow::slotSuspendSess at ../onmainwindow.cpp:4620
  #3 ONMainWindow::slotResumeSess at ../onmainwindow.cpp:4526
  #4 ONMainWindow::slotResumeDoubleClick at ../onmainwindow.cpp:6005
  #5 ONMainWindow::qt_static_metacall at moc_onmainwindow.cpp:399
  #6 QMetaObject::activate at kernel/qobject.cpp:3567
  #7 QAbstractItemView::activated at
.moc/release-shared/moc_qabstractitemview.cpp:361
  #8 QAbstractItemView::mouseReleaseEvent at
itemviews/qabstractitemview.cpp:1821
  #9 QWidget::event at kernel/qwidget.cpp:8389

-- 
You are receiving this mail because:
You are on the CC list for the bug.
You are the assignee for the bug.

---

From: Mihai Moldovan <[email-masked]>
Date: Wed, 1 Mar 2017 08:18:30 +0100

> lastSession is null and not being checked.  Probably applies to other parts of 

I don't know if that's still a problem, since the session manager/explorer
feature was added in the meantime, but I've tried to add guards to most
locations, except where it was obvious that getLastSession() must return
non-NULL because we already checked it before.

Should it ever actually be NULL, at least it shouldn't crash (at this point) any
longer, but I admit that I don't know how the client behaves when just returning
out of these functions without doing its work.

Mihai