Subject: X2Go issue (in src:nx-libs) has been marked as closed

From: Mike Gabriel <[email-masked]>
Date: Mon, 30 Jun 2014 14:24:34 +0200 (CEST)

close #490
thanks

Hello,

we are very hopeful that X2Go issue #490 reported by you
has been resolved in the new release (2:3.5.0.25) of the
X2Go source project »src:nx-libs«.

You can view the complete changelog entry of src:nx-libs (2:3.5.0.25)
below, and you can use the following link to view all the code changes
between this and the last release of src:nx-libs.

    http://code.x2go.org/gitweb?p=nx-libs.git;a=commitdiff;h=be23e057f28a6624380a91d1ba36cbf5df6c3fff;hp=460a3cb3911bbfb717d0259947fe05f68d964948

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:nx-libs.

Thanks a lot for contributing to X2Go!!!

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
X2Go Component: src:nx-libs
Version: 2:3.5.0.25-0x2go1
Status: RELEASE
Date: Mon, 30 Jun 2014 14:05:46 +0200
Fixes: 40 339 490 504 505 515 516
Changes: 
 nx-libs (2:3.5.0.25-0x2go1) RELEASED; urgency=low
 .
   [ Mihai Moldovan ]
   * Add 029_nxcomp_ppc64.full+lite.patch. Fix sockaddr handling on
     Big Endian systems (like PPC64). (Fixes: #515).
   * Add 057_nx-X11_sanitize-eventmasks.full.patch. Fix
     failures in session windows coming up on Big Endian systems
     like PPC64. (Fixes: #516).
   * Improve 105_nxagent_export-remote-keyboard-config.full.patch.
     Don't print out nonsensical information, if there really was
     no error when creating the keyboard file or the other way around.
     Also add the reason when failing to create the keyboard file.
     Only print an error message if SessionPath *really* is not defined.
   * Improve 028_nx-X11_abstract-kernel-sockets.full.patch. Make it more
     Big Endian robust by assigning correct types for socklen_t objects.
   * Add 990_fix-DEBUG-and-TEST-builds.full.patch. Fix debug builds (e.g.
     when globally setting -DDEBUG and -DTEST at build time).
 .
   [ Nito Martínez ]
   * Add 212_nxcomp_build-on-Android.patch. Fix FTBFS of nxproxy/nxcomp when
     build against the Android system. (Fixes: #339).
 .
   [ Oleksandr Shneyder ]
   * Add 210_nxagent_nxcomp_save_session_state.full+lite.patch. Save session
     state in path specified by "state" option in agent options file. If
     option is omitted, session state will not be saved. Session states are:
     STARTING, RUNNING, SUSPENDING, SUSPENDED, RESUMING, TERMINATING,
     TERMINATED.
   * Add 211_nxcomp_set_default_options.full+lite.patch. Set default arguments
     for options 'link' and 'pack' to avoid session damage by resuming with
     incorrect options file.
 .
   [ Mike Gabriel ]
   * Add 606_nx-X11_build-on-aarch64.full.patch. Build on aarch64
     architectures. (Fixes: #490).
   * Add 027_nxcomp_abstract-X11-socket.full+lite.patch. In proxy mode "server"
     let NX proxy attempt connecting to the abstract X11 socket first, and only
     fallback to the file system socket, if the abstract socket is not
     available. (Fixes: #505).
   * Add 028_nx-X11_abstract-kernel-sockets.full.patch. Provide abstract local
     socket support for Linux based systems. This patch pulls in abstract
     socket relevant code from xtrans 1.2.7. (Fixes: #504).
   * Add 302_nx-X11_xkbbasedir-detection.patch. For detecting XkbBaseDir
     test for xkb/rules/base instead of testing for deprecated file
     xkb/keymap.dir. (Fixes: #40).
   * Add 206_nxagent_clipboard-as-nxoption.full.patch. Make the clipboard
     option configurable in nxagent via NX options as addition to the
     command line parameter -clipboard. Note that the command line
     parameter overrides the clipboard NX option. Possible values are
     both or 1, client, server, none or 0.
 .
   * Update patches, to make them apply cleanly after above changes:
     + 220_nxproxy-bind-loopback-only.full+lite.patch
     + 016_nx-X11_install-location.debian.patch
     + 056_nx-X11-Werror-format-security.full.patch
     + 108_nxagent_wine-close-delay.full.patch
     + 300_nxagent_set-wm-class.full.patch
     + 320_nxagent_configurable-keystrokes.full.patch
 .
   * Rename patches to match our naming scheme:
     + 008_nxcomp_sa-restorer.full+lite.patch
     + 009_nxagent_add-man-page.full.patch
     + 009_nxproxy_add-man-page.full+lite.patch
     + 056_nx-X11_Werror-format-security.full.patch
     + 209_x2goagent_add-man-page.full.patch
     + 220_nxproxy_bind-loopback-only.full+lite.patch

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Mon, 30 Jun 2014 12:25:12 +0000

This is an automatic notification regarding your Bug report
which was filed against the nx-libs package:

#490: Attempt at aarch64 support

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go issue (in src:nx-libs) has been marked as closed
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Mon, 30 Jun 2014 14:24:34 +0200 (CEST)

close #490
thanks

Hello,

light+love

---

Subject: Attempt at aarch64 support
From: Orion Poplawski <[email-masked]>
To: [email-masked]
Date: Wed, 07 May 2014 20:43:35 -0600

Package: nx-libs
Version: 3.5.0.24
Tags: patch

This is quick hack attempt at aarch64 support.  It allows nx-libs to
compile, but I have nothing to test on and I suspect it may be
incorrect, but it's a start.

-- 
Orion Poplawski
Technical Manager                     303-415-9701 x222
NWRA/CoRA Division                    FAX: 303-415-9702
3380 Mitchell Lane                  [email-masked]
Boulder, CO 80301              http://www.cora.nwra.com
diff -up nx-libs-3.5.0.24/nx-X11/config/cf/Imake.cf.aarch64 nx-libs-3.5.0.24/nx-X11/config/cf/Imake.cf
--- nx-libs-3.5.0.24/nx-X11/config/cf/Imake.cf.aarch64	2014-05-07 01:56:12.000000000 -0600
+++ nx-libs-3.5.0.24/nx-X11/config/cf/Imake.cf	2014-05-07 19:27:07.748795509 -0600
@@ -908,6 +908,9 @@ XCOMM Keep cpp from replacing path eleme
 #  endif
 #  undef __ARMEB__
 # endif
+# ifdef __aarch64__
+#  define Arm64Architecture
+# endif
 # ifdef mc68000
 #  define Mc68020Architecture
 #  undef mc68000
diff -up nx-libs-3.5.0.24/nx-X11/config/cf/linux.cf.aarch64 nx-libs-3.5.0.24/nx-X11/config/cf/linux.cf
--- nx-libs-3.5.0.24/nx-X11/config/cf/linux.cf.aarch64	2014-05-07 02:00:04.000000000 -0600
+++ nx-libs-3.5.0.24/nx-X11/config/cf/linux.cf	2014-05-07 19:28:17.823777953 -0600
@@ -844,6 +844,16 @@ InstallNamedTargetNoClobber(install,file
 # define ServerExtraDefines	-DGCCUSESGAS XFree86ServerDefines
 #endif /* Arm32Achitecture */
 
+#ifdef Arm64Architecture
+# define DefaultCCOptions
+# ifndef OptimizedCDebugFlags
+#  define OptimizedCDebugFlags	-O3
+# endif
+# define LinuxMachineDefines	-D__aarch64__ -U__arm -Uarm
+# define ServerOSDefines	XFree86ServerOSDefines -DDDXTIME
+# define ServerExtraDefines	-DGCCUSESGAS XFree86ServerDefines
+#endif /* Arm64Achitecture */
+
 #ifdef HPArchitecture
 # define OptimizedCDebugFlags	-O2  GccAliasingArgs
 # define LinuxMachineDefines	-D__hppa__
diff -up nx-libs-3.5.0.24/nx-X11/config/cf/Imake.tmpl.aarch64 nx-libs-3.5.0.24/nx-X11/config/cf/Imake.tmpl
--- nx-libs-3.5.0.24/nx-X11/config/cf/Imake.tmpl.aarch64	2014-05-07 02:00:04.000000000 -0600
+++ nx-libs-3.5.0.24/nx-X11/config/cf/Imake.tmpl	2014-05-07 19:59:05.266769630 -0600
@@ -526,6 +526,10 @@ XCOMM the platform-specific parameters -
 #define ByteOrder		X_BIG_ENDIAN
 #elif defined(Arm32Architecture)
 #define ByteOrder		X_LITTLE_ENDIAN
+#elif defined(Arm64ebArchitecture)
+#define ByteOrder		X_BIG_ENDIAN
+#elif defined(Arm64Architecture)
+#define ByteOrder		X_LITTLE_ENDIAN
 #elif defined(RsArchitecture)
 #define ByteOrder		X_BIG_ENDIAN
 #elif defined(PpcArchitecture) || defined(Ppc64Architecture)
diff -up nx-libs-3.5.0.24/nx-X11/programs/Xserver/include/servermd.h.aarch64 nx-libs-3.5.0.24/nx-X11/programs/Xserver/include/servermd.h
--- nx-libs-3.5.0.24/nx-X11/programs/Xserver/include/servermd.h.aarch64	2014-05-07 01:56:12.000000000 -0600
+++ nx-libs-3.5.0.24/nx-X11/programs/Xserver/include/servermd.h	2014-05-07 19:55:11.760395141 -0600
@@ -154,6 +154,28 @@ SOFTWARE.
 
 #endif /* __arm32__ */
 
+#ifdef __aarch64__
+
+#ifdef __AARCH64EL__
+#define IMAGE_BYTE_ORDER        LSBFirst
+#define BITMAP_BIT_ORDER        LSBFirst
+#endif
+#ifdef __AARCH64EB__
+#define IMAGE_BYTE_ORDER        MSBFirst
+#define BITMAP_BIT_ORDER        MSBFirst
+#endif
+
+# if defined(XF86MONOVGA) || defined(XF86VGA16)
+#  define BITMAP_SCANLINE_UNIT  8
+# endif
+
+#define GLYPHPADBYTES           4
+#define GETLEFTBITS_ALIGNMENT   1
+#define LARGE_INSTRUCTION_CACHE
+#define AVOID_MEMORY_READ
+
+#endif /* __aarch64__ */
+
 #if defined (hpux) || defined __hppa__
 
 #define IMAGE_BYTE_ORDER	MSBFirst