Subject: Bug#49: Reported wine issue on Ubuntu oneiric not related to X2Go

From: Mike Gabriel <[email-masked]>
Date: Sun, 21 Oct 2012 20:38:19 +0200

reassign #49 not-a-bug
tags #49 not-a-bug
close #49
thanks

Hi Matthias,

your reported issue is definitely not related to X2Go or any of its  
components (as you already admitted in one of your earlier posts).

I have tested wine on Ubuntu precise and it works flawlessly inside  
X2Go sessions (latest packages in use).

Greets,
Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, rothenstein 5, 24214 neudorf-bornstein
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Sun, 21 Oct 2012 18:48:02 +0000

This is an automatic notification regarding your Bug report
which was filed against the not-a-bug package:

#49: wine does not start within x2goclient: Application tried to create a window, but no driver could be loaded.

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: Reported wine issue on Ubuntu oneiric not related to X2Go
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Sun, 21 Oct 2012 20:38:19 +0200

reassign #49 not-a-bug
tags #49 not-a-bug
close #49
thanks

Hi Matthias,

Greets,
Mike

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

Subject: wine does not start within x2goclient: Application tried to create a window, but no driver could be loaded.
From: Matthias Hellinghausen <[email-masked]>
To: [email-masked]
Date: Thu, 18 Oct 2012 16:10:04 +0200

Package: x2goserver 3.1.1.3-0~571~oneiric1, x2goagent  2:3.5.0.14-0~247~oneiric1

Hello

After upgrading the x2goserver from the following Version

x2goagent      2:3.5.0.14-0~247~oneiric1
x2goserver     3.1.1.3-0~571~oneiric1

to

x2goagent     2:3.5.0.15-0~263~oneiric1
x2goserver    3.1.1.4-0~592~oneiric1

wine (v. 1.2.3) programs do not start anymore within the x2goclient session.

The following is what wine tells us when starting notepad:

mh@ltsp3:~$ notepad
Application tried to create a window, but no driver could be loaded.
Unknown error (998).
err:systray:initialize_systray Could not create tray window
Application tried to create a window, but no driver could be loaded.
Unknown error (998).

All other X-applications are working fine. The version of the x2goclient
did not change.

please let me know, If there is anything more you need to know...

kind regards
Matthais

-- 
Dipl.-Ing.(FH)  Matthias Hellinghausen
EDV-Abteilung
BZD Gesellschaft f. Transfusionsmedizin Duisburg mbH
Königstrasse 63 - 47051 Duisburg

Tel.:    +49 (0) 203 - 300 95 8557
Fax:     +49 (0) 203 - 300 95 8564
Email:   [email-masked]

Sitz der Gesellschaft: Duisburg
Amtsgericht Duisburg HRB 4273
Geschäftsführung: Sybille Trobisch, Olaf Frahm

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Mon, 22 Oct 2012 11:18:01 +0000

Thank you for the additional information you have supplied regarding
this Bug report.

This is an automatically generated reply to let you know your message
has been received.

Your message has not been forwarded to the package maintainers or
other interested parties; you should ensure that the developers are
aware of the problem you have entered into the system - preferably
quoting the Bug reference number, #49.

If you wish to submit further information on this problem, please
send it to [email-masked].

Please do not send mail to [email-masked] unless you wish
to report a problem with the Bug-tracking system.

-- 
49: http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=49
X2Go Bug Tracking System
Contact [email-masked] with problems

---

From: Mike Gabriel <[email-masked]>
Date: Mon, 22 Oct 2012 13:29:42 +0200

reopen #49
reassign #49 x2goagent
retitle #49 Xinerama patch in nx-libs maybe breaks wine1.4
severity #49 minor
thanks

Hi Matthias,

On Mo 22 Okt 2012 13:07:10 CEST Matthias Hellinghausen wrote:

> Then I found out that the LD_LIBRARY_PATH in the x2go Session is set  
> to "/usr/lib/nx/X11/Xinerama:/usr/lib/nx/X11".
>
> When I unset the LD_LIBRARY_PATH or remove  
> "/usr/lib/nx/X11/Xinerama", wine 1.2.3 works again on the  
> LTSP-servers!
>
> (...but it also works with wine version 1.3 and the library path set  
> to Xinerama...)
>
> So there must be a Problem with a Setup of 32 Bit, wine 1.2.3 and  
> Xinerama...!?
>
> Is it possible that the library path was not set within the  
> x2go-session before?  Is there a special reason that the  
> LD_LIBRARY_PATH ist set at all?
>
> thanks in advance.
>
> kind regards
> Matthias

Ahhh... ok... the LD_LIBRARY_PATH indeed has been added (actually, it  
should have been there for  a while, refer to http://bugs.x2go.org/29).

Hmmm... so our xinerama add-on on top of nx-libs breaks Wine 1.4. This  
is not so nice.

Hopefully you can provide more debugging and info.

I have Cc:ed Alex who is the author of the Xinerama patch in nx-libs.

Greets,
Mike

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy: